Subject: FW: Call for implementation experience on RFC 2558: SONET MIB

From: "Nolish, Kevin" <[email-masked]>
Date: Fri, 19 Oct 2001 16:19:38 -0400

Faye,

Here is Marconi's implementation experience for 2558/1595.

> -----Original Message-----
> From: Faye Ly [mailto:[email-masked]]
> Sent: Wednesday, September 12, 2001 2:31 PM
> To: [email-masked]
> Subject: Call for implementation experience on RFC 2558: SONET MIB
> 
> 
> Hi,
> 
> The chairs of the AToMMIB working group would like to issue another
> implementation experience call on RFC 2558: SONET/SDH MIB.
> 
> We didn't receive any report from the last call and your help will
> be greatly appreciated.  Please repond to [email-masked] or
> directly to the list.
> 
> We are specically looking for:
> 
> 1. Have you implemented RFC 2558/1595?

Yes, we have

> 2. If yes, what is the implemented objects/tables compared to the
> attached compliance statements? 

See comments in the attached compliance statements and some concluding
comments on information that we included in proprietary extensions.

> 3. Are you willing to publish the name of your company in the
> implementation experience report?
> 

Sure

> Again thank you very much for your help in advancing the RFC to
> the Draft Standard.
> 
> sonetCompliance2 MODULE-COMPLIANCE
>     STATUS  current
>     DESCRIPTION
>             "The compliance statement for SONET/SDH interfaces."
> 
>     MODULE  -- this module
>         MANDATORY-GROUPS { sonetMediumStuff2, sonetSectionStuff2 }
> 
>         OBJECT      sonetMediumType
>         MIN-ACCESS  read-only
>         DESCRIPTION
>             "Write access is not required."
> 

Generally, we support read-write.  However, there are a small number of
SDH-only or SONET-only netmods that do not allow this to be configured.

>         OBJECT      sonetMediumLineCoding
>         MIN-ACCESS  read-only
>         DESCRIPTION
>             "Write access is not required."
> 

read-only

>         OBJECT      sonetMediumLineType
>         MIN-ACCESS  read-only
>         DESCRIPTION
>             "Write access is not required."
> 

read-only

>         OBJECT      sonetMediumCircuitIdentifier
>         MIN-ACCESS  read-only
>         DESCRIPTION
>             "Write access is not required."
> 

read-only

>         OBJECT      sonetMediumLoopbackConfig
>         MIN-ACCESS  read-only
>         DESCRIPTION
>             "Write access is not required."
> 

read-write, although not all hardware implementations support all values.

>         OBJECT      sonetSESthresholdSet
>         MIN-ACCESS  read-only
>         DESCRIPTION
>           "Write access is not required, and only one
>           of the enumerated values need be supported."
> 

read-only

>         GROUP       sonetLineStuff2
>         DESCRIPTION
>             "Implementation of this group is mandatory for all
>              SONET/SDH systems that terminate SONET/SDH Lines,
>              Paths or Virtual Tributaries."
> 

Supported

>         GROUP       sonetFarEndLineStuff2
>         DESCRIPTION
>             "Implementation of this group is optional for all
>              SONET/SDH systems that terminate SONET/SDH Lines,
>              Paths or Virtual Tributaries, and that
>              provide for a far end block error (FEBE)
>              information at the SONET/SDH Line Layer."
> 

Supported

>         GROUP       sonetPathStuff2
>         DESCRIPTION
>             "Implementation of this group is mandatory for all
>              SONET/SDH systems that terminate SONET/SDH
>              Paths or Virtual Tributaries."
> 

Supported

>         OBJECT      sonetPathCurrentWidth
>         MIN-ACCESS  read-only
>         DESCRIPTION
>             "Write access is not required."
> 

read-only

Note - Writing to this variable to configure multiple sonet paths on a sonet
interface is not sufficient to completely specify a path configuration.
Consider an STS-12 composed of both STS-1 and STS-3 paths.  Besides stacking
the path objects on top of the low level if and configuring the path width,
each path must be configured with the timeslots occupied by in within the
STS-12.  The current mib has no mechanism for specifying the time slots used
by a path.

>         GROUP       sonetFarEndPathStuff2
>         DESCRIPTION
>             "Implementation of this group is optional for all
>              SONET/SDH systems that terminate SONET/SDH
>              Paths or Virtual Tributaries, and that process
>              Far End information."
> 

implemented

>         GROUP       sonetVTStuff2
>         DESCRIPTION
>             "Implementation of this group is mandatory for all
>              SONET/SDH systems that terminate SONET/SDH Virtual
>              Tributaries."
> 
> 

implemented

> 
> Tesink                      Standards Track                   
>  [Page 58]
> > 
> RFC 2558                   SONET/SDH Objects                  
> March 1999
> 
> 
>         OBJECT      sonetVTCurrentWidth
>         MIN-ACCESS  read-only
>         DESCRIPTION
>             "Write access is not required."
> 

read-only.

We decided that a proprietary extension was necessary to support
configuration changes.  Changing the width of a single VT doesn't map well
to the configuration changes that acutally need to be done in hardware to
support dynamically sized Virtual Tributaries.  

In Sonet and SDH all VTs within a group must be the same width.
Furthermore, as the bandwidth of the group is fixed, changing the vt width
will necessarily change the number of VTs to the group. 

We have a table with entries for all 7 groups in each VT Structured Sonet
Path.  We change the VT size for all vts in a group by modifying the group
width attribute.  This was cleaner to implement as changing the width of a
VT will require the addition or deletion of VTs to or from the group.

>         GROUP       sonetFarEndVTStuff2
>         DESCRIPTION
>             "Implementation of this group is optional for all
>              SONET/SDH systems that terminate the SONET/SDH
>              floating Virtual Tributaries, and that process
>              Far End information."
> 
>     ::= { sonetCompliances 2 }
> 

implemented

> 
> Faye Ly
> Senior System Architect
> Salira Optical Network Systems
> 2698 Orchard Parkway
> San Jose, CA 95134
> (408)325-8700 X116 
>

---

From: Sharon Mantin <[email-masked]>
Date: Mon, 22 Oct 2001 10:35:24 +0200

Faye,

Here is Corrigent's implementation experience for 2558/1595.

Best regards, 

Sharon Mantin
System engineer

Corrigent Systems
Main Tel  : 972-3-6952727
Direct Tel : 972-3-6948608
Fax : 972-3-6953222
Email: [email-masked]

Yes, we have

> attached compliance statements? 

See comments in the attached compliance.
 
> implementation experience report?

Yes

>             "Write access is not required."

read-write.

read-only

read-only

>             "Write access is not required."

read-write

>             "Write access is not required."

read-write.

>           of the enumerated values need be supported."

read-write, but only part of the available options are supported. 

Supported

Supported

Supported

read-only

Note - This object is display path type which has been configured in a
proprietary MIB table. This table is used to configure multiple sonet paths
on a sonet
interface.Besides stacking the path objects on top of the Line interface and
configuring the path type, each path must be configured with the timeslots
occupied by in within the Line. 
The current mib has no mechanism for specifying the time slots used
by a path. 

implemented

>              SONET/SDH systems that terminate SONET/SDH Virtual

Not implemented

>             "Write access is not required."

NA 

>     ::= { sonetCompliances 2 }

NA implemented