Subject: Re: query regarding RFC2558

From: Kaj Tesink <[email-masked]>
Date: Fri, 22 Mar 2002 09:20:05 -0500

At 12:34 PM 3/22/2002 +0530, you wrote:
>Sir,
>
>I have a few queries regarding RFC 2558:
>
>- I want to know how the indexing is done in RFC 2558?
>- In case of path and VT multiple lines are there, how these line as indexed?
>- How can IfIndex help in indexing?
>- the number of rows keeps on changing in VT table as the type of VT 
>changes, how can we handle this situation?
>- Is it required to maintain separate IfIndex Table for Path and VC table? 
>If yes, how we can use IfTable in this regard?
>
>Thanks and Regards
>Anubhav

Anubhav,

the use of ifIndex and ifTable are described in detail
in the preamble of the document - see section 4.

I copy your comments to the discussionlist of the atommib wg
which is the appropriate forum to discuss these issues. See
http://www.ietf.org/html.charters/atommib-charter.html
for subscription info.

Note that 2558 is being evaluated right now and implementation experience is
being requested. Please send your implementation report to
Faye Ly <[email-masked]>
Use the compliance clause as guidance.

kaj

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies. In.
331 Newman Springs Road
Red Bank, NJ 07701
Email: kaj @research.telcordia.com
Tel: (732) 758-5254
Fax: (732) 758-4177

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

---

From: Subrahmanya Hegde <[email-masked]>
Date: Fri, 22 Mar 2002 08:06:04 -0800

Anubhav
  Comments inline
Hope this helps

Subra

>> - I want to know how the indexing is done in RFC 2558?
We need to have an ifIndex entry for each
  *  sonet Line  ( physical connector representing the line)  ifType =
sonet
  * sonet Path  ( if Channelization is allowed in each path) ifType =
sonetPath
  * sonetVT    ( if VTs can be configured on Path)           ifType =
sonetVT

>> - In case of path and VT multiple lines are there, how these line as
ifTable contains entries for sonetVT

>> - How can IfIndex help in indexing?
sonetLine and sonetSection Tables point to ifTable entry with ifType =
sonet
sonetPath related tables point to ifTable entry with ifType = sonetPath
sonet VT related tables point to ifTable entry with ifType = sonetVT

>> changes, how can we handle this situation?
Are you asking that whenver 'sonetVTCurrentWidth' changes, the ifTable
entry changes?
Why is that?  May be I need more info.  on that?
My assumption is 'sonetVTCurrentWidth' is an attribute of each VT.
So, one need not have a seperate entries for each width in ifTable

Refer Section "3.1.2" in RFC 2863.
We need to sub-layer only if required. Otherwise it has to be carried
as an attribute in Media Specific MIB

>>
>> - Is it required to maintain separate IfIndex Table for Path and VC
>> table? If yes, how we can use IfTable in this regard?
>
I don't have an implementation experience on this. However we will be
using this approach in the future.

>  _/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/Kaj
> TesinkTelcordia Technologies. In.331 Newman Springs RoadRed Bank, NJ
> 07701Email: kaj @research.telcordia.comTel: (732) 758-5254Fax: (732)
> 758-4177_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/