Subject: RE: Multiple instances of Sonet Mib

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 17 Mar 2002 01:20:05 +0100

Mike, I am not sure you are describing "multiple instances
of the sonet-mib". What you describe is to havle multiple
pieces of SONET "stuff" represented in the same instance
of the SONET MIB. And it seems to adress the question that
was asked.

But if indeed multiple instances of the SONET MIB MODULE
(or whichever MIB MODULE)  are wanted/needed, then it
seems to me they need to live in a different context as
defined by contextName within the same contextEngineID.

Bert 

> -----Original Message-----
> From: C. M. Heard [mailto:[email-masked]]
> Sent: Saturday, March 16, 2002 6:25 PM
> To: [email-masked]
> Subject: Re: Multiple instances of Sonet Mib
> 
> 
> On Sat, 16 Mar 2002, R. Muralidharan wrote:
> >   Would appreciate if some one can guide me regarding 
> multiple instances of
> > SONET MIB in a system. Take the case of an equipment with 
> multiple SONET
> > OC-N interfaces. How does one go about providing multiple 
> instances of the
> > SONET MIB? Is it as simple as all MIB parameters extended 
> to the ending
> > ".n" where n is the interface number?
> 
> That's close but not quite right.  As described in Section 3 
> of RFC 2558 or
> Section 4 of <draft-ietf-atommib-rfc2558bis-00.txt>, a row in 
> the IF-MIB's
> ifTable [RFC 2863] is used to represent each physical 
> interface (medium/
> section/line layers) and for equipment that terminates paths 
> or VTs a row
> in the ifTable is also used for each path or VT.  Each table in the
> SONET-MIB is then indexed by the appropriate instance of 
> ifIndex;  those
> that deal with interval data are indexed by ifIndex and and 
> interval number.
> So the OID for an instance of each columnar object will end in ".n" or
> ".n.m" where n is the interface number (i.e. relevant ifIndex 
> value) and m
> is the appropriate interval number.
> 
> Mike
> 
> 
>

---

From: "C. M. Heard" <[email-masked]>
Date: Sat, 16 Mar 2002 17:52:47 -0800 (PST)

> of the SONET MIB. And it seems to adress the question that

You are right, what I was describing was how different
instances of the objects in the SONET-MIB are tied to
different SONET interfaces within a single SONET NE
(Network Element), since that was the example presented
in the original query.

> defined by contextName within the same contextEngineID.

Indeed, that would be the case if (for example) one wanted
to have one SNMP engine act as command responder and
notification generator for several SONET NEs, each with
its own independent interface numbering scheme.

I hope this clears up any confusion I may have caused.

//cmh

---

From: "R. Muralidharan" <[email-masked]>
Date: Mon, 18 Mar 2002 16:53:12 +0530

Hi,

Many Thanks for the prompt responses. Special thanks  to Mike and Bert. This
has also helped me reframe the question more close as follows:

" Take the case of a SONET NE with Four numbers of bi-directional OC-3s as
tributary interfaces and one OC-12 as the Network interface with protection
( two OC-12 - one for Working and the other for Protection). In this case,
would it be correct to define the ifNumber for SONET interfaces to be 10?
( one for Tx and another for Rx of each OC-3 interface + one for OC-12
working channel and another for OC-12 Protection channel). Each SONET
interface will now be identified with the unique ifIndex ranging from 1 to
ifNumber (=10) or should it be only ifName?"

Would appreciate response, gratefully acknowledged in advance.
thanks and regards
muralidharan

----- Original Message -----
From: "C. M. Heard" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, March 17, 2002 7:22 AM
Subject: RE: Multiple instances of Sonet Mib

> I hope this clears up any confusion I may have caused.

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com