Subject: RE: Optical Interface MIB questions - draft 04

From: "Rishi Grover" <[email-masked]>
Date: Wed, 12 Jun 2002 12:09:38 -0700

Mike,

Appreciate your response. I think I understand your point.

Pls allow me to ask a follow-on question relating to this.

For a DWDM service that transports multiple channels (160 total) that are divided into C (80 lambdas) and L (80 lambdas) band wavelengths, does this MIB have any provision to monitor the C and L bands seperately?

Here is the dilemma. In our implementation, the C and L bands are implemented and amplified in separate cards (and hence have seperate physical interfaces). Finally the 80 lambdas from each band are muxed into one DWDM fiber using a passive component. This passive component cannot measure PM params like aggregate power etc. for the 160 lambdas.

The PM params defined in the MIB can only be captured on a band-basis (i.e. C-band and L-band) because their specific cards have the active circuitry to measure such parameters. 

So would this all mean that I would need to model the C-band physical interface as one "OTN" ifEntry and the the L-band physical interface as another "OTN" ifEntry in the ifTable? And then in the ifStackTable represent OCh1-OCh80 over OTN1 and OCh81-OCh160 over OTN2.

OR

Would I represent the C and L bands as seperate OMS's over one OTS? In which case the interface stacking would be OCh1-OCh80 over OMS1 over OTS. And OCh81-OCh160 over OMS2 over OTS?

Thanks in advance for trying to clarify these interpretations.

- RG

-----Original Message-----
From: C. M. Heard [mailto:[email-masked]]
Sent: Tuesday, June 11, 2002 7:31 PM
To: [email-masked]
Subject: Re: Optical Interface MIB questions - draft 04

On Tue, 11 Jun 2002, Rishi Grover wrote:

> Would the authors or folks who are implementing the Optical Interface MIB
> please clarify the following:
> 
> The MIB suggests that there is a 1-to-1 relationship between the OMS and OTS
> layers. This relationship is represented by one OTN ifEntry that is required
> to support these two layers. The example in Figure 1 also indicates OChs
> stacked directly on top of an OTN interface.
> 
> However the PM data described in the MIB captures information for the OCh,
> OMS, and OTS layers.
> 
> Questions:
> 
> 1. Why is the PM data seperate for 3 layers when the MIB suggests that
> because of a 1-to-1 relationship between OMS and OTN, 2 layers (OCh and
> OTN) are sufficient to represent an optical interface?

This question arose during the MIB review of draft 04.  Kam Lam and his
co-authors have agreed to include some figures and additional text in
draft 05 (which will appear shortly) to clarify exactly what is monitored
at each layer.  Hopefully that will answer your question.

> 2. If we follow the recommendation of the MIB to represent the OMS and
> OTS layers as one OTN ifEntry in the ifTable, what is the ifIndex used
> for the OMS and OTS to access their PM tables?

The PM tables for OTSn and OMSn layers for a given physical interface are
indexed by the ifIndex of the ifTable entry used to represent that physical
interface.  The exact assignment of ifIndex values is, as always, up to
the agent.  I'm sorry if this answer seems tautological, but I'm not sure
exactly what's unclear.

Regards,

Mike Heard

---

From: "C. M. Heard" <[email-masked]>
Date: Wed, 12 Jun 2002 13:25:25 -0700 (PDT)

On Wed, 12 Jun 2002, Rishi Grover wrote:

> For a DWDM service that transports multiple channels (160 total) that
> are divided into C (80 lambdas) and L (80 lambdas) band wavelengths,
> does this MIB have any provision to monitor the C and L bands seperately?

No, it does not have a way to model banded amplifiers.

> Here is the dilemma. In our implementation, the C and L bands are
> implemented and amplified in separate cards (and hence have seperate
> physical interfaces).  Finally the 80 lambdas from each band are muxed
> into one DWDM fiber using a passive component. This passive component
> cannot measure PM params like aggregate power etc. for the 160 lambdas.

In other words the system looks something like this, possibly with the
order of the filters and amplifiers reversed:

          |\      C-band   C-band amp|\
          | |____ add/drop ____|\____| |
  RX      | |     filters      |/    | |      TX
 from ____| |                        | |____  to
 West     | |     L-band   L-band amp| |     East
          | |____ add/drop ____|\____| |
          | |     filters      |/    | |
          |/                         |/
        passive                     passive
         demux                        mux

> The PM params defined in the MIB can only be captured on a band-basis
> (i.e. C-band and L-band) because their specific cards have the active
> circuitry to measure such parameters.
> 
> So would this all mean that I would need to model the C-band physical
> interface as one "OTN" ifEntry and the the L-band physical interface
> an another "OTN" ifEntry in the ifTable?  And then in the ifStackTable
> represent OCh1-OCh80 over OTN1 and OCh81-OCh160 over OTN2.

No, this is not correct.  An opticalTransport ifTable entry is intended
to represent a single external interface (ifConnectorPresent is true(1)),
so it would be wrong to divide the wavelengths in a single fiber between
two such interfaces.

> OR
> 
> Would I represent the C and L bands as seperate OMS's over one OTS?  In
> which case the interface stacking would be OCh1-OCh80 over OMS1 over OTS.
> And OCh81-OCh160 over OMS2 over OTS?

This is not right either, since the OMSn sublayer has a 1-for-1 relationship
with the OTSn sublayer.

The problem is that the pre-OTN PM objects in the OPT-IF-MIB just don't fit
your NE very well.  You could _calculate_ the OTSn input and output power
by summing the corresponding C-band and L-band parameters, but the OTSn
laser temperature object does not fit at all.  Perhaps you should consider
defining proprietary PM objects in your enterprise MIB that better fit the
structure of the equipment that you are trying to manage.

Perhaps the MIB authors could jump in here and comment on this.

Mike