Subject: Optical Interface MIB questions - draft 04

From: "Rishi Grover" <[email-masked]>
Date: Tue, 11 Jun 2002 17:51:52 -0700

Would the authors or folks who are implementing the Optical Interface MIB please clarify the following:

The MIB suggests that there is a 1-to-1 relationship between the OMS and OTS layers. This relationship is represented by one OTN ifEntry that is required to support these two layers. The example in Figure 1 also indicates OChs stacked directly on top of an OTN interface. 

However the PM data described in the MIB captures information for the OCh, OMS, and OTS layers. 

Questions:

1. Why is the PM data seperate for 3 layers when the MIB suggests that because of a 1-to-1 relationship between OMS and OTN, 2 layers (OCh and OTN) are sufficient to represent an optical interface?

2. If we follow the recommendation of the MIB to represent the OMS and OTS layers as one OTN ifEntry in the ifTable, what is the ifIndex used for the OMS and OTS to access their PM tables?

Thanks.

RG

---

From: "C. M. Heard" <[email-masked]>
Date: Tue, 11 Jun 2002 19:31:16 -0700 (PDT)

On Tue, 11 Jun 2002, Rishi Grover wrote:

> The MIB suggests that there is a 1-to-1 relationship between the OMS and OTS
> layers. This relationship is represented by one OTN ifEntry that is required
> to support these two layers. The example in Figure 1 also indicates OChs
> stacked directly on top of an OTN interface.
> 
> 1. Why is the PM data seperate for 3 layers when the MIB suggests that
> because of a 1-to-1 relationship between OMS and OTN, 2 layers (OCh and
> OTN) are sufficient to represent an optical interface?

This question arose during the MIB review of draft 04.  Kam Lam and his
co-authors have agreed to include some figures and additional text in
draft 05 (which will appear shortly) to clarify exactly what is monitored
at each layer.  Hopefully that will answer your question.

> 2. If we follow the recommendation of the MIB to represent the OMS and
> OTS layers as one OTN ifEntry in the ifTable, what is the ifIndex used
> for the OMS and OTS to access their PM tables?

The PM tables for OTSn and OMSn layers for a given physical interface are
indexed by the ifIndex of the ifTable entry used to represent that physical
interface.  The exact assignment of ifIndex values is, as always, up to
the agent.  I'm sorry if this answer seems tautological, but I'm not sure
exactly what's unclear.

Regards,

Mike Heard