Subject: Framing the Extensibility Discussion

From: Dare Obasanjo <[email-masked]>
Date: Wed, 25 Aug 2004 11:09:51 -0700 (PDT)

It seems best to properly frame what the goals of
extensibilty should be before debating various
techniques for achieving this in Atom. 

When I client encounters content in an Atom feed it
doesn't understand it can do one of three things 

1.) Ignore it
2.) Treat it in some default manner
3.) Learn how to consume this content

The RSS approach has been to do (1). It looks like the
goal of the folks championing link extensibility is so
that in some cases one could do (2). However no one
has put forward what this default treatment should be
nor what the connection should be between such
extensions that allows them to be treated the same.
The Semantic Web approach is (3). My personal opinion
is that this is a pipe dream but I suspect some in the
RDF camp belive otherwise even though so far it hasn't
been shown to occur in the wild outside of demoware. 

=====
THINGS TO DO IF I BECOME AN EVIL OVERLORD #25
No matter how well it would perform, I will never construct any sort of machinery which is completely indestructible except for one small and virtually inaccessible vulnerable spot.

__________________________________
Do you Yahoo!?
Yahoo! Mail Address AutoComplete - You start. We finish.
http://promotions.yahoo.com/new_mail

---

From: Ian Davis <[email-masked]>
Date: Wed, 25 Aug 2004 19:49:09 +0100

> 3.) Learn how to consume this content

I think 3 here is meaningless. I would suggest:

4. Discover if part or all of extension can safely be treated as 
something the client already knows how to handle

You could potentially discover that some unknown link types should be 
displayed to the user and that others are for system use only by 
referring to some kind of inheritance mechanism.

Ian