Subject: PaceHeadInEntry

From: Tim Bray <[email-masked]>
Date: Mon, 15 Nov 2004 14:59:26 -0800

+1, for what it's worth.  I can't think of any gotchas and I do think 
composite feeds of various kinds are going to be real important.

This Pace should be updated to remove atom:origin, which IMHO it 
supercedes. -Tim

---

From: Graham <[email-masked]>
Date: Tue, 16 Nov 2004 03:24:27 +0000

> This Pace should be updated to remove atom:origin, which IMHO it 

I think the Pace needs to be explicit that the entry inherits from its 
own head rather than from the main head. There need to be rules of how 
to interpret it.

Also, it should probably be the first child of atom:entry, for the same 
reason the main atom:head already comes before all the other entries.

Graham

---

From: "Bob Wyman" <[email-masked]>
Date: Mon, 15 Nov 2004 22:59:39 -0500

Graham wrote:
> I think the Pace needs to be explicit that the entry inherits
> from its own head rather than from the main head. There need
> to be rules of how to interpret it.
	Would wording like the following be acceptable?

"If an atom:entry contains an atom:head element then any elements or
attributes of the atom:entry which are defined as being inherited from the
atom:head of the parent feed MUST be inherited only from the atom:head
element contained by the atom:entry."

> Also, it should probably be the first child of atom:entry,
	Would this work for you?
"An atom:head element, if present in an atom:entry, should be the first
child of atom:entry."

		bob wyman

---

From: Lance Lavandowska <[email-masked]>
Date: Tue, 16 Nov 2004 09:56:50 -0600

> element contained by the atom:entry."

Huh? is my first reaction.  Here is an off-the-cuff attempt at
rewording it.  Perhaps some jumble of the two will be more clear?

"Elements or attributes of atom:entry which are defined as being
inherited from atom:head MUST inherit from the atom:head of the
atom:entry, if present.  If atom:head is not present in atom:entry
then inheritance descends from the atom:head of the parent feed."

Lance Lavandowska

---

From: Antone Roundy <[email-masked]>
Date: Tue, 16 Nov 2004 09:24:57 -0700

> then inheritance descends from the atom:head of the parent feed."
What about if we stated things more broadly, along the lines of:

"An atom:entry element which contains an atom:head element MUST be 
processed as if its containing atom:feed element contained an atom:head 
element with the same contents."

---

From: "Bob Wyman" <[email-masked]>
Date: Tue, 16 Nov 2004 11:31:44 -0500

I prefer Lance Lavandowska 's wording to my own. So, take the proposal as:

If nobody complains soon, I'll update the Pace.

		bob wyman

---

From: Walter Underwood <[email-masked]>
Date: Tue, 16 Nov 2004 10:03:12 -0800

I'd rather not see "inherit". Just say something like "values from the
atom:head of the parent feed are used."

wunder

--
Walter Underwood
Principal Architect
Verity Ultraseek

---

From: Martin Duerst <[email-masked]>
Date: Wed, 17 Nov 2004 08:03:37 +0900

>If nobody complains soon, I'll update the Pace.

Sorry, but I'm not sure what this means. Assume the following:

<feed>
    <head>
       <el1>foo</el1>
    </head>
    <entry id="entry1">
    <entry/>
    <entry id="entry2">
       <head>
         <el2>bar</el2>
       </head>
    <entry/>
</feed>

It is clear that <el1>foo</el1> applies to entry1. It is clear
that <el2>bar</el2> applies to entry2. But does <el1>foo</el1>
apply to entry2? It looks like it does, because there is no
<el1> in entry2's head, and it looks like it doesn't, because
there is a <head> in entry2, so you can forget about anything
in the feed <head>.

Which one is it? I'd prefer that <el1>foo</el1> applies to entry2,
but apart from that, either way, the text isn't clear enough.

Regards,    Martin.

---

From: "Bob Wyman" <[email-masked]>
Date: Tue, 16 Nov 2004 18:14:05 -0500

Martin Duerst wrote:
> But does <el1>foo</el1> apply to entry2?
	I would argue that it does not. Since entry2 contains a <head/>
element, all entry-level "inheritance" should be from that <head/> entry --
not from the feed's <head/>. The mere presence of <head/> should re-route
*ALL* inheritance, not just inheritance of the elements which appear in the
<head/>. 
	Imagine the following:

<feed>
    <head>
       <author>Tom Bombadil</author>
       <copyright>The Fellowship</copyright>
    </head>
    <entry/>
    <entry>
       <head>
         <author>Sauron</author>
       </head>
    <content>...</content>
    <entry/>
</feed>

	Since the entry contains a <head/>, it should NOT inherit author,
copyright or anything else from the feed's head.

		bob wyman

---

From: Bill de hÓra <[email-masked]>
Date: Wed, 17 Nov 2004 00:53:37 +0000

> copyright or anything else from the feed's head.

I dislike this kind of stealthy implication for which we require a short 
circuit mechanism to patch around. It's much to better to declare that 
you want something from another context expanded in the current context. 
IOW if people want inheritance to occur they should ask for it 
explicitly, not disable it explicitly.

cheers
Bill

---

From: Tim Bray <[email-masked]>
Date: Tue, 16 Nov 2004 19:20:39 -0800

> atom:head of the parent feed are used."

Agreed that the verb "inherit" is overloaded with semantics that we 
probably don't want Atom to, uh, inherit. -Tim