Subject: RE: Published extensibility Paces

From: "David Orchard" <[email-masked]>
Date: Thu, 11 Nov 2004 11:18:28 -0800

I kind of like where this is going, but I think that the discussion of
"foreign" should be removed.  If Atom refers normatively to some third
party spec, like dc:title, is that foreign?  I would simply say
"unknown" markup is allowed as I did in
http://www.intertwingly.net/wiki/pie/PaceExtensibilityAndVersioningNoSce
narios

A minor tweak on MU: what about making the namespaces into a list of
URIs in an attribute, ie <atom:feed atom:must-understand="ns1 ns2">?

Also, does the removal of version imply a resolution to Atom Component
Identification that is the use of atom namespace name changes + mU to
indicate incompatible versions, as I had proposed?

Dave

> -----Original Message-----
> From: [email-masked] [mailto:owner-atom-
> [email-masked]] On Behalf Of Tim Bray
> Sent: Wednesday, November 10, 2004 3:05 PM
> To: 'Atom WG'
> Subject: Published extensibility Paces
> 
> 
> I had a talk about Atom and extensibility with Dave Orchard this
> morning, and he convinced me that there is benefit in a
must-understand
> facility, but then educated me as to how complex it can be to
> implement.
> 
> Based on that discussion, I have just published
> PaceMustUnderstandElement and PaceExtendingAtom.  Note that the WG
> could reject PaceMustUnderstandElement and I think that
> PaceExtendingAtom would still work.
> 
> For convenience:
>   http://www.intertwingly.net/wiki/pie/PaceMustUnderstandElement
>   http://www.intertwingly.net/wiki/pie/PaceExtendingAtom
> 
>    -Tim

---

From: Tim Bray <[email-masked]>
Date: Thu, 11 Nov 2004 11:27:44 -0800

> PaceExtensibilityAndVersioningNoSce

If people buy the concept, we can let the editors choose the word.

> URIs in an attribute, ie <atom:feed atom:must-understand="ns1 ns2">?

Just seems like it's easier to make the XML processor do the parsing  
rather than having to do it yourself.

> indicate incompatible versions, as I had proposed?

I totally didn't understand that question, and I bet there are others  
similarly puzzled.  Want to try again? -Tim

---

From: Henry Story <[email-masked]>
Date: Thu, 11 Nov 2004 20:28:16 +0100

On 11 Nov 2004, at 20:18, David Orchard wrote:

> party spec, like dc:title, is that foreign?

There would be no need for atom to normatively do this. That can be  
hidden away in the OWL ontology. That is where you can state that  
atom:title is a subproperty of dc:title

> I would simply say

I don't think that would be such a good idea. I prefer a set of them

	<atom:must-understand>uri1</atom:must-understand>
	<atom:must-understand>uri2</atom:must-understand>

---

From: Tim Bray <[email-masked]>
Date: Thu, 11 Nov 2004 11:49:36 -0800

> 	<atom:must-understand>uri2</atom:must-understand>

For all the others who apparently didn't bother to read the Pace, the 
proposal was

<atom:must-understand>
  <ns>uri1</ns>
  <ns>uri2</ns>
</atom:must-understand>

  -Tim