Subject: Atom for internal use? <link>, etc

From: [email-masked]
Date: Fri, 26 Aug 2005 12:13:08 -0500

Hi,

I am developing a web app framework and am using a RSSesque xml format to allow
the application layer talk to a higher layer. XSL is used to combine this and
then passes it on up to the gui layer.

I would like to move to Atom instead of RSS since Atom seems to encapsulate more
things. I would like to be able to be fully atom compliant, and not just some
atomesque flavor.

Here is an issue I am having....

* Nested feeds and <link>
A bit back I posted about nested feeds. I took the advice given and made
separate sibling feed tags instead of having feeds of feeds. The problem comes
in connecting them at the XSL level. I can't use <link href="..."/> since the
xml i need to reference is not at a different location, but inside of a parent
node that holds all the sibling application feed nodes. In practice, this
parent node basically represents a content area on a webpage.

Is there an attribute to the LINK tag I can use as some sort of id that i can
assign to the feed tag and link to it via the link tag? I read the spec and
couldn't really find one.

Here is an example. Products and Products Options are two differnt feeds within
this parent tag.
<application_data>
<!-- feed for a specific product -->
<feed id="primary">
   <entry>
     <products_id>1</products_id>
     <name>Atom Sweatshirt</name>
     <!-- link to child application data for product options -->
     <link id="567" />
   </entry>
</feed>

<!-- feed for a specific product's options -->
<feed id="567">
   <entry>
     <options_id>1</options_id>
     <name>small</name>
   </entry>
   <entry>
     <options_id>2</options_id>
     <name>medium</name>
   </entry>
   <entry>
     <options_id>3</options_id>
     <name>large</name>
   </entry>
</feed>
</application_data>

Any thoughts?

Thanks in advance.

Blaine

---

From: "A. Pagaltzis" <[email-masked]>
Date: Fri, 26 Aug 2005 20:20:08 +0200

* [email-masked] <[email-masked]> [2005-08-26 19:20]:
> assign to the feed tag and link to it via the link tag?

My first thought would be to use xml:id on the feed element and a
fragment identifier in the @href.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>