Subject: Finishing up on whitespace in IRIs and dates

From: Paul Hoffman <[email-masked]>
Date: Thu, 11 Aug 2005 21:04:21 -0700

Greetings again. I think we have rough consensus on "emitting with 
whitespace around IRIs and dates is an error" and "we should warn 
folks that people might emit errors here because this is somewhat 
subtle".

If that is true, I propose that, just before section 3.1 (at the end 
of the introductory text to "Common Atom Constructs") we add:

Note that there MUST be no whitespace in a Date construct or in any 
IRI. Some XML-emitting implementations erroneously insert whitespace 
around values by default, and such implementations will emit invalid 
Atom.

--Paul Hoffman, Director
--Internet Mail Consortium

---

From: "A. Pagaltzis" <[email-masked]>
Date: Fri, 12 Aug 2005 06:29:23 +0200

* Paul Hoffman <[email-masked]> [2005-08-12 06:15]:
> Note that there MUST be no whitespace in a Date construct or in
> any IRI. Some XML-emitting implementations erroneously insert
> whitespace around values by default, and such implementations
> will emit invalid Atom.

+1

Minor niggle: I’d prefer “there MUST NOT be any whitespace” over
the proposed wording.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: Walter Underwood <[email-masked]>
Date: Thu, 11 Aug 2005 21:37:43 -0700

--On August 11, 2005 9:04:21 PM -0700 Paul Hoffman <[email-masked]> wrote:

> Note that there MUST be no whitespace in a Date construct or in any IRI. Some XML-emitting implementations erroneously insert whitespace around values by default, and such implementations will emit invalid Atom.

Nice clear wording.

+1 with "MUST be no" changed to "MUST NOT be", as suggested by Aristotle.

wunder
--
Walter Underwood
Principal Software Architect, Verity

---

From: James M Snell <[email-masked]>
Date: Thu, 11 Aug 2005 22:08:34 -0700

+1 on this with the "MUST NOT be" suggestion

---

From: Eric Scheid <[email-masked]>
Date: Fri, 12 Aug 2005 14:40:01 +1000

On 12/8/05 2:29 PM, "A. Pagaltzis" <[email-masked]> wrote:

> Minor niggle: I¹d prefer ³there MUST NOT be any whitespace² over
> the proposed wording.

+1.

Also, 
    
    s/emit invalid Atom./emit invalid Atom documents./

e.

---

From: Bill de hÓra <[email-masked]>
Date: Fri, 12 Aug 2005 11:26:43 +0100

Paul Hoffman wrote:
> whitespace around IRIs and dates is an error" and "we should warn folks
> that people might emit errors here because this is somewhat subtle".
> 
> If that is true, I propose that, just before section 3.1 (at the end of
> the introductory text to "Common Atom Constructs") we add:
> 
> Note that there MUST be no whitespace in a Date construct or in any IRI.
> Some XML-emitting implementations erroneously insert whitespace around
> values by default, and such implementations will emit invalid Atom.

+1

cheers
Bill

---

From: Joe Gregorio <[email-masked]>
Date: Fri, 12 Aug 2005 09:34:29 -0400

> +1 with "MUST be no" changed to "MUST NOT be", as suggested by Aristotle.

+1 with the MUST NOT change incorporated.

   -joe

-- 
Joe Gregorio        http://bitworking.org

---

From: Martin Duerst <[email-masked]>
Date: Sat, 13 Aug 2005 00:02:40 +0900

+1, including the 'MUST NOT' suggestion.

(Note that the XML Schema anyURI datatype, which may be used in
the RelaxNG schema for IRIs, allows spaces, because it was based
on an early draft of the IRI spec. If precision is desired, spaces
(and the other US-ASCII characters that the XML Schema anyURI
datatype allows) can easily be excluded using a pattern facet.)

Regards,    Martin.

---

From: Robert Sayre <[email-masked]>
Date: Fri, 12 Aug 2005 11:46:25 -0400

+1.

Robert Sayre

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 12 Aug 2005 10:23:03 -0700

Seems like we have consensus. Rob: please make this change and turn 
in the -11. Thanks!

--Paul Hoffman, Director