Subject: Re: spec bug: can we fix for draft-11?

From: Brett Lindsley <[email-masked]>
Date: Sun, 07 Aug 2005 19:22:57 -0500

I was just observing most of this discussion, but I am wondering how
much of an issue the whitespace issue will cause when generating
signatures. Obviously, different signatures will result when signing
an element that has white space and one that does not. Does the
canonicalization fix this? Brett.

----- Original Message -----
From: Walter Underwood <[email-masked]>
Date: Friday, August 5, 2005 4:37 pm
Subject: Re: spec bug: can we fix for draft-11?

> 
> --On August 4, 2005 9:31:55 AM -0700 Tim Bray 
<[email-masked]> 
> wrote:>
> > So for now, I'm -1 on an weakening or removing "The element's 
> content  MUST be
> > an IRI" or analogous text in any other section. I'll stop  
> shouting if I'm in
> > a small minority here.  -Tim
> 
> Wow, this string has made my "away on vacation" mailbox fatter.
> 
> I strongly favor making white space around IRIs illegal in Atom, 
> whetherthey are an ID or somewhere else. Same for dates.
> 
> This follows the robustness principle, where we are conservative 
> in what
> we generate. Atom processors are free to be liberal in what they 
> accept,so they can strip whitespace. Or not, I don't care.
> 
> Note that a feed with whitespace around an IRI can never be aggregated
> into another feed, because a) the ID IRI cannot be changed, and b) 
> the new
> feed cannot cannot contain whitespace.
> 
> Making every single processor strip whitespace smells too much like
> the HTML tag soup processors that we all have to maintain. Yuk.
> 
> wunder
> --
> Walter Underwood
> Principal Architect, Verity
> 
>

---

From: Bill de hÓra <[email-masked]>
Date: Mon, 08 Aug 2005 01:41:06 +0100

> canonicalization fix this? Brett.

Exclusive canonicalization (which is the one we care about here) like
canonicalization keeps whitespace inside element content significant.
Those bytes are counted. I take that as meaning in the dsig case,
trimming is broken.

cheers
Bill

---

From: Tim Bray <[email-masked]>
Date: Sun, 07 Aug 2005 23:01:15 -0700

> Those bytes are counted. I take that as meaning in the dsig case,

The c14n/dsig implementations I know of would agree with you.  The  
XML and RFC3470 are both crystal-clear on this. -Tim