Subject: Weather data in Atom

From: Asbjørn Ulsberg <[email-masked]>
Date: Fri, 12 Dec 2008 00:08:58 +0100

Hi.

I just wonder if anybody have any experience with either producing or consuming weather (meteorological) data through Atom? Would WeatherML be worth looking at, or are there simpler and more light-weight vocabularies that might express the data satisfyingly?

How do you think such data should be expressed through Atom? How should the basic Atom entry look like, which basic Atom constructs would be useful to utilize for the entry to give as much meaning as possible to non-meteorological consumers like ordinary feed readers?

Since weather measurements are timely events, they fit rather well into Atom's feed structure, but there are lots of metadata (like longitude, latitude, wind speed, humidity, etc) that would need extensions of some sort to be expressed properly.

Anyone?

-- 
Asbjørn Ulsberg         -=|=-          [email-masked]
«He's a loathsome offensive brute, yet I can't look away»

---

From: Sean Gillies <[email-masked]>
Date: Thu, 11 Dec 2008 21:14:11 -0700

Asbjørn Ulsberg wrote:
> 
> Hi.
> 
> I just wonder if anybody have any experience with either producing or 
> consuming weather (meteorological) data through Atom? Would WeatherML be 
> worth looking at, or are there simpler and more light-weight 
> vocabularies that might express the data satisfyingly?
> 
> How do you think such data should be expressed through Atom? How should 
> the basic Atom entry look like, which basic Atom constructs would be 
> useful to utilize for the entry to give as much meaning as possible to 
> non-meteorological consumers like ordinary feed readers?
> 
> Since weather measurements are timely events, they fit rather well into 
> Atom's feed structure, but there are lots of metadata (like longitude, 
> latitude, wind speed, humidity, etc) that would need extensions of some 
> sort to be expressed properly.
> 
> Anyone?
> 

Sure, put meteorological markup of observations (or grid point data) in 
an entry's content element. Use standard Atom elements for the 
observation metadata (time, id), and a georss:where element for position 
(see GeoRSS). I haven't found any evidence that the US National Weather 
Service uses SensorML or WeatherML in its existing feeds. For example,

http://www.weather.gov/xml/current_obs/KCCU.rss

has HTML markup meant for humans. The NWS is experimenting with "ATOM" 
for its next generation of alerts. See

http://www.weather.gov/alerts-beta/

The current Colorado one

http://www.weather.gov/wwarss-tst/co.php?x=0

demonstrates some "cap" and "ha" namespace elements. Seems like most of 
the cap elements could be replaced with Atom categories, or GeoRSS for 
the areal element, but cap:expires at least is new and useful.

Cheers,
Sean

---

From: Aristotle Pagaltzis <[email-masked]>
Date: Sat, 13 Dec 2008 00:02:18 +0100

* Sean Gillies <[email-masked]> [2008-12-12 05:35]:
> Sure, put meteorological markup of observations (or grid point
> data) in an entry's content element. Use standard Atom elements
> for the observation metadata (time, id), and a georss:where
> element for position (see GeoRSS).

+1

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: "Ian Mayo" <[email-masked]>
Date: Sat, 13 Dec 2008 08:48:03 +0000

+1

I'd also recommend exploring the other Atom elements to establish
their applicability to your applications are (esp Category, Author,
Generator)

Ian Mayo

---

From: Bill de hOra <[email-masked]>
Date: Tue, 16 Dec 2008 21:53:28 +0000

>> element for position (see GeoRSS).

http://tech.groups.yahoo.com/group/rest-discuss/message/11597

What am I missing?

Bill

---

From: "Lindsley Brett-ABL001" <[email-masked]>
Date: Wed, 17 Dec 2008 07:57:30 -0500

Does anyone know of any work on encapsulating an Atom entry in an SMTP
message? This would be useful for push notifications as an alternative
to Atom over XMPP. 

Brett Lindsley, Motorola
Advanced Technology and Research Center

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 24 Dec 2008 11:46:22 +0100

On Wed, Dec 17, 2008 at 07:57:30AM -0500,
 Lindsley Brett-ABL001 <[email-masked]> wrote 
 a message of 9 lines which said:

> Does anyone know of any work on encapsulating an Atom entry in an
> SMTP message?

[There are no SMTP messages, I assume you mean RFC5322 messages, which
can be sent with SMTP or with other protocols.]

MIME-Version: 1.0
Content-Type: application/atom+xml
Content-Disposition: attachment; filename="myentry.atom"
Content-Transfer-Encoding: what-you-want

With the content, encoded according to Content-Transfer-Encoding,
being:

<?xml version="1.0" encoding="utf-8"?>
<entry xmlns="http://www.w3.org/2005/Atom" >
<title>Atom-Powered Robots Run Amok</title>
...

What else?