Subject: Re: Looking for Atom readers supporting RFC 5005 ?

From: Sergey Beryozkin <[email-masked]>
Date: Fri, 19 Feb 2010 15:08:38 +0000

Hi

Snarfer indeed is capable of reading paged feeds, thanks for a link !
Ex, given 8 available records and with a page size configured to 2, Snarfer managed to follow the 'next' link 4 times and showed all 8 records immediately.

However, without clicking "Retrieve old messages that have already been archived" it shows me the current messages only (the very first 2 ones in this case) but ideally, the reader would also offer me an option to see the records from the 'first' feed or the 'last' one or traverse to the 'previous' or 'next' one by adding corresponding links to the view.

Would it make sense to open an enhancement request ? I was not able to do it at the Snarfer site

cheers, Sergey

[email-masked] wrote:
> I'd like to test an endpoint returning feed instances with links of types 'previous', 'next', 'first' and 'last'.
> Do you know of any existing readers supporting such links ?

Snarfer does (http://www.snarfware.com/). Not exactly as specified in RFC 5005, but something similar.

When subscribing to a feed, make sure you tick the checkbox, "Retrieve old messages that have already been archived", assuming that's what you want. Also select "Keep all messages" if you don't want to be limited to the most recent 200 (or whatever the default is). Even then, by default, it won't retrieve more than 500 archived messages, but there is a setting to change that if you really feel the need to leech a lot of data from someone.

Regards
James

---

From: James Holderness <[email-masked]>
Date: Fri, 19 Feb 2010 15:12:25 -0500

[email-masked] wrote
> ideally, the reader would also offer me an option to see the
> records from the 'first' feed or the 'last' one or traverse to
> the 'previous' or 'next' one by adding corresponding links to
> the view.
                                                                     
Interesting idea. But the way Snarfer is structured internally, 
implementing something like that would be difficult if not 
impossible.
 
> Would it make sense to open an enhancement request ?

Ultimately the person that would have to implement it would be
me, so no. :)

As much as I'd like to, I just don't have the time to do much 
work on Snarfer anymore.

Regards
James

_________________________________________________________________
Hotmail: Trusted email with powerful SPAM protection.
http://clk.atdmt.com/GBL/go/201469227/direct/01/