Subject: Atom Tombstones - Last Call

From: James Snell <[email-masked]>
Date: Tue, 22 Jun 2010 09:16:02 -0700

Ok, I'm declaring this done... Last Call on Tombstones and a Call for
Implementation...

  http://www.ietf.org/internet-drafts/draft-snell-atompub-tombstones-10.txt

- James

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Tue, 22 Jun 2010 23:25:30 +0200

>  http://www.ietf.org/internet-drafts/draft-snell-atompub-tombstones-10.txt

As the document contains a media type registration, you should ask for
its review on the ietf-types mailing list, see RFC 4288. It is customary
to send a pointer to the document as well as the filled out template.

You need to adapt your template so it follows the form specified in RFC
4288, for instance, some of the field names are different. The fields
"Fragment identifiers" and "Base URI" should be removed, RFC 3023 does
not specify anything in that regard that would be of note.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: James Holderness <[email-masked]>
Date: Tue, 22 Jun 2010 19:16:11 -0400

Haven't had a chance to re-read the whole document, but I just noticed something which I thought I should mention before I forgot about it.

I don't know RELAX NG syntax very well, but it seems to me that the schema you have for the deletedEntry isn't quite right.

     deletedEntry = element at:deleted-entry {
       atomCommonAttributes,
       attribute ref { atomUri },
       attribute when { atomDateConstruct },
       ( element at:by { atomPersonConstruct}?,
       & element at:comment {atomTextConstruct}?,
       & element atom:link*,
       & element atom:source?,
       & extensionElement* )
     }

Surely those element lines shouldn't have a comma on the end? You already have an ampersand connector and you wouldn't want a comma connector anyway since order isn't significant. Or have I got it all wrong?

Also, not a big deal, but while you're looking at that, the spacing inside the braces could do with some consistency.

Regards
James

_________________________________________________________________
The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail. 
http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5