Subject: Re: [Autoconf] Next steps?

From: Jari Arkko <[email-masked]>
Date: Mon, 22 Mar 2010 14:46:20 -0700

Alex,

> In the solution space I am interested in the use of link-local addresses
> and of multicast link-scoped addresses.
>
> I hope these are not forbidden by the IPv6 addressing architecture
> document, which seems to be sent to the IESG now.

Actually, I *do* want to see the working group's solutions build on top 
of the address model that we have just completed. And it does discourage 
the use of link-local addresses. Lets not return to that discussion, I 
would be more interested in discussing what gaps we have the technology 
and what possible solutions we might need to do.

Jari

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 22 Mar 2010 14:59:57 -0700

I agree with Jari on this point.

To the chairs: is there already an agenda for the meeting? Will there be
solutions presented?

Ulrich

On Mon, Mar 22, 2010 at 2:46 PM, Jari Arkko <[email-masked]> wrote:

> Actually, I *do* want to see the working group's solutions build on top of
> the address model that we have just completed. And it does discourage the
> use of link-local addresses. Lets not return to that discussion, I would be
> more interested in discussing what gaps we have the technology and what
> possible solutions we might need to do.
>
> Jari
>
> _______________________________________________
>
> Autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/autoconf
>

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 22 Mar 2010 15:03:02 -0700

Hi Ulrich,

#although I am sitting next to you, let me answer here.

On 2010/03/22, at 14:59, Ulrich Herberg wrote:

> To the chairs: is there already an agenda for the meeting? Will there be solutions presented? 

Yes, we got 5 presentation requests and allocate slots for all the requests.  
We also plan to spend more time on "our next step" at this meeting.

We will publish agenda shortly (sorry for delay).

thanks,
ryuji

> Actually, I *do* want to see the working group's solutions build on top of the address model that we have just completed. And it does discourage the use of link-local addresses. Lets not return to that discussion, I would be more interested in discussing what gaps we have the technology and what possible solutions we might need to do.
> 
> Jari
>

---

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Mon, 22 Mar 2010 23:13:38 +0100

Jari, all, 

> 
> > In the solution space I am interested in the use of link-local 
> > addresses and of multicast link-scoped addresses.
> >
> Actually, I *do* want to see the working group's solutions 
> build on top of the address model that we have just 
> completed. And it does discourage the use of link-local 
> addresses. Lets not return to that discussion, I would be 
> more interested in discussing what gaps we have the 
> technology and what possible solutions we might need to do.
> 

Then, to put it bluntly, we have been had. Time and again it has been
mentioned that the document presented *an* addressing architecture
model, not *the* model. I would think that the scope of solutions would
be subject of a re-chartering discussion.

Ronald
This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/disclaimer/email.html

---

From: Teco Boot <[email-masked]>
Date: Tue, 23 Mar 2010 00:02:54 +0100

Jari,

The address model doesn't discourage the use of IPv6 link-local 
addresses. It explains the limitations of it and encourage the 
WG to primarily focus on configuring IP addresses that are 
not IPv6 link-local. Small but essential difference.
IPv4 link-local addresses are discouraged.

My BRDP proposal runs on RA. I could change it to run on PacketBB
or RFC4861 could be updated. Or I keep the usage of link-local.
I'll pick the WG preference on this. And check what ROLL RPL is 
doing.
BRDP does configure non-link-locals.

Regards, Teco.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 22 Mar 2010 16:52:28 -0700

Hello folks,

Teco's wording matches my understanding also.  Anyway,
I think when it comes to solutions, we'll be able to see
whether or not a link-local solution is "competitive"
with other solutions.

Regards,
Charlie P.

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 23 Mar 2010 22:15:08 +0100

Le 22/03/2010 22:46, Jari Arkko a écrit :
> Actually, I *do* want to see the working group's solutions build on
> top of the address model that we have just completed. And it does
> discourage the use of link-local addresses. Lets not return to that
> discussion, I would be more interested in discussing what gaps we
> have the technology and what possible solutions we might need to do.

WEll yes let's discuss gaps in technology but for which deployment?
Anything simply labelled "MANET" is way too vague to understand for me.

-personal area networks for commercial PDAs and phones?
-vehicular settings?
-mobile Client to Access Point configuration? (bonjour)
-WiFi AP fixed on street poles?
-any other?

I am throwing this list just like that.  Maybe identifying deployments
is not important at all.  I really don't know what should we discuss
about technology gaps.

Alex