Subject: Re: [Autoconf] draft-boot-autoconf-support4hosts

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 03 Dec 2010 16:09:41 -0800

Hello Teco,

Comments below:

>                     Packet forwarding between hosts is always lead
>    via one ore more MANET routers, unless link-local addresses are used
>    and direct reachability between the hosts exists.

I did not understand this sentence.

>                                                    However, usage of
>    link-local addresses is not recommended, as non-link-local addresses
>    provide better support for session continuity in mobile environments.

I was surprised to read that the purpose for using non-link-local
addresses was for session continuity.  I think it is more along the
lines of "identity preservation and uniqueness".

> Charles E. Parkins

Thanks for the acknowledgement.  My last name has
an 'e' in it :-).

>                                                 Mobility
>    solutions are already available and can be used in the MANET
>    scenario.

This is true, but usually is considered in the context
of having a home agent in the Internet instead of in
the ad-hoc network.  Is this what you are proposing?

Regards,
Charlie P.

On 11/29/2010 1:30 PM, Teco Boot wrote:
> Feel free to comment on a draft I just submitted.
> http://www.ietf.org/id/draft-boot-autoconf-support4hosts-00.txt
> Teco.
>
>> Abstract:
>> This document describes how hosts using IPv6 Stateless Address
>> Autoconfiguration can be used in a MANET, without a need for any
>> change, neither in functioning of Neighbor Discovery nor in MANET
>> protocols.  In addition, legacy hosts nor other parts of the network
>> are faced any deviation on the IPv6 Addressing architecture.
>
> _______________________________________________
> Autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/autoconf
>

---

From: Teco Boot <[email-masked]>
Date: Mon, 6 Dec 2010 22:50:25 +0100

Hello Charlie,

Thanks for reviewing.
I posted a -01. I hope it clears up a bit.
http://www.ietf.org/id/draft-boot-autoconf-support4hosts-01.txt

> I did not understand this sentence.

Now, diagrams and text is added.
It shows when LLs work, and when it fails.
Maybe MPTCP can support LLs and find out automatically 
if a host-host path exists and has larger throughput 
as a path via router(s).

> lines of "identity preservation and uniqueness".

I guess mobility solutions are not designed for link-locals.
But this is not clear in this sentence, so I reworded.

> Thanks for the acknowledgement.  My last name has

Who said it was you? :-)

> the ad-hoc network.  Is this what you are proposing?

There are mobility solutions that don't need a home agent. E.g. I
suggested running a MANET routing protocol.

I am aware of MANETs where main requirement is connectivity with 
nodes on the Internet. Here, MIP6 could work quite well.

Another model is using the router that provided the 1st configured prefix
as MIP6 HA. When Host1 gets address from RtrA and assigns address HostA,
it could use this address as home address. When later on, an address
HostB with prefix from RtrB is assigned, it could bind this HostB address
as care-of address to HA RtrA. Route optimization can be performed with
for example MPTCP.
Legacy hosts would not perform such functions, but I think it is doable.

Regards, Teco