Subject: Re: [AVT] Final edits to RTP spec and A/V profile

From: John Lazzaro <[email-masked]>
Date: Thu, 16 Jan 2003 11:24:31 -0800

> Jonathan Rosenberg <[email-masked]> writes:
>
> I suspect each unicast connection is treated as a separate RTP session.

Sfront currently ships with multi-unicast support, and the  
implementation is a hybrid of both approaches. A sender does
sent the same RTP packet to each receiver, and in this way
everything but the lowest layers of the stack believes a 
true multicast session is underway. Sfront needs to do this,
because it lets a sender create and maintain one recovery
journal system for all receivers, a big efficiency improvement
over N recovery journal systems.

However, a receiver doesn't send RTCP RR packets describing  
a sent stream to all other participants, only to the original
sender. This is for efficiency ...                         

BTW, Appendix B of the MWPP guidelines document:

http://www.ietf.org/internet-drafts/draft-lazzaro-avt-mwpp-coding-guidelines-01.txt

Covers this topic in detail ... 

-------------------------------------------------------------------------
John Lazzaro -- Research Specialist -- CS Division -- EECS -- UC Berkeley
lazzaro [at] cs [dot] berkeley [dot] edu     www.cs.berkeley.edu/~lazzaro
-------------------------------------------------------------------------
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Stephen Casner <[email-masked]>
Date: Fri, 31 Jan 2003 00:42:32 -0800 (PST)

> sender. This is for efficiency ...

This is really not a multi-party RTP session then, because each pair
of participants sees only their two SSRC identifiers in packets
exchanged between them.  It is an "arranged coincidence" that a given
participant uses the same SSRC for all of its point-to-point unicast
RTP sessions.

How do you avoid collisions in the choice of SSRC identifiers?  Is the
choice of SSRC coordinated at the time of session establishment?  Or
does a new participant listen for packets from all of the other
participants before choosing its own SSRC?  (This can be tricky if
multiple participants join at once.)

                                                        -- Steve