Subject: [AVT] Re: RFC3267 question regarding not sending of NO_DATA

From: Magnus Westerlund <[email-masked]>
Date: Tue, 04 Nov 2003 15:33:23 +0100

Hi Ersue,

This comment actually applies to payload format in general. If you look 
at the Octet-algined mode this section is referenced regarding the 
definition of the FT field. We should probably try to restructure this 
or make it clearer that it applies for both bandwidth-efficient and 
octet-align mode in the draft standard version.

The reasoning that it is very unnecessary to transmit NO_DATA frames 
when they instead can be deducted from the RTP TS is true for all modes, 
except interleaving where it does not hold.

I hope this clarifies it for you.

Cheers

Magnus

Ersue Mehmet wrote:

> Hi Magnus, Ari,
> 
> we are implementing RFC3267 octet aligned mode and during the 
> compliance cross check one question arose:
> 
> On page 18 in chapter 4.3.2, which belongs to chapter 
> "4.3 Bandwidth efficient mode" is written:
> 
>    "Note that packets containing only NO_DATA frames SHOULD NOT be
>    transmitted.  Also, frame-blocks containing only NO_DATA frames at
>    the end of a packet SHOULD NOT be transmitted, except in the case of
>    interleaving."
> 
> First we assumed that packets with only NO_DATA SHOULD NOT be sent 
> in Bandwith efficient mode only, because this is in the "Bandwith 
> efficient" chapter. 
> On the other hand we do not understand the remark in the next sentence, 
> because it mentions interleaving. Interleaving is defined for Octet 
> Aligned only. (See 3.8).
> 
> Are these "SHOULD NOT"s now valid also for "Octet Aligned"?
> 
> 
> Best Regards,
> Mehmet 

-- 

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Ersue Mehmet <[email-masked]>
Date: Tue, 4 Nov 2003 15:18:32 +0100

Hi Magnus, Ari,

Best Regards,
Mehmet