Subject: RE: [AVT] HC over multihop / MPLS

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Fri, 21 Nov 2003 10:51:10 -0600

Lars-Erik,

I very much appreciate your taking the time to read the draft and comment.

A lot of the questions raised at the AVT meeting are addressed in the draft, so it helps when people do read the draft.

Allison, Colin, Magnus, and I met after the meeting and agreed on the following approach for next steps:

1. split the current document http://ietf.org/internet-drafts/draft-ash-e2e-voip-hdr-comp-rqmts-01.txt into 2 requirements documents:
a. 'requirements for hop-by-hop ECRTP over MPLS' (RSVP-TE protocol extension oriented)
b. 'requirements for hop-by-hop ECRTP over IP' (SCID switching oriented)
(note that Colin suggests 'hop-by-hop' versus 'multi-hop' terminology; 'multi-hop was meant to clarify 'end-to-end' in the OO version, but still may have led to some confusion).
2. eliminate MPLS jargon such as CE, PE, etc., just talk about routers R1, R2, etc.
3. eliminate absolute performance objectives and simply state goal to 'minimize delta degradation' (for delay, jitter, pkt loss, etc.).  This includes performance degradation due to too much resync.
4. eliminate absolute scalability requirement for # of flows, and simply state goal to improve scalability of the number of compressed flows that can be handled.
5. use already standard protocols for compression, signaling, etc.

It was agreed that requirements 1a should lead to an RSVP-TE protocol extension effort and be worked in conjunction with the MPLS SG, and that requirements 1b could lead to an Informational RFC out of AVT.

Please let me know of any comments or suggestions on this plan.

I've made a few other brief comments below on your email. 

Thanks,
Jerry

> The AVT charter states the following as a WG task: 
> "to review the applicability of Compressed RTP operation on
> MPLS networks, developing extensions as necessary"
> 
> With the following milestones:
> Nov 03    Initial draft requirements for ECRTP over MPLS; 
> discuss with MPLS WG
> Nov 03    Initial draft requirements for ECRTP over MPLS; 
> discuss with MPLS WG
> 
> However, the current draft refers to "VoIP Header Compression 
> over Multi-Hop Paths", which is not the same thing. The draft
> clearly shows that compression over multihop paths is one thing, 
> and compression over MPLS another. Further, the draft takes a 
> wider scope, and talks about header compression generally,
> not only ECRTP as the charter says.
> 
> The following observations can be made:
> * If work is to done for header compression over multihop 
> and/or MPLS, it might make sense to not only address ECRTP.

Agreed.  The plan to split the requirements draft into 2 separate requirements drafts (ECRTP over MPLS, ECRTP over IP) addresses this, as outlined above.

> * The only work in this that naturally could belong in the 
> AVT WG would be to make sure ECRTP would work in these 
> scenarios.  In my understanding, this should already be 
> the case with ECRTP (as well as some ROHC profiles), which 
> is also indicated by the multihop req draft.

Agreed.

> * Header compression over multihop paths [ described by the 
> multihop req draft as where one wants to avoid 
> decompression/compression steps at intermediate routers if 
> the same compression scheme is supported at both incoming 
> and outgoing interfaces ] is fully possible also without any 
> new standards, as it would only be an implementation issue for 
> each intermediate router to bind an incoming compressed stream
> to its corresponding outgoing compressed stream. In a path 
> A->B->C, where B is the intermediate router
> negotiating use of e.g. CRTP with both A and C, it is fully 
> up to the implementation of B to avoid unnecessary 
> decompression/compression and just forward compressed packets
> as-is ("CID routing").

Agreed (requirements draft 1b, as outlined above, leading to an Informational RFC).

> * The only significant standardization work I can see is to 
> define how to do header compression (e.g. IPHC, CRTP/ECRTP, 
> ROHC) over MPLS, which is  probably a work that would require 
> some coordination with AVT and ROHC individuals, but the core
> of that work does not naturally belong to ROHC or AVT. Would
> not the MPLS WG be a more proper place?

I think the plan is to complete the requirements 1a and the follow-on protocol work in conjunction with the MPLS WG.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Tue, 25 Nov 2003 12:39:10 +0100

Jerry,

This seems like a reasonable work plan!

Rgds,
/L-E

> -----Original Message-----
> From: Ash, Gerald R (Jerry), ALABS [mailto:[email-masked]]
> Sent: den 21 november 2003 17:51
> To: Lars-Erik Jonsson (LU/EAB); [email-masked]
> Cc: Ash, Gerald R (Jerry), ALABS
> Subject: RE: [AVT] HC over multihop / MPLS
> 
> 
> Lars-Erik,
> 
> A lot of the questions raised at the AVT meeting are 
> addressed in the draft, so it helps when people do read the draft.
> 
> Allison, Colin, Magnus, and I met after the meeting and 
> agreed on the following approach for next steps:
> 
> 1. split the current document 
> http://ietf.org/internet-drafts/draft-ash-e2e-voip-hdr-comp-rq
> mts-01.txt into 2 requirements documents:
> (note that Colin suggests 'hop-by-hop' versus 'multi-hop' 
> terminology; 'multi-hop was meant to clarify 'end-to-end' in 
> the OO version, but still may have led to some confusion).
> 3. eliminate absolute performance objectives and simply state 
> goal to 'minimize delta degradation' (for delay, jitter, pkt 
> loss, etc.).  This includes performance degradation due to 
> too much resync.
> 4. eliminate absolute scalability requirement for # of flows, 
> and simply state goal to improve scalability of the number of 
> compressed flows that can be handled.
> It was agreed that requirements 1a should lead to an RSVP-TE 
> protocol extension effort and be worked in conjunction with 
> the MPLS SG, and that requirements 1b could lead to an 
> Informational RFC out of AVT.
> 
> Agreed.  The plan to split the requirements draft into 2 
> separate requirements drafts (ECRTP over MPLS, ECRTP over IP) 
> addresses this, as outlined above.
> 
> I think the plan is to complete the requirements 1a and the 
> follow-on protocol work in conjunction with the MPLS WG.
>