Subject: RE: [AVT] RTP MIB Extensions

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 21 Nov 2003 20:21:04 +0200

> -----Original Message-----
> From: Alan Clark [mailto:[email-masked]]
> Sent: 21 November, 2003 8:08 PM
> To: Romascanu, Dan (Dan); 'Colin Perkins'
> Cc: [email-masked]; [email-masked]; 'Bert Wijnen (E-mail)'
> Subject: RE: [AVT] RTP MIB Extensions
> 
> 
> 
> [Dan R] RTCP XR is an extension of RTP/RTCP. Subsequently, 
> the RTCP XR MIB is an extension of the RTP MIB. At this point 
> in the evolution of RTP, as RFC 3550 obsoletes RFC 1889, it 
> looks imperative that the necessary changes are being made to 
> the RTP MIB first, so that any extension work (like the 
> proposed work on RTCP XR MIB) is based on an updated version 
> of the MIB and standard. 
> 
> Dan
> 
> I have to disagree with you.  There is minimal overlap 
> between the two other than a need to put the RTCP XR 
> MIB/Group under the RTP MIB OID and hence they can be 
> progressed in parallel. 
> 
> At this moment there are no proposed specific changes to the 
> RTP MIB other than the draft discussed in Minneapolis and 
> hence making these serial activities would delay the progress 
> of the RTCP XR MIB work for an indefinite period, which I'm 
> sure you would not want.  There is strong interest in the use 
> of RTCP XR for VoIP fault/ performance management - I am 
> prepared to do the work needed to progress the draft and 
> would welcome your input and comments.
> 
> Regards
> 
> Alan
> 

Alan,

We need to agree to disagree:-) 

As a user of the technology, and as a MIB advisor I think that the proper way is to have the core RTP MIB updated first. I understand your wish to make progress on your specific work on RTCP XR, but the RTP MIB is the main item for this WG.  Everybody implementing RTCP-XR need to implement RTP as well, and better do its management based on an updated MIB. I hope that the RTP MIB authors will do the necessary changes soon. Maybe you can do them. The work needs not be serialized, but I think that an RTCP XR MIB should not be approved on the standards track before the RTP MIB is updated for eventual changes caused by RFC 1889 being obsolete by RFC 3550.

Regards,

Dan

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 21 Nov 2003 20:23:13 +0200

Agreed. There is no for serialization. We just need to make sure that by the time extensions MIB modules are to enter the standards track, an updated RTP MIB is already available. Dan

> From: Tom Taylor [mailto:[email-masked]]
> Sent: 21 November, 2003 8:15 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]; Colin Perkins; [email-masked]; 
> [email-masked]; Bert Wijnen (E-mail)
> Subject: Re: [AVT] RTP MIB Extensions
> 
> 
> I see no reason why the two can't be developed in parallel.  Yes, the 
> RTCP XR MIB will be an extension, but I would think the 
> updates to the 
> RTP MIB would stabilize pretty quickly.
> 
> Romascanu, Dan (Dan) wrote:
> 
> >>With regard to the relative priorities of (i) and (ii), I 
> >>recall that there
> >>seemed to be no disagreement that the RTP MIB update was 
> >>important but there
> >>was no suggestion that this was more or less important than 
> >>progressing an
> >>RTCP XR based draft.  There is considerable interest in using 
> >>RTCP XR for
> >>VoIP fault/performance management and some definite expressed 
> >>interest in
> >>seeing a MIB based on the RTCP XR metrics.
> >>
> >>Alan Clark
> >>
> >>
> >>
> > 
> > 
> > Alan,
> > 
> > RTCP XR is an extension of RTP/RTCP. Subsequently, the RTCP 
> XR MIB is an extension of the RTP MIB. At this point in the 
> evolution of RTP, as RFC 3550 obsoletes RFC 1889, it looks 
> imperative that the necessary changes are being made to the 
> RTP MIB first, so that any extension work (like the proposed 
> work on RTCP XR MIB) is based on an updated version of the 
> MIB and standard. 
> > 
> > Regards,
> > 
> > Dan
> >