Subject: Re: [AVT] Re: Additional events for 2833bis-06 - What is the influence on work with text telephony

From: "Gunnar Hellstrom" <[email-masked]>
Date: Sat, 8 Jan 2005 20:35:13 +0100

I hope you all have noticed that the work on a new revision of rfc 2833 has taken a sudden
turn to drastically reduce the number of specified signals in the basic spec, and that
most of the textphone related signals are gone.

In the earlier rfc2833bis, there was a comprehensive set of signals related to V.8,
V.8bis, V.18 and and all its submodes, so that detection of such signals could be conveyed
over IP networks.

V.25 signals, just a few V.8 signals and V.21 300bps bit values are still in the
rfc2833bis specification. There is currently a discussion in the IETF "avt" list on what
to do with all signals that were moved out of rfc2833bis.

I am not aware of any situation when detection of text telephony related signals need to
be conveyed by RFC2833 mechanisms. I still have the view that text gateways perform best
with very loose end - to - end control. Since some of the text telephony modes ( Baudot
and EDT ) carry data at the same moment that their nature can be detected, there is no
time for conveying detection information for the purpose of negotiating gateway modes, but
instead decoding and secured transmission must start immediately.

But I think that when signals for fax and modems are defined, it is important to have the
text related signals there as well, so that fax, text and modem communication can get the
same treatment.

There is text gatewaying work going on in many groups currently. If some of this work for
text gatewaying requires the text related signals of earlier versions of RFC2833bis, there
is an urgent need to participate in the discussion in IETF avt now and make sure that the
signals reappear in a specification soon.

Because of the widespread text gateway actions, I have posted this message to multiple
lists. Please regard avt to be the home base for the discussion.

Gunnar
-------------------------------------------
Gunnar Hellstrom
Omnitor AB
Renathvagen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Friday, November 19, 2004 9:18 PM
To: [email-masked]
Cc: [email-masked]
Subject: [AVT] I-D ACTION:draft-ietf-avt-rfc2833bis-06.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Working Group of the IETF.

	Title		: RTP Payload for DTMF Digits, Telephony Tones and
                          Telephony Signals
	Author(s)	: H. Schulzrinne, et al.
	Filename	: draft-ietf-avt-rfc2833bis-06.txt
	Pages		: 49
	Date		: 2004-11-19

This memo describes how to carry dual-tone multifrequency (DTMF)
   signaling, other tone signals and telephony events in RTP packets.
   This memo captures and expands upon the basic framework defined in
   RFC 2833, but retains only the most basic event codepoints.  Other
   codepoints are documented separately.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-avt-rfc2833bis-06.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of the message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-avt-rfc2833bis-06.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-avt-rfc2833bis-06.txt".

NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Tom Taylor <[email-masked]>
Date: Sat, 08 Jan 2005 20:30:35 -0500

Just to let you know: the latest intention is to capture all of the modem, FAX, 
and V.18-related events in a single document, separate from the core 
specification.  The latter will now contain only the DTMF events.

-- 
Tom Taylor
Carrier VoIP Standards Development
Nortel
Phone +1 613 763 1496  (ESN 393-1496)
E-mail: [email-masked]