Subject: [AVT] Any implementations of RFC 2833 tones payload?

From: Tom Taylor <[email-masked]>
Date: Mon, 17 Jan 2005 09:42:14 -0500

I was just reading new ITU-T Recommendation V.152 on voice-band data and found a 
statement there saying that the tones payload format in RFC 2833 (which reports a 
tone as a frequency, amplitude, and modulation) must NOT be used.

This raises the obvious question: has anyone used this payload format?  Should it 
be dropped from RFC 2833bis?

-- 
Tom Taylor
Carrier VoIP Standards Development
Nortel
Phone +1 613 763 1496  (ESN 393-1496)
E-mail: [email-masked]

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 18 Jan 2005 16:25:34 +0200

> Apologies for the misdirection: I found what I had read 
> (picked up on a quick
> scan) in V.150.1, where the prohibition is quite limited.
> 
> 15.3	Gateway Call Discrimination messages
> During this phase of MoIP Gateway operation, the following 
> signals may be transmitted or received.  The support of both 
> SSE and RFC 2833 events ANS, /ANS, ANSam and /ANSam is 
> required.  The use of Tone Packets as defined in section 4 of 
> RFC 2833 shall not be used for transporting the Answer Tone events.

Tom

I think what that is supposed to mean is that
MoIP GWs use ANS and ANSam events to trigger
transitioning into the proper modem relay state
(e.g. ANS events would trigger V.25, 
       ANSam would trigger V.8, etc)

They don't want anyone to send them generic
tone events here, since that would require more
complex logic (e.g., what if you got a 2102 Hz tone ?).

I quite agree that for well known telephony events
(DTMF, MFR1, MFCR2, COT, T.30, V.25, V.8, etc)
tailored events should be used,
and the generic message reserved for special cases.

Y(J)S