Subject: RE: [AVT] Any implementations of RFC 2833 tones payload?

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 18 Jan 2005 15:15:15 +0200

> I was just reading new ITU-T Recommendation V.152 on 
> voice-band data and found a statement there saying that the 
> tones payload format in RFC 2833 (which reports a tone as a 
> frequency, amplitude, and modulation) must NOT be used.

I went through the consented version of V.152  again
and don't see where you have found such a statement.

In clause 8 we find the following :

    8	The use of RFC 2833 modem/Facsimile/text telephone events
   The declaration of IETF RFC 2833 telephone-events ANS (32), /ANS
(33), ANSam (34) and /ANSam (35) is optional. 
   If these events are declared by a media gateway, the remote media
gateway may use RFC 2833 to transmit these events 
   in place of VBD packet transmission.  If both media gateways indicate
support of the RFC 2833 telephone-events 
   ANS (32), /ANS (33), ANSam (34) and /ANSam (35), 
   then these events shall be used by the media gateways for echo
canceller control per G.168.  
   If either end does not indicate this support then the media gateways
shall detect the 2100Hz tone 
   with phase reversals signal for echo canceller disabling on their
incoming VBD packet stream.
   When using IETF RFC 2833 telephone-events, the amount of in-band
signal leakage into the IP Network for 
   ANS, ANSam, /ANS, and /ANSam signals shall be less than 50ms.

Which simply says that any use of tone relay via 2833 is optional.

In addition, in the scope we find the statement:

  The negotiation of a VBD-capability does not exclude from a VoIP
session 
  any other capabilities such as the transport of audio signals, 
  RFC 2833-based telephone events, ITU T.38 facsimile relay, 
  RFC 2793 text relay, ITU V.150.1 modem relay etc. 

which specifically says that V.152 does not rule out any previously
defined mechanism.

> This raises the obvious question: has anyone used this 
> payload format?  Should it be dropped from RFC 2833bis?

I have found a generic tone relay function to be very useful
for drop-in toll-bypass systems. In many places you will find
non-standard tones in use for all sorts of telephony functions,
and having a generic tone may mean the difference between 
getting a system up and working in minutes,
and one that requires days of study and tweaking.

Y(J)S

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Tom Taylor <[email-masked]>
Date: Tue, 18 Jan 2005 09:17:27 -0500

Your primary message is that the format is useful.  That's great, and I'll leave 
it alone.

Apologies for the misdirection: I found what I had read (picked up on a quick 
scan) in V.150.1, where the prohibition is quite limited.

15.3	Gateway Call Discrimination messages
During this phase of MoIP Gateway operation, the following signals may be 
transmitted or received.  The support of both SSE and RFC 2833 events ANS, /ANS, 
ANSam and /ANSam is required.  The use of Tone Packets as defined in section 4 of 
RFC 2833 shall not be used for transporting the Answer Tone events.

-- 
Tom Taylor
Carrier VoIP Standards Development
Nortel
Phone +1 613 763 1496  (ESN 393-1496)
E-mail: [email-masked]