Subject: [AVT] Does from-to range have an impact on master key's lifetime

From: Chadha Retesh-A19894 <[email-masked]>
Date: Thu, 6 Jan 2005 19:05:44 +0530

RFC 3711 doesn't seem to be saying that there is a relation between from-to
and the lifetime of a master key.
 
But, in the following scenario there might be a security issue.
    RTCP lifetime is 2^31. 
    RTP lifetime is 2^48.
    And from-to range is 0-2^20.
Now, since the from-to range is valid always wrt RTP packet index. Say the
RTP packets are not sent at all, or they don't reach the upper limit, but
number of transmitted RTCP packets reached 2^30. But, from-to is used to
recycle the master keys across the session, but this doesn't seem to hold
good for RTCP packets.
 
Why don't we have a different from-to range for RTCP packets?
And is there any relation between lifetime and from-to range of RTP packets?
 
Please, let me know if i am missing something.
 
Thanks & regards
Retesh Chadha
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Mats Näslund (KI/EAB) <[email-masked]>
Date: Thu, 6 Jan 2005 16:05:45 +0100

Hi Retesh,
 
 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On Behalf Of Chadha Retesh-A19894
 > Sent: den 6 januari 2005 14:36
 > To: [email-masked]
 > Subject: [AVT] Does from-to range have an impact on master key's lifetime
 > 

 > RFC 3711 doesn't seem to be saying that there is a relation between from-to and the lifetime of a master key.
>
> Now, since the from-to range is valid always wrt RTP packet index. Say the RTP packets are not sent at all, or they don't reach the upper limit, but number of  
> transmitted RTCP packets reached 2^30. But, from-to is used to recycle the master keys across the session, but this doesn't seem to hold good for RTCP packets.
>
 
You have identified an issue which was discussed quite a lot among the authors of SRTP...
 
You are absolutely correct that if the rate of RTP packets is "degenerate", the from-to re-key mechanism
doesn't work at all, and you should use the MKI approach instead. This is mentioned in one or two places
in the RFC.
 
> Why don't we have a different from-to range for RTCP packets? 
 
We included the from-to mechanism as a "simple" mechanism, aimed at equally "simple" (and non-degenerate) 
scenarios. The robust (but requiring more bandwidth) method is to use MKI. 
 
> And is there any relation between lifetime and from-to range of RTP packets? 
 
Yes. The lifetime of the master key can be expressed as the minimum of: 
 
    2^48 RTP packets, 2^31 RTCP packets, "to" - "from" (mod 2^48). 
 
(i.e. the smallest of these three) .
  
> Please, let me know if i am missing something.
 
No, you are in principle correct.
 
Cheers
 
/Mats