Subject: [AVT] Req:Doubt regarding ILBC codec

From: "Viswanatha reddy" <[email-masked]>
Date: Thu, 2 Mar 2006 17:13:03 +0530

Hi,

This is viswanath.I am porting ILBC floating point code into fixed point.

I got a small doubt about ILBC codec floating point.

In the floating point code they are taking the input as short which is in
Q-15 form.
I don't understand this concept of taking q-15 input..

Please help me regarding this.

Thanks in advance,
Viswanath..
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: <[email-masked]>
Date: Thu, 2 Mar 2006 19:50:53 +0530

Viswanath,
 
The input to encoder or output from decoder is always in linear format i.e., 16-bit uniform PCM, while the processing could be either fixed-point or floating-point to give compressed codewords. The input will not be in floating-point domain.

Regards,
Rupesh
 
--
Rupesh W Kumbhare
Software Specialist
DSP & Multimedia Group,
Wipro Technologies
OFF: 301-515-3783
________________________________

From: Viswanatha reddy [mailto:[email-masked]]
Sent: Thu 3/2/2006 6:43 AM
To: [email-masked]
Subject: [AVT] Req:Doubt regarding ILBC codec

Hi,

In the floating point code they are taking the input as short which is in Q-15 form. 
I don't understand this concept of taking q-15 input..

Thanks in advance,
Viswanath..

---

From: "Viswanatha reddy" <[email-masked]>
Date: Thu, 2 Mar 2006 20:12:19 +0530

Hi Rupesh,

Thanks for your reply.

I am facing one more problem that when i am running the ILBC codec for
evalution purpose. My decoder output is always -32768 or 32767 though i am
getting the coder output correctly.
i am using the input given by ilbcfreeware.com.

Regards,
Viswanath..

On 3/2/06, [email-masked] <[email-masked]> wrote:
>
>  Viswanath,
>
> The input to encoder or output from decoder is always in linear format i.e.,
> 16-bit uniform PCM, while the processing could be either fixed-point or
> floating-point to give compressed codewords. The input will not be in
> floating-point domain.
>
> Regards,
> Rupesh
>
> --
>  Rupesh W Kumbhare
> Software Specialist
> DSP & Multimedia Group,
> Wipro Technologies
> OFF: 301-515-3783
>  ------------------------------
>  *From:* Viswanatha reddy [mailto:[email-masked]]
> *Sent:* Thu 3/2/2006 6:43 AM
> *To:* [email-masked]
> *Subject:* [AVT] Req:Doubt regarding ILBC codec
>
>
>
> Hi,
>