Subject: RE: [AVT] Proposed addition of time alignment for AMR in RFC 3267 bis

From: "Ejzak, Richard P (Richard)" <[email-masked]>
Date: Thu, 2 Mar 2006 10:51:31 -0600

Hi Dave,
Time alignment is only applicable to certain codecs in limited circumstances, so it's not clear that a generic solution is necessary or desirable.  Do you have other applications in mind?

Richard

> -----Original Message-----
> From: David R Oran [mailto:[email-masked]]
> Sent: Wednesday, March 01, 2006 5:25 PM
> To: Ejzak, Richard P (Richard)
> Cc: AVT
> Subject: Re: [AVT] Proposed addition of time alignment for AMR in RFC
> 3267 bis
> 
> 
> I'm wondering if this might be better abstracted into a payload- 
> format independent capability and use a framework like that in draft- 
> wenger-avt-avpf-ccm-02.txt?
> 
> Dave.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Thu, 2 Mar 2006 18:04:39 +0000

On 2 Mar 2006, at 16:51, Ejzak, Richard P (Richard) wrote:
> Time alignment is only applicable to certain codecs in limited  
> circumstances, so it's not clear that a generic solution is  
> necessary or desirable.  Do you have other applications in mind?

The point, I think, is that it's not limited to only one codec.  
Therefore we should try to develop a general mechanism, if we develop  
anything. I'm personally unconvinced that this is worth the trouble,  
but if there is a need for it, a new RTCP message would seem  
appropriate, coupled with the feedback profile. Adding it to the  
payload format doesn't seem to be a good approach.

Colin

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 02 Mar 2006 14:02:18 -0500

I'm assured by my voice quality experts that the issue is worth working 
on, for the cellular case at least. I can check under what circumstances 
it might apply in other cases.

Colin Perkins wrote:
>> circumstances, so it's not clear that a generic solution is  necessary 
>> or desirable.  Do you have other applications in mind?
> 
>

---

From: Colin Perkins <[email-masked]>
Date: Thu, 2 Mar 2006 19:09:00 +0000

On 2 Mar 2006, at 19:02, Tom-PT Taylor wrote:
> I'm assured by my voice quality experts that the issue is worth  
> working on, for the cellular case at least. I can check under what  
> circumstances it might apply in other cases.

Please do. This sort of background information is useful to include  
in drafts.

Colin

---

From: David R Oran <[email-masked]>
Date: Thu, 2 Mar 2006 14:18:03 -0500

I could imagine a good use for exact frame alignment in video coders,  
for mosaic or tiling applications.