Subject: [AVT] RE: draft-ietf-avt-hc-over-mpls-protocol-05.txt

From: "Gray, Eric" <[email-masked]>
Date: Fri, 19 May 2006 11:20:08 -0400

Andy,

	I agree with the below.

	I am having an off-line discussion with Lars-Erik about
possible issues with HC control message loss, and will get back
to you on that later. 

--
Eric

--> -----Original Message-----
--> From: Andrew G. Malis [mailto:[email-masked]] 
--> Sent: Friday, May 19, 2006 9:30 AM
--> To: Gray, Eric
--> Cc: Andrew G. Malis; Ash, Gerald R \(Jerry\); James Hand; 
--> Andy Malis; Stewart Bryant; Danny McPherson; 'Danny 
--> McPherson'; PWE3 WG (E-mail); [email-masked]
--> Subject: RE: draft-ietf-avt-hc-over-mpls-protocol-05.txt
--> 
--> Eric,
--> 
--> 
--> At 5/18/2006 15:13 -0400, Gray, Eric wrote:
--> >Andy,
--> >
--> >         I've "snipped" the points on which we appear to agree, or
--> >where no further comment seems necessary.
--> >
--> >It is conceivable, in some cases, that an LSR _might_ re-use the
--> >same label for multiple pseudo wires (even though the platform
--> >wide label space is used) in - for example - cases where a strict
--> >point-to-point connection is not what the distributing LSR is
--> >interested in setting up.  For example, this _may_ be something
--> >an LSR could do for Ethernet pseudo wires.
--> >
--> >The issue is that I do not know that this is prohibited in RFC
--> >4447, and I am pretty sure it is not explicitly forbidden in
--> >your draft.  Yes, there is an example indicating why this will
--> >not be a good idea.  However, not everybody reads the examples
--> >and - as the saying goes - what is not explicitly forbidden is
--> >allowed.
--> >
--> >(My concern is for implementers that might miss the example -
--> >  the problem scenario identified there is not something that
--> >  is likely to arise frequently in testing and verification.)
--> 
--> OK - I see you point.  We'll add to section 5.1 that unique 
--> PW labels 
--> MUST be allocated for each context.
--> 
--> 
--> >--- [SNIP] ---
--> >-->
--> >--> >MINOR COMMENTS:
--> >--> >==============
--> >--> >
--> >--> >In Figure 3, the delimination of "header" should be 
--> removed from
--> >--> >both the Link Layer and PHY portions of the diagram.  
--> It is more
--> >--> >accurate simply to show that the PDU at that level is 
--> larger by
--> >--> >some unspecified amount.  The actual formats for a 
--> variety of L2
--> >--> >and L1 PDUs is nowhere near as simple as this figure 
--> indicates.
--> >--> >
--> >--> >Figure 3 is on page 12 in version "05".
--> >-->
--> >--> I can agree for the physical layer.  However, I'm not aware
--> >--> of a link layer defined  for MPLS packets that doesn't have
--> >--> a header.
--> >-->
--> >
--> >My point is that - by explicitly delimiting "header" - you're
--> >being less accurate than if you did not do so (bad information
--> >is worse than no information).
--> 
--> How about if we add a trailer at the link layer?  All of the link 
--> layers have trailers (even ATM, since AAL5 encapsulation is being 
--> used).  But really, I think people get the point without 
--> the picture 
--> being exact.
--> 
--> Cheers,
--> Andy
--> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Malis, Andrew G." <[email-masked]>
Date: Fri, 19 May 2006 08:36:20 -0700

Eric,
 
Thanks.
 
Cheers,
Andy

________________________________

From: Gray, Eric [mailto:[email-masked]]
Sent: Fri 5/19/2006 11:20
To: Andrew G. Malis
Cc: Ash, Gerald R \(Jerry\); James Hand; Malis, Andrew G.; Stewart Bryant; Danny McPherson; 'Danny McPherson'; PWE3 WG (E-mail); [email-masked]
Subject: RE: draft-ietf-avt-hc-over-mpls-protocol-05.txt

Andy,

        I agree with the below.

--
Eric

============================================================
The information contained in this message may be privileged
and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, or an employee
or agent responsible for delivering this message to the
intended recipient, you are hereby notified that any reproduction,
dissemination or distribution of this communication is strictly
prohibited. If you have received this communication in error,
please notify us immediately by replying to the message and
deleting it from your computer. Thank you. Tellabs
============================================================
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt