Subject: [AVT] RE: Working group last call: draft-ietf-avt-rtp-g729-scal-wb-ext-04.txt

From: "SOLLAUD Aurelien RD-TECH-LAN" <[email-masked]>
Date: Fri, 5 May 2006 10:48:16 +0200

Hi

FYI, The G.729EV codec is in ITU-T Last Call  (end by may 28th).

Note that it will be released as recommendation G.729.1
So I may replace the media type audio/G729EV by audio/G7291 if it appears to be more in line with usual practices; or keep EV if the term exists in the final recommendation and stays the common name, we'll see.

Aurelien

> -----Message d'origine-----
> De : Colin Perkins [mailto:[email-masked]] 
> Envoyé : lundi 1 mai 2006 18:29
> À : IETF AVT WG
> Cc : SOLLAUD Aurelien RD-TECH-LAN
> Objet : Working group last call: 
> draft-ietf-avt-rtp-g729-scal-wb-ext-04.txt 
> 
> This is to announce a working group last call on the RTP 
> payload format for the G.729EV audio codec 
> <draft-ietf-avt-rtp-g729-scal-wb- ext-04.txt>. Please send 
> any final comments on this draft to the mailing list by 15th 
> May 2006. If no comments are received by that time, we will 
> request the IESG consider this for publication as a proposed 
> standard RFC.
> 
> Colin
> 
> 
> 
> On 25 Apr 2006, at 08:51, SOLLAUD Aurelien RD-TECH-LAN wrote:
> 
> > Hi
> >
> > This month the G.729EV codec has been approved by the 
> ITU-T. A draft 
> > spec is available for ITU members at http://www.itu.int/md/ 
> > T05-SG16-060403-TD-WP3-0152/en
> >
> > The payload format draft has been updated with the latest 
> information 
> > about the codec in the Background Section.
> > The payload format itself did not change, but some 
> clarifications are 
> > made driven by the received comments.
> >
> > I would like to request a new WGLC on this document.
> >
> > Main changes :
> > - Section 2 update, from the draft codec spec
> > - Section 6.2 example 2 changed, to be more concrete
> > - Section 6.2.x clarifications in offer-answer about G.729 
> > compatibility and new declarative usage consideration
> >
> > Aurelien

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: viswanatha reddy <[email-masked]>
Date: Fri, 5 May 2006 11:01:52 -0700 (PDT)

Hi all,
   
  I am working on fixed point for ILBC codec.
   
  i am in a strange situation. in floating point the output values are varying from 0.2 to 2pow35 where both ends are important for me. 
   
  the situation came in a all pole filter where in i have a buffer of length 40. some times my first value will start at 2 and it will goes to 2pow35 when i caluculate 30th value.
   
  Please give me some suggestion on this.
   
  Below is the C code of the filter that i am talking about
   
  void AllPoleFilter1(
       float *InOut,   /* (i/o) on entrance InOut[-orderCoef] to
                              InOut[-1] contain the state of the
                              filter (delayed samples). InOut[0] to
                              InOut[lengthInOut-1] contain the filter
                              input, on en exit InOut[-orderCoef] to
                              InOut[-1] is unchanged and InOut[0] to
                              InOut[lengthInOut-1] contain filtered
                              samples */
       float *Coef,/* (i) filter coefficients, Coef[0] is assumed
                              to be 1.0 */
       int lengthInOut,/* (i) number of input/output samples */
       int orderCoef   /* (i) number of filter coefficients */
   ){
       int n,k;
         for(n=0;n<lengthInOut;n++){
           for(k=1;k<=orderCoef;k++){
               *InOut -= Coef[k]*InOut[-k];
           }
           InOut++;
       }
   }
   
  Thanks & Regards,
  viswanath..

---------------------------------
New Yahoo! Messenger with Voice. Call regular phones from your PC and save big.