Subject: [AVT] Re: [saag] The use of AES-192 and AES-256 in Secure RTP

From: [email-masked]
Date: Fri, 19 May 2006 17:07:33 +0200

Hi all,

As a suggestion, would it be also possible to use SSRC and RTP sequence 
number different of  0000 for the AES-CM Test Vectors section.

This would avoid any endianess issue.

Regards

Laurent PILATI
Tel. + 33 (0) 4 93 00 69 34
Design Center 
Mindspeed Technologies France

David McGrew <[email-masked]> 
Sent by: [email-masked]
08/05/2006 18:17

To

Paul Hoffman <[email-masked]>
cc
AVT <[email-masked]>, [email-masked], [email-masked]

Subject
Re: [saag] The use of AES-192 and AES-256 in Secure RTP

Paul,

good points, I'm convinced that it would be better to dump AES-192 
from the spec.

David

On May 8, 2006, at 9:12 AM, Paul Hoffman wrote:

> At 12:15 PM -0700 5/4/06, David McGrew wrote:
>> The main motivation for AES-192 and AES-256 is to provide 
>> alternative ciphers to AES-128 that can be adopted in event that 
>> unforeseen advances in cryptanalysis significantly erode the 
>> security level of
>> AES-128.
>
> The downside of proposing multiple alternative ciphers, as compared 
> to just one, is that it is likely that implementers will not do 
> interop testing on all of them. It is much better to propose just 
> one fall-back cipher. This is particularly true for AES, as we have 
> discovered in the VPNC test lab.
>
> For IETF standards where AES-128 is a MUST-level requirement, there 
> should be just one fall-back, AES-256, with wording like the "SHOULD 
> +" definitions in RFC 4307.
>
> --Paul Hoffman, Director
> --VPN Consortium

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: David McGrew <[email-masked]>
Date: Mon, 22 May 2006 14:57:54 -0700

Hi Laurent,

using an SSRC different from 0x0000 in (at least one of) the test  
vectors is a very good suggestion!

David

On May 19, 2006, at 8:07 AM, [email-masked] wrote:

>
> Hi all,
>
> As a suggestion, would it be also possible to use SSRC and RTP  
> sequence number different of  0000 for the AES-CM Test Vectors  
> section.
>
> cc	AVT <[email-masked]>, [email-masked], [email-masked]
> Subject	Re: [saag] The use of AES-192 and AES-256 in Secure RTP
>
>
>
>
>
>
> Paul,
>