Subject: [AVT] interdigit delay with rfc 2833

From: "Murat Artun" <[email-masked]>
Date: Tue, 6 Jun 2006 19:27:21 +0300

Hello,

I want to ask how the interdigit delays could be implemented and generated
with RFC 2833 payload type.

Kind Regards

-- 
M u r at  A r t u n, MSc.
   Software Engineer
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 06 Jun 2006 13:22:34 -0400

They are implicit in the gaps between the timestamps assigned to the 
tone event reports. That is, silent period = Timestamp of new event - 
(Timestamp of old event plus event duration).

Murat Artun wrote:
> Hello,
> 
> I want to ask how the interdigit delays could be implemented and generated with RFC 2833 payload type.
> 
> Kind Regards
> 
> 
> 
> ------------------------------------------------------------------------
>

---

From: "Murat Artun" <[email-masked]>
Date: Thu, 8 Jun 2006 17:07:39 +0300

I have one more question to clarify a point: When we send DTMF digits as
individually (by not using redundancy mechanism), it seems as if it is
impossible to rely on the timestamp of the next digit. Because, we can never
be sure that when the END bit for that digit will be received and when the
next digit will start.

So, can we conclude that to implement interdigit delays it is mandatory to
receive the digits with redundancy mechanism?

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 08 Jun 2006 11:21:26 -0400

I think you're right. The only alternative would be that when the 
receiving gateway received a report of a new event, if it had not 
stopped playing out the old one, it would deliberately insert the 
minimum required amount of silence before playing out the new one. That 
could mean clipping of whatever eventually follows the DTMF.