Subject: [AVT] comment on RFC2833

From: "Aleksandar Lebl" <[email-masked]>
Date: Mon, 12 Jun 2006 13:24:08 +0200

Hi all,
we want to excuse for late comments on RFC2833biscas-01, after its expiry date.

Our comment deals with sending analog R2 line signals, as defined in RFC2833biscas-01. In
2.3.1. of RFC2833biscas-01 is defined that the event code 144 is used for "tone on" condition,
and the event code 159 is used for "tone-off" condition, which means that bit(s) A(BCD) take
values 0(000) for "tone-on" condition and 1(111) for "tone-off" condition.

In the case of E1 (2048kb/s) digital link (ITU-T Recommendation G.704) that is not possible.
According to table 14 in ITU-T Recommendation G.704, note 3, it is recommended that values
of unused bits be b(B)=1, c(C)=0, d(D)=1. It is also recommended not to use combination 0000
(reserved for multiframe alignment) for signalling of channels 1 to 15.
So, we suggest introduction of new codes for "tone on" and "tone off" signals of R2 signalling.

1. For the analog R2 line signals shown in Table 1 of ITU-T Recommendation Q.411, and E1
digital links, implementations MUST map as follows.

    * event code 149 (ABCD=0101, Table 1) is used to indicate the Q.411 "tone-on" condition

    * event code 157 (ABCD=1101, Table 1) is used to indicate the Q.411 "tone-off" condition

2. The digital R2 line signals as described by ITU-T Recommendation Q.421 are carried in
two bits, A and B. The mapping between A and B bit values and event codes SHALL be the
same in both directions. The values of unused bits C and D MUST be C=0 and D=1.

3. It is obvious that the signal 3 (900Hz/1020Hz) in table 5 of RFC2833biscas-01 is defined
as Fwd 3 instead of Bkwd 3.

                                Zarko Markov and Aleksandar Lebl
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 12 Jun 2006 09:36:47 -0400

I'm grateful for your comments and the references you have supplied. I'm 
hoping to update the draft later this week, and I'll follow up on your 
comments at that point.

Aleksandar Lebl wrote:
> ------------------------------------------------------------------------
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 16 Jun 2006 15:12:44 -0400

I have had a chance to review Rec. G.704 today. It appears that the rule 
for populating unused bits is different for different types of 
transmission facility. In particular, T1 framing (used in North America) 
has the used bits propagate into the unused bits the way we have it in 
2833biscas-01. E1 framing (used in Europe and I'm not sure where else) 
has fixed values for unused bits, as Aleksandar points out. This 
presents us with an interoperability problem if the receiving end 
doesn't know how many bits the sending end is using and also doesn't 
know what kind of facility is being emulated.

Would it make sense to use the present event codes for full ABCD 
signalling, but allocate six more codes for AB and A signalling? That 
would remove ambiguity and make using gateways interoperable across 
different transmission facilities.