Subject: [AVT] Interpretation question about RFC 3551 & G.729B

From: "McMahon, Tom-P57170" <[email-masked]>
Date: Tue, 27 Jun 2006 09:02:31 -0700

In a scenario where G.729B is being used with a 40ms packetization
interval, would SID and "untransmitted" frames affect the phasing of the
packetization and packet size?  Specifically, given the requirement that
there may be at most one SID frame and the end of a packet, would
intermittent SID and untransmitted frames cause subsequent packets to
move from integral 40ms boundaries? 
 
As an example, in the following sequence of 10ms samples, where a=active
voice, u=unstransmitted, and s=sid:  
 
          1111111111
01234567890123456789   - timestamp / 10ms 
aaaaaasuusuaaaaaaaaa   - sample type
 
It seems that the packets would look like the following:  
 
           1    1    1 
0    4   9 1    5    9   - timestamp / 10ms 
aaaa aas s aaaa aaaa a...  - sample type
 
which would cause the packets to not always be sent on an integral 40ms
boundary (i.e. 0ms, 40ms, 80ms, 120ms, 160ms), but instead would be sent
whenever an active or SID frame is discovered after a SID or
untransmitted frame (i.e. 0ms, 40me, 90ms, 110ms, 150ms, 190ms in this
example). 
 
This would also imply that, despite negotiating a 40ms rate, some
packets will contain fewer than 40 samples.  
 
Have I interpreted the behavior correctly? 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "SOLLAUD Aurelien RD-TECH-LAN" <[email-masked]>
Date: Wed, 28 Jun 2006 14:17:10 +0200

Yes
 
Since SID can happen at any time and are always at the end of the RTP packet, you will not always have "40ms" packets.

________________________________

	De : McMahon, Tom-P57170 [mailto:[email-masked]] 
	Envoyé : mardi 27 juin 2006 18:03
	À : [email-masked]
	Objet : [AVT] Interpretation question about RFC 3551 & G.729B

	In a scenario where G.729B is being used with a 40ms packetization interval, would SID and "untransmitted" frames affect the phasing of the packetization and packet size?  Specifically, given the requirement that there may be at most one SID frame and the end of a packet, would intermittent SID and untransmitted frames cause subsequent packets to move from integral 40ms boundaries? 
	 
	As an example, in the following sequence of 10ms samples, where a=active voice, u=unstransmitted, and s=sid:  
	 
	          1111111111

	           1    1    1 
	 
	which would cause the packets to not always be sent on an integral 40ms boundary (i.e. 0ms, 40ms, 80ms, 120ms, 160ms), but instead would be sent whenever an active or SID frame is discovered after a SID or untransmitted frame (i.e. 0ms, 40me, 90ms, 110ms, 150ms, 190ms in this example). 
	 
	This would also imply that, despite negotiating a 40ms rate, some packets will contain fewer than 40 samples.