Subject: [AVT] Cannot express H.264/AVC level 1b in RFC 3984

From: Per Fröjdh (KI/EAB) <[email-masked]>
Date: Tue, 19 Sep 2006 17:32:59 +0200

Dear AVT experts, RFC 3984 authors,

I'm not aware if there is already a discussion regarding
the signalling of H.264/AVC level 1b in RFC 3984. 
Currently this is not defined since the definition of 
profile-level-id does not include constraint_set3_flag.

profile-level-id is a hexadecimal representation of:
(cut and paste from RFC 3984 plus som formatting)
 
1) profile_idc
2) a byte herein referred to as profile-iop, 
composed of the values of 
  constraint_set0_flag, 
  constraint_set1_flag, 
  constraint_set2_flag, 
and reserved_zero_5bits in bit-significance order, 
starting from the most significant bit, and 
3) level_idc. 

Note that reserved_zero_5bits is required to be
equal to 0 in [1], but other values for it may
be specified in the future by ITU-T or ISO/IEC.

(end cut and paste from RFC 3984)

In 3GPP we use level 1b of H.264. This level was added
later and it is signalled as level 1.1 together with
constraint_set3_flag set to 1.

The natural generalization of the profile-level-id
defined in RFC 3984 would be (following the syntax
of sequence parameter sets) to replace the first
reserved bit above with constraint_set3_flag.

We can of course include a note in the 3GPP specs that
this is how we signal level 1b. A long term solution 
would be to update 3984 though. Is there such an effort 
already ongoing?

Examples applicable to 3GPP Release 6 would be

Baseline level 1:
profile-level-id=42e00a

Baseline level 1b:
profile-level-id=42f00b

(constraint set 0,1 and 2 flags indicate that Baseline,
Main and Extended profile decoders can decode the bitstream)

In principle OK, but the second case (level 1b) corresponds
to an undefined value in RFC 3984.

Best regards,
Per

----------------------------------------------------------------
Per Fröjdh, Ph.D.                              Tel +46 8 4048188
Ericsson Research, Multimedia Technologies     Mob +46 730312413

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Dave Singer <[email-masked]>
Date: Tue, 19 Sep 2006 10:38:31 -0700

My read of 3984 is that it says "you put in a hex 
representation of that byte, which was defined at 
the time of writing as...", which means exactly 
what you're suggesting.

I'm not sure an 3984bis is really warranted for 
such a small clarification, but that a note in 
the 3G specs might be in order.

-- 
David Singer
Apple Computer/QuickTime