Subject: [AVT] RTP EVRC WB draft questions

From: "Yuval Nissan" <[email-masked]>
Date: Sun, 11 Mar 2007 12:34:26 +0200

Hi,

We have few questions regarding this draft:

- We don't understand the meaning of the parameters "rcvmode" and
"sendmode" in case of compact bundling mode (EVRCB1,EVRCWB1). Doesn't
the rate is fixed and determined only by "fixedrate" parameter?

-It is written that "EVRC-WB mode 4 interoperable with EVRC-B ...".
Isn't EVRC-WB mode 7 also interoperable (according to Table 2.5.1.2-1
Service Option 70 Encoding rate control parameters) in [5]? 

-Shouldn't the "fixedrate" parameter be described also in the EVRCB1
section (9.6)?

Regards,

Yuval

 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Desineni, Harikishan" <[email-masked]>
Date: Mon, 12 Mar 2007 14:56:33 -0700

Thanks for reviewing draft-ietf-avt-rtp-evrc-wb-00.txt. Please see my comments inline - prefixed with [Hari]

________________________________________
From: Yuval Nissan [mailto:[email-masked]] 
Sent: Sunday, March 11, 2007 3:34 AM
To: [email-masked]
Cc: Eli Shoval
Subject: [AVT] RTP EVRC WB draft questions

Hi,
We have few questions regarding this draft:
- We don't understand the meaning of the parameters "rcvmode" and "sendmode" in case of compact bundling mode (EVRCB1,EVRCWB1). Doesn't the rate is fixed and determined only by "fixedrate" parameter?

[Hari] Yes. Fixed rate frames can be produced in several modes of EVRC-WB/EVRC-B. "sendmode" can be used to signal the encoder's current mode. "rcvmode" can be used to signal the remote encoder to operate in a specific mode.
 
-It is written that "EVRC-WB mode 4 interoperable with EVRC-B ...". Isn't EVRC-WB mode 7 also interoperable (according to Table 2.5.1.2-1 Service Option 70 Encoding rate control parameters) in [5]? 
 
[Hari] You are correct. We will change the text to "EVRC-WB mode 4 interoperable with EVRC-B mode 0 and EVRC-WB mode 7 is interoperable with EVRC-B mode 7". The draft is not updated after the publication of [5]

-Shouldn't the "fixedrate" parameter be described also in the EVRCB1 section (9.6)?

[Hari] Yes, it should be. We will add it in the next version (-01) of the draft. 

Another change that will appear in -01, which is relevant to EVRC-WB MIME types: semicolon is the separator for parameter=value pairs in a=fmtp lines. In -00, space is used as the separator.

Thanks,
Hari