Subject: [AVT] Video streaming withour RTCP

From: <[email-masked]>
Date: Fri, 30 Mar 2007 18:41:01 +0530

Hi, 
  
     Can video(with audio) streaming is possible with out RTCP?  RTCP
packets are used for lip sync. I suppose!!  If it is so, then with out RTCP
how can we achieve audio & video that is lip sync.??

Thanks & Regards,
Vamsi

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Franceschini Guido" <[email-masked]>
Date: Fri, 30 Mar 2007 16:19:22 +0200

Ten years ago, I was asking myself (and not just myself) whether the RTP/RTCP framework wasn't maybe an overkill for my simple use-case.
And I still believe it was.
So I was tempted to redesign my own RTP/RTCP, and cut out a lot of useless stuff.
Someone convinced me that this was a bad idea, and he was absolutely right.

Ten years later, I must say that the RTP/RTCP framework is indeed a great overkill. Because as soon as my simple use-case evolved a little bit, and then another bit and then another bit, and now is not anymore as simple as it was originally ... well, the RTP/RTCP framework still supports my evolving needs.

Concerning your scenario. You need the wallclock to sync audio and video. You need reporting packet losses at least for video.
You will soon need recognizing SSRCs, evaluating jitter and RTTs. And then interoperate with some device that requires RTCP.

Just use it.

Have fun
Guido

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: venerdì 30 marzo 2007 16.04
> To: 'David R Oran'
> Cc: [email-masked]
> Subject: RE: [AVT] Video streaming withour RTCP
> 
> 
> Hi David, 
>  
>      Thanks for your reply.  So, its better to use RTCP for 
> VIDEO.  In a
> unicast session, even if I wont use rtcp then there might be 
> no issues I
> suppose as compared to that of video session!  
> 
> Thanks & regards,
> Vamsi
> 
> -----Original Message-----
> From: David R Oran [mailto:[email-masked]] 
> Sent: Friday, March 30, 2007 7:26 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [AVT] Video streaming withour RTCP
> 
> 
> On Mar 30, 2007, at 9:11 AM, <[email-masked]> wrote:
> 
> > Hi,
> >
> Unless you use some stream-internal multiplexing and timing method  
> (like MPEG2TS), you can't. Just implement RTCP. Your life will be  
> much better for it.
> 
> > Thanks & Regards,
> > Vamsi
> >
> >
> >
--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------