Subject: RE: [AVT] RTP EVRC WB draft questions

From: "Yuval Nissan" <[email-masked]>
Date: Tue, 13 Mar 2007 09:28:45 +0200

I will try to explain my first question by few examples:

If I configure EVRCB1 with:
-Sendmode=0 and fixedrate=1
-Sendmode=1 and fixedrate=1 
 
Won't the result be the same (because the fixed rate overrides the sendmode)?

Another example for EVRCB1:
Sendmode=7, fixedrate=1

Sendmode equal 7 means max rate is 1/2, but fixedrate equal 1 means the rate is always 1, so how the sender should work?

My point is that the 'mode' determines the average bit-rate, which is achieved by changing the coder rate at each frame, and that can't work when the rate is fixed.

In EVRC-WB the mode has also another new meaning - it tells if the coder works in WB or NB points, right? This is the only reason I see why we need this field in compact bundling.

Please explain.

Yuval

-----Original Message-----
From: Desineni, Harikishan [mailto:[email-masked]] 
Sent: Monday, March 12, 2007 11:57 PM
To: Yuval Nissan
Cc: Eli Shoval; [email-masked]
Subject: RE: [AVT] RTP EVRC WB draft questions 

Thanks for reviewing draft-ietf-avt-rtp-evrc-wb-00.txt. Please see my comments inline - prefixed with [Hari]

________________________________________
From: Yuval Nissan [mailto:[email-masked]] 
Sent: Sunday, March 11, 2007 3:34 AM
To: [email-masked]
Cc: Eli Shoval
Subject: [AVT] RTP EVRC WB draft questions

Hi,
We have few questions regarding this draft:
- We don't understand the meaning of the parameters "rcvmode" and "sendmode" in case of compact bundling mode (EVRCB1,EVRCWB1). Doesn't the rate is fixed and determined only by "fixedrate" parameter?

[Hari] Yes. Fixed rate frames can be produced in several modes of EVRC-WB/EVRC-B. "sendmode" can be used to signal the encoder's current mode. "rcvmode" can be used to signal the remote encoder to operate in a specific mode.
 
-It is written that "EVRC-WB mode 4 interoperable with EVRC-B ...". Isn't EVRC-WB mode 7 also interoperable (according to Table 2.5.1.2-1 Service Option 70 Encoding rate control parameters) in [5]? 
 
[Hari] You are correct. We will change the text to "EVRC-WB mode 4 interoperable with EVRC-B mode 0 and EVRC-WB mode 7 is interoperable with EVRC-B mode 7". The draft is not updated after the publication of [5]

-Shouldn't the "fixedrate" parameter be described also in the EVRCB1 section (9.6)?

[Hari] Yes, it should be. We will add it in the next version (-01) of the draft. 

Another change that will appear in -01, which is relevant to EVRC-WB MIME types: semicolon is the separator for parameter=value pairs in a=fmtp lines. In -00, space is used as the separator.

Thanks,
Hari

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Desineni, Harikishan" <[email-masked]>
Date: Tue, 13 Mar 2007 11:00:34 -0700

> Won't the result be the same (because the fixed rate overrides the

If you carefully look at the definition of 'sendmode', it is just
informing the encoder's current mode of operation. EVRCB1 with fixed
rate can be produced in several encoder modes. As given in your example,
several sendmode values are possible when using fixedrate=1. 

> Another example for EVRCB1:

This is not a valid combination from [5]

> 
> Sendmode equal 7 means max rate is 1/2, but fixedrate equal 1 means
the
> rate is always 1, so how the sender should work?

Encoder cannot be in mode 7 when using fixed rate. Hence the sender
should not use mode value 7 when fixedrate=1. Remember that 'sendmode'
is simply informing the 'current' mode of operation of the encoder. 
> 
> My point is that the 'mode' determines the average bit-rate, which is
> achieved by changing the coder rate at each frame, and that can't work
> when the rate is fixed.

Irrespective of which rate (full or half) a sender is using, its encoder
has to stay in one of the possible modes. 'sendmode' is an optional
parameter that can be used to provide this information. 

> 
> In EVRC-WB the mode has also another new meaning - it tells if the
coder
> works in WB or NB points, right? This is the only reason I see why we
need
> this field in compact bundling.

Yes, you are correct. 'sendmode' makes more sense for EVRC-WB.

> - We don't understand the meaning of the parameters "rcvmode" and
> "sendmode" in case of compact bundling mode (EVRCB1,EVRCWB1). Doesn't
the
> rate is fixed and determined only by "fixedrate" parameter?
> 
> [Hari] Yes. Fixed rate frames can be produced in several modes of
EVRC-
> WB/EVRC-B. "sendmode" can be used to signal the encoder's current
mode.
> "rcvmode" can be used to signal the remote encoder to operate in a
> specific mode.
> 
> -It is written that "EVRC-WB mode 4 interoperable with EVRC-B ...".
Isn't
> EVRC-WB mode 7 also interoperable (according to Table 2.5.1.2-1
Service
> Option 70 Encoding rate control parameters) in [5]?
> 
> [Hari] You are correct. We will change the text to "EVRC-WB mode 4
> interoperable with EVRC-B mode 0 and EVRC-WB mode 7 is interoperable
with
> EVRC-B mode 7". The draft is not updated after the publication of [5]
> 
> [Hari] Yes, it should be. We will add it in the next version (-01) of
the
> draft.
> 
> Another change that will appear in -01, which is relevant to EVRC-WB
MIME
> types: semicolon is the separator for parameter=value pairs in a=fmtp
> lines. In -00, space is used as the separator.
> 
> Thanks,
> Hari
> 
> 
>

---

From: "Desineni, Harikishan" <[email-masked]>
Date: Thu, 22 Mar 2007 11:31:39 -0700

Hi,

Given that sendmode is not useful for EVRCB1 MIME type, I decided to
remove the MIME update for EVRCB1 from this draft. Sendmode will
continue to exist for EVRCWB1. Let me know if you have any comments on
this.

Thanks,
Hari

> Sent: Tuesday, March 13, 2007 11:01 AM
> To: Yuval Nissan
> > Thanks for reviewing draft-ietf-avt-rtp-evrc-wb-00.txt. Please see
my
> > comments inline - prefixed with [Hari]
> >

---

From: "Yuval Nissan" <[email-masked]>
Date: Thu, 22 Mar 2007 22:29:16 +0200

Hari,
I think that also recvmode isn't useful from the same reason as below.
 
To my understanding it will be better not to use sendmode and recvmode in case of fixed rate(EVRCB1, EVRCWB1), and instead to define these parameters:
 
recvfixedrate
sendfixedrate
 
In that way you add another ability that each side can tell the other side in which fixed rate to work, and make the interface more intuitive. 
 
In EVRC-WB there is still the problem that the mode determines also if working in WB or NB, so here you can add another parameter like: coderbandwithmode.
 
What do you think?
 
Regards,
Yuval

________________________________

מאת: Desineni, Harikishan [mailto:[email-masked]]
נשלח: ה 22/03/2007 20:31
אל: Yuval Nissan
עותק לידיעה: Eli Shoval; [email-masked]
נושא: RE: [AVT] RTP EVRC WB draft questions 

Hi,

Thanks,
Hari

my

---

From: "Yuval Nissan" <[email-masked]>
Date: Thu, 22 Mar 2007 22:55:49 +0200

Another change that might be possible it to extend the table of recvmode and sendmode to specail modes for the fixed rate, like:
mode = xxx - rate is fixed to 1/2, NB
mode = xxx+1 - rate is fixed to  1, NB
mode = xxx+2 - rate is fixed to  1/2, WB
mode = xxx+3 - rate is fixed to  1, WB
 
and than you don't need the fixedrate parameter anymore.
 
Regards,
Yuval

מאת: Yuval Nissan
נשלח: ה 22/03/2007 22:29
אל: Desineni, Harikishan

Hari,

recvfixedrate
sendfixedrate

 
What do you think?
 
Regards,
Yuval

Hi,

Thanks,
Hari

my

---

From: "Yuval Nissan" <[email-masked]>
Date: Fri, 23 Mar 2007 00:03:12 +0200

For EVRCWB1:
The idea to add new coder modes isn't meant to avoid SDP parameter, but to avoid illegal set-up combination that can occur because of the meaning overlapping.
 
Regards,
Yuval

נשלח: ה 22/03/2007 23:29

I’ll remove EVRCB1 MIME update. Both sendmode and recvmode will go away from EVRCB1.

For EVRCWB1:

Sendmode is still useful to differentiate between WB and NB fixed rates. Default sendmode for EVRCWB1 can be 0 (WB). Mode-set-recv can be used to signal the sender to produce fixed rate frames in one of the signaled modes. For example, mode-set-recv = 4, 7 (mode-set-recv = 4 and mode-set-recv = 7) signals the sender to produce fixed rate frames in NB. Mode-set-recv=7 with fixedrate=1 is not a valid combination according to [5].

Wideband modes are defined in [5]. They are common for both circuit switched and packet switched operation. It is not a good idea to introduce new codec modes to avoid an SDP parameter. 

From: Yuval Nissan [mailto:[email-masked]] 
Sent: Thursday, March 22, 2007 1:56 PM
To: Desineni, Harikishan
Cc: Eli Shoval; [email-masked]
Subject: RE: [AVT] RTP EVRC WB draft questions 

Regards,

Yuval

---

From: "Desineni, Harikishan" <[email-masked]>
Date: Thu, 22 Mar 2007 14:29:40 -0700

For EVRCWB1:

 

 

Regards,

Yuval

מאת: Yuval Nissan
נשלח: ה 22/03/2007 22:29
אל: Desineni, Harikishan

Hari,

recvfixedrate

sendfixedrate

What do you think?

Regards,

Yuval

Hi,

Thanks,
Hari

my

---

From: "Desineni, Harikishan" <[email-masked]>
Date: Thu, 22 Mar 2007 16:19:36 -0700

The invalid combination is not allowed in [5] and hence it must not appear in SDP. Would it help to clarify that combinations of ‘sendmode’/’recv-mode-set’ and ‘fixedrate’ disallowed by [5] MUST not be used in SDP?

From: Yuval Nissan [mailto:[email-masked]] 
Sent: Thursday, March 22, 2007 3:03 PM
To: Desineni, Harikishan
Cc: Eli Shoval; [email-masked]
Subject: RE: [AVT] RTP EVRC WB draft questions 

For EVRCWB1:

Regards,

Yuval

For EVRCWB1:

 

 

Regards,

Yuval