Subject: [AVT] I-D Action:draft-ietf-avt-seed-srtp-05.txt

From: [email-masked]
Date: Thu, 18 Sep 2008 08:15:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Working Group of the IETF.

	Title           : The SEED Cipher Algorithm and Its Use with the Secure Real-time Transport Protocol (SRTP)
	Author(s)       : I. Property
	Filename        : draft-ietf-avt-seed-srtp-05.txt
	Pages           : 12
	Date            : 2008-09-18

This document describes the use of the SEED block cipher algorithm in 
the Secure Real-time Transport Protocol (SRTP) for providing 
confidentiality for the Real-time Transport Protocol (RTP) traffic 
 
 and for the control traffic for RTP, the Real-time Transport Control 
Protocol (RTCP).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-avt-seed-srtp-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: 윤석웅 <[email-masked]>
Date: Fri, 19 Sep 2008 01:15:56 +0900 (KST)

WINiPMail Mail

Hi, all

We just submitted -05 of SEED-SRTP.

It was modified according to comments from Roni.

Any comments are really appreciated.

BR,

Seokung

----- 메일의 원문 -----

From: [email-masked]

Sent: Fri Sep 19 00:15:02 KST 2008

To: [email-masked]

Cc: [email-masked]

Subject: [AVT] I-D Action:draft-ietf-avt-seed-srtp-05.txt

Author(s) : I. Property

Pages : 12

Date : 2008-09-18

Protocol (RTCP).

Internet-Draft.

[email-masked]

---

From: Mats Näslund <[email-masked]>
Date: Fri, 19 Sep 2008 16:42:19 +0200

Hi

I have two comments/questions on the draft.

When you replace AES_CM with SEED_CM, does it apply only to encryption?
I.e. will you still use AES_CM for key derivations?

The CCM mode as I understand first applies authentication, _then_ encrypts.
Strictly speaking, this does not fit with RFC3711 which first encrypts
and then authenticates (from RFC3711):

3.3.  SRTP Packet Processing

   ... the sender SHALL do the following to
   construct an SRTP packet:

   1. ...

	...

   5. Encrypt the RTP payload ...

	...

   7. For message authentication, compute the authentication tag ...

I think at least you should point out that you do not follow the general
processing order of RFC3711.

BR

/Mats

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: den 18 september 2008 17:15
> 	Title           : The SEED Cipher Algorithm and Its Use 
> with the Secure Real-time Transport Protocol (SRTP)
> 	Author(s)       : I. Property
> This document describes the use of the SEED block cipher 
> algorithm in the Secure Real-time Transport Protocol (SRTP) 
> for providing confidentiality for the Real-time Transport 
> Protocol (RTP) traffic 
>  
>  and for the control traffic for RTP, the Real-time Transport 
> Control Protocol (RTCP).
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
>