Subject: Re: [AVT] MPEG2 Streaming Over internet

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Sep 2008 13:51:50 +0300

This question is more in scope for the AVT list (CC'ed.)

Lars

On 2008-9-27, at 16:24, ext Sumit Aggarwal wrote:

> Hi All,
> i want to know, if i want to stream MPEG2 TS over internet(unicast/ 
> brodcast)
> using RTP and receive it on TV, what are the fields in TS i should  
> update by
> streaming server.
> i mean what are the fields in TS should be updated before streaming  
> (Like
> PCR, PTS ..DTS) so that my TV decoder can understand the stream  
> properly.
> Is there any global standard followed which is accepted by all the  
> TVs.
> May be this is very basic question, but the problem i am facing is  
> when i
> stream using RTP with out modifying any field in TS, TV decoder is  
> not able
> to display it properly. But when i stream the TS using VLC, TV is  
> able to
> display the picture perfectly.
> Regards
> Sumit
> _______________________________________________
> Apps-Discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: "Trevor Dyck" <[email-masked]>
Date: Tue, 30 Sep 2008 16:46:48 -0700

Sumit,

You need to essentially follow the MPEG-2 TS standard (ISO/IEC 13818-1)
in detail.  This describes the correct way to generate a compliant
MPEG-2 TS that can be decoded by any decoder that is MPEG-2 TS
compliant.

Trevor Dyck
Zeugma Systems

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Lars Eggert
Sent: Tuesday, September 30, 2008 3:52 AM
To: ext Sumit Aggarwal
Cc: AVT Lista; [email-masked]
Subject: Re: [AVT] MPEG2 Streaming Over internet

Lars

On 2008-9-27, at 16:24, ext Sumit Aggarwal wrote:

> update by streaming server.
> (Like PCR, PTS ..DTS) so that my TV decoder can understand the stream 
> properly.
> when i stream using RTP with out modifying any field in TS, TV decoder

> is not able to display it properly. But when i stream the TS using 
> VLC, TV is able to display the picture perfectly.
> Regards
> Sumit

---

From: "Sandy (Alexander) MacInnis" <[email-masked]>
Date: Tue, 30 Sep 2008 17:40:27 -0700

Assuming the MPEG-2 TS stream you start out with conforms to the standard, and the problem is that carrying it over RTP results in some timing variation i.e. jitter which the decoder does not tolerate, then what you need is a jitter removal function after the RTP reception and before the decoder that takes in MPEG-2 TS.

There are various ways to do this. The MPEG-2 TS (ISO/IEC 13818-1) standard tells you what characteristics the stream has to have, but not how to do this conversion.

FYI - there is also MPEG-2 part 9, which is a spec on jitter applied to transport streams - but it also doesn't tell you how to do it. It may not be very helpful in this context.

How good a job you have to do of eliminating jitter depends on the decoder. Some of them may require strictly compliant, no-jitter streams, while others may tolerate some jitter.

--Sandy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Trevor Dyck
Sent: Tuesday, September 30, 2008 4:47 PM
To: ext Sumit Aggarwal
Cc: AVT Lista
Subject: Re: [AVT] MPEG2 Streaming Over internet

Sumit,

Trevor Dyck
Zeugma Systems

-----Original Message-----

Lars

---

From: "Sumit Aggarwal" <[email-masked]>
Date: Wed, 1 Oct 2008 13:14:56 +0900

Thanks for the reply.

I think the problem i am facing is not because of network jitter because i
am uni casting using RTP by connecting cross cable. As i am writing the
streaming server also with myself, i am suspecting it.
I want to know, while streaming do i need to update/modify the PCR/PTS/DTS
or any other field in transport stream.

Regards,
Sumit.

On Wed, Oct 1, 2008 at 9:40 AM, Sandy (Alexander) MacInnis <
[email-masked]> wrote:

> Assuming the MPEG-2 TS stream you start out with conforms to the standard,
> and the problem is that carrying it over RTP results in some timing
> variation i.e. jitter which the decoder does not tolerate, then what you
> need is a jitter removal function after the RTP reception and before the
> decoder that takes in MPEG-2 TS.
>
> There are various ways to do this. The MPEG-2 TS (ISO/IEC 13818-1) standard
> tells you what characteristics the stream has to have, but not how to do
> this conversion.
>
> FYI - there is also MPEG-2 part 9, which is a spec on jitter applied to
> transport streams - but it also doesn't tell you how to do it. It may not be
> very helpful in this context.
>
> How good a job you have to do of eliminating jitter depends on the decoder.
> Some of them may require strictly compliant, no-jitter streams, while others
> may tolerate some jitter.
>
> --Sandy
>

---

From: "Greg Herlein" <[email-masked]>
Date: Tue, 30 Sep 2008 21:18:27 -0700

Can you explain more about what you are actually trying to do?  What is
generating your RTP?  What is the source of your transport stream?  Is it
one long stream or are you splicing files together?  If so, how?  What is at
the TV that is receiving the RTP and decoding the transport stream?  We
might be able to point you at help if we knew more.

Greg

On Tue, Sep 30, 2008 at 9:14 PM, Sumit Aggarwal <[email-masked]>wrote:

>> There are various ways to do this. The MPEG-2 TS (ISO/IEC 13818-1)
>> standard tells you what characteristics the stream has to have, but not how
>> to do this conversion.
>>
>> How good a job you have to do of eliminating jitter depends on the
>> decoder. Some of them may require strictly compliant, no-jitter streams,
>> while others may tolerate some jitter.
>>
>> --Sandy
>>