Subject: [AVT] Question about sound-level indication in RTP

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Sat, 1 Aug 2009 11:23:33 -0700

I have a question, which might be actually out of scope of this draft.

Consider a concert-like scenario where there are multiple instruments that are collectively producing some sort of music. Suppose that each of the instruments is actually packetizing its digitized audio and sending it over IP/RTP to a recorder or some sort of sink. Instead of recording the aggregated music at that time, each stream is recorded individually and they can be mixed, multiplexed, etc. later in any desired way. Or, of course, they can be transported individually for whatever reason.

In this context, would sound-level indicators be useful to aid other elements in the system when they need to process the stream(s)?

If this is something already done, any pointers are appreciated. If not, comments would be welcome.

-acbegen

---

From: Enrico Marocco <[email-masked]>
Date: Sat, 1 Aug 2009 21:21:47 +0200

Ali C. Begen (abegen) wrote:
> Consider a concert-like scenario where there are multiple instruments
> that are collectively producing some sort of music. Suppose that each
> of the instruments is actually packetizing its digitized audio and
> sending it over IP/RTP to a recorder or some sort of sink. Instead of
> recording the aggregated music at that time, each stream is recorded
> individually and they can be mixed, multiplexed, etc. later in any
> desired way. Or, of course, they can be transported individually for
> whatever reason.
> 
> In this context, would sound-level indicators be useful to aid other
> elements in the system when they need to process the stream(s)?
> 

We didn't actually think of the concert use case. Just off the top of my
head, I'd say it would be perfectly useless. It could be fun though: the
client interface would end up looking quite similar to an equalizer with
bars representing instruments rather than frequencies, and thus probably
more significant to musically-illiterate listeners (e.g. in the case of
web radios).

-- 
Ciao,
Enrico

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Sat, 1 Aug 2009 12:32:21 -0700

I am not sure what "perfectly useless" means, however, an equalizer where you can volume up/down specific instruments/singers/etc. would be a quite cool feature IMO. Frequency does not map to instruments on a 1:1 basis, so the two equalizers will serve different purposes and they should not replace each other.

-acbegen

> -----Original Message-----
> From: Enrico Marocco [mailto:[email-masked]]
> Sent: Saturday, August 01, 2009 9:22 PM
> To: Ali C. Begen (abegen)
> Cc: [email-masked]
> Subject: Re: [AVT] Question about sound-level indication in RTP
>

---

From: Enrico Marocco <[email-masked]>
Date: Sat, 1 Aug 2009 21:51:15 +0200

I'm not sure we are talking about the same thing. The use case I have in
mind is that of a transmitter that sends a single stream with meta data
representing the instantaneous sound levels of the contributing
instruments/voices.

The use case you have in mind is definitely more complicated; I don't
see any way to achieve that without actually sending to the client (or
the mixing entity fine controlled by the client) all the individual
contributing streams.

Enrico

---

From: Greg Herlein <[email-masked]>
Date: Sun, 2 Aug 2009 08:55:47 -0700

Cobranet does this for professional audio.  It's not IP based, but is
Ethernet based.  I think it's patented in how it approaches the problem but
perhaps there's inspiration there that can be gleaned for an IP-based
solution (Cobranet frames cannot be routed and lose the timing data if
subjected to forwarding/bridging delays).  I can attest that Cobranet woks
quite well.

Greg

On Sat, Aug 1, 2009 at 11:23 AM, Ali C. Begen (abegen) <[email-masked]>wrote:

> Consider a concert-like scenario where there are multiple instruments that
> are collectively producing some sort of music. Suppose that each of the
> instruments is actually packetizing its digitized audio and sending it over
> IP/RTP to a recorder or some sort of sink. Instead of recording the
> aggregated music at that time, each stream is recorded individually and they
> can be mixed, multiplexed, etc. later in any desired way. Or, of course,
> they can be transported individually for whatever reason.
>
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

-- 
Greg Herlein
www.herlein.com