Subject: [AVT] Some minor nits in "draft-begen-avt-rtp-mpeg2ts-preamble-03.txt", FYI

From: Ross Finlayson <[email-masked]>
Date: Sun, 8 Nov 2009 04:29:59 -0800

1. Introduction
	Last sentence: "explains" is misspelled.

4.2.2.  Random Access Point Acquisition Delay
	You start by defining an "I-frame", but later refer to "key 
frame", without explaining that those two terms are synonyms.

Several sections:
	"octets" is misspelled as "octects"

5.2.3.  PCR TLOV
	"initialize" is misspelled

5.2.4.  PID_LIST TLOV
	The "CC" field used in the "PID Element" structure is not 
defined.  (It presumably means "Continuity Counter", but this is not 
explained.)

10.2.  MPEG2-TS Preamble TLOV Space Registry
	"The Type values 0 and 256 are reserved for future use.  The Type
	values between (and including) 128 and 255 are reserved for private
	extensions."

	Because "Type" is an 8-bit field, shouldn't this instead be:

	"The Type values 0 and 255 are reserved for future use.  The Type
	values between (and including) 128 and 254 are reserved for private
	extensions."

	???

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Sat, 7 Nov 2009 15:06:25 -0800

Hi Ross,

Thanks for catching these. All points are valid, and will be fixed in the revision.

Cheers, acbegen.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Ross Finlayson
> Sent: Sunday, November 08, 2009 9:30 PM
> To: [email-masked]
> Subject: [AVT] Some minor nits in "draft-begen-avt-rtp-mpeg2ts-preamble-03.txt", FYI
> 
> 1. Introduction
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt