Subject: [AVT] Comments on draft-ietf-avt-rtp-rapid-acquisition-for-rtp-05 - buffer sizw in milliseconds

From: Roni Even <[email-masked]>
Date: Thu, 17 Dec 2009 23:42:36 +0200

Hi,

I saw the question from Magnus and Ali's response. I  still have a question
about  Max RAMS buffer fill requirement.  

The RS will send information that is time based as retransmission but also
has preamble information that may be of a larger size that is unknown to the
RTP_Rx when it tries to provide its maximum buffer size by milliseconds. 

How does the RS know the amount of data that it can actually send

Roni Even as individual

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 17 Dec 2009 14:43:58 -0800

If we revise it as follows, would it more clear?

      If specified, the amount of backfill that will be provided by the
      unicast burst and any payload-specific information SHOULD NOT be larger than this value since it may
      cause buffer overflows at RTP_Rx.

At the end, the total data the receiver will get counts.

-acbegen

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
> Sent: Thursday, December 17, 2009 4:43 PM
> To: 'IETF AVT WG'
> Subject: [AVT] Comments on draft-ietf-avt-rtp-rapid-acquisition-for-rtp-05 - buffer sizw
> in milliseconds
> 
> Hi,
> 
> I saw the question from Magnus and Ali's response. I  still have a question about  Max
> RAMS buffer fill requirement.
> 
> The RS will send information that is time based as retransmission but also has preamble
> information that may be of a larger size that is unknown to the RTP_Rx when it tries to
> provide its maximum buffer size by milliseconds.
>

---

From: Roni Even <[email-masked]>
Date: Fri, 18 Dec 2009 06:57:02 +0200

Ali,
I think that the issue is not the text but the units, if this is the amount
of backfill people expect to see size in bytes and not in milliseconds. To
calculate the size you will need to convert from milliseconds to bytes so
why not use bytes, I think this is the clarification needed in the text.
Roni Even as Individual

> From: Ali C. Begen (abegen) [mailto:[email-masked]]
> Sent: Friday, December 18, 2009 12:44 AM
> To: Roni Even; IETF AVT WG
> Subject: RE: [AVT] Comments on draft-ietf-avt-rtp-rapid-acquisition-
> for-rtp-05 - buffer sizw in milliseconds
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 18 Dec 2009 08:13:37 -0800

A few months ago we had the same discussion and we collectively decided that we should have the reqs specified in ms rather than bytes.
See the thread ending with:
http://www.ietf.org/mail-archive/web/avt/current/msg11745.html 

Cheers, acbegen.

> From: Roni Even [mailto:[email-masked]]
> Sent: Thursday, December 17, 2009 11:57 PM
> To: Ali C. Begen (abegen); 'IETF AVT WG'
> Subject: RE: [AVT] Comments on draft-ietf-avt-rtp-rapid-acquisition-for-rtp-05 - buffer
> sizw in milliseconds
> 
> Ali,

---

From: Roni Even <[email-masked]>
Date: Fri, 18 Dec 2009 19:35:56 +0200

Ali,
I am aware of that, I was just suggesting that since anyone who will read
the draft may have a question about why use ms instead of bytes it will be
good to have some text that explains this preference instead of pointing to
an older email thread.
Roni Even as Individual

> Sent: Friday, December 18, 2009 6:14 PM
> A few months ago we had the same discussion and we collectively decided
> that we should have the reqs specified in ms rather than bytes.
> > >       unicast burst and any payload-specific information SHOULD NOT
> be
> > > larger than this value since it may
> > > > From: [email-masked] [mailto:[email-masked]] On
> Behalf Of
> > > Roni Even
> > > > Subject: [AVT] Comments on draft-ietf-avt-rtp-rapid-acquisition-
> for-
> > > rtp-05 - buffer sizw
> > > > in milliseconds
> > > >
> > > > Hi,
> > > >
> > > > I saw the question from Magnus and Ali's response. I  still have
> a
> > > question about  Max
> > > > The RS will send information that is time based as retransmission
> but
> > > also has preamble