Subject: [AVT] sending only preamble information in draft-ietf-avt-rtp-rapid-acquisition-for-rtp-05

From: Roni Even <[email-masked]>
Date: Fri, 18 Dec 2009 13:32:27 +0200

Hi,

I was wondering if it will be good to specify a way for RTP_Rx to ask only
for preamble information if it wants to join the multicast immediately or
for RS to be able to send the preamble information even when it responds to
RAMS-R with join immediately.

I was looking at the current parameters like  Max RAMS Buffer Fill
Requirement, Earliest Multicast Join Time and Burst Duration and could not
see that it is possible.

Roni Even

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 18 Dec 2009 08:30:45 -0800

If the server cannot serve the burst, the server may still send the preamble packet(s). We should reflect this with a new response code (500-level) as none of the existing ones seems to cover this case. Something like "Only the preamble packet(s) will be sent."
 
I don't think we need to make changes in other parts.

Cheers, acbegen.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
> Sent: Friday, December 18, 2009 6:32 AM
> To: 'IETF AVT WG'
> Subject: [AVT] sending only preamble information in draft-ietf-avt-rtp-rapid-acquisition-
> for-rtp-05
> 
> Hi,
> 
> I was wondering if it will be good to specify a way for RTP_Rx to ask only for preamble
> information if it wants to join the multicast immediately or for RS to be able to send the
> preamble information even when it responds to RAMS-R with join immediately.
> 
> I was looking at the current parameters like  Max RAMS Buffer Fill Requirement, Earliest
> Multicast Join Time and Burst Duration and could not see that it is possible.
> 
> 
> 
> Roni Even

---

From: Roni Even <[email-masked]>
Date: Fri, 18 Dec 2009 19:38:14 +0200

Ali,
This is from the RS side. Do you see any value in having the RTP_Rx request
just the preamble information.
Roni

> From: Ali C. Begen (abegen) [mailto:[email-masked]]
> Sent: Friday, December 18, 2009 6:31 PM
> To: Roni Even; IETF AVT WG
> Subject: RE: [AVT] sending only preamble information in draft-ietf-avt-
> rtp-rapid-acquisition-for-rtp-05
> 
> If the server cannot serve the burst, the server may still send the
> preamble packet(s). We should reflect this with a new response code
> (500-level) as none of the existing ones seems to cover this case.
> Something like "Only the preamble packet(s) will be sent."
> 
> Requirement, Earliest

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 18 Dec 2009 13:37:05 -0800

Yes, I guess this could be a useful feature. There may be certain things in the preamble that will still help the receiver when it starts receiving the multicast packets. This will require a flag/field in the RAMS-R message but we can do that easily. 

One note I would like to make here is that w/o the burst, the receiver may need to do "(post) processing" on the preamble packets, depending on the payload format. In particular, if the payload is mpeg2 ts, we cannot feed the TS packets from the preamble right before the TS packets from the multicast session into the demux. The TS packets from the preamble and the multicast session need to form a valid transport stream. And this is only achievable via some sort of post processing.

-acbegen

> From: Roni Even [mailto:[email-masked]]
> Sent: Friday, December 18, 2009 12:38 PM
> To: Ali C. Begen (abegen); 'IETF AVT WG'
> Subject: RE: [AVT] sending only preamble information in draft-ietf-avt-rtp-rapid-
> acquisition-for-rtp-05
> 
> Ali,