Subject: [AVT] Why don't you use signaling channel for exchanging shared key for SRTP?

From: tabt couret <[email-masked]>
Date: Tue, 12 Jan 2010 17:22:43 +0900

Dear folks,

This is my first mail to avt mailing list.
If you have any advices about manner about this mailing list,
please tell me.

By the  way,
I have a question about key exchanges for SRTP(e.g. dlts-srtp
and zrtp).

Why do they use signaling channel for it?
Is media channel better than it?

If you know it, please tell me.

Sincirely,
tabt

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 14 Jan 2010 13:57:07 +0100

Hi,

I think
http://tools.ietf.org/html/draft-wing-media-security-requirements-05
will answer your question to at least some degree.

Magnus

tabt couret skrev 2010-01-12 09:22:
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 

-- 

Magnus Westerlund

IETF Transport Area Director
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Couret Tabt <[email-masked]>
Date: Sat, 16 Jan 2010 17:30:52 +0900

Thanks, Magnus,

By the way,
I have read I-D below, none the less, I have keep the following question.

If the signaling channel is encrypted, is it reasonable that we use it
for key-exchange?

Thanks,
Tabt

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 18 Jan 2010 13:39:54 +0100

Hi,

>From my perspective, you can clearly build solutions that use the
signaling channel for key-exchange. However, there are usually a couple
of issues with that also. For example SIP isn't usually workable due to
that it normally only have hop by hop security and not end-to-end security.

Cheers

Magnus Westerlund

---

From: Couret Tabt <[email-masked]>
Date: Tue, 19 Jan 2010 22:13:16 +0900

Dear folks,

Thank you for your helpful comments as usual. >Magnus

Please let me know more over.

> that it normally only have hop by hop security and not end-to-end security.
            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~        ~~~~~~~~~~~~~~~~~

If I could associate with some parts of SIP security
(that have only hop by hop security) well,
is it more useful that we use signaling channel (e.g. SIP) for key-exchange?

If you know some documents that was written about it, please let me know.

Thanks,
Tabt