Subject: [AVT] Status of monitoring architecture for RTP - RTCP XR reports

From: Roni Even <[email-masked]>
Date: Wed, 05 May 2010 09:06:03 +0300

Hi,

AVT have the following milestone in the working group charter:

  Mar 2010 - Submit Monitoring Architecture for RTP for Informational

  Mar 2010 - Submit RTCP XR Report Block for Measurement Identity

  Apr 2010 - Submit RTCP XR Report Block for Burst/Gap Discard metric
Reporting

  Apr 2010 - Submit RTCP XR Report Block for Burst/Gap Loss metric Reporting

  Apr 2010 - Submit RTCP XR Report Block for Concealed Seconds metric
Reporting

  Apr 2010 - Submit RTCP XR Report Block for Delay metric Reporting

   Apr 2010 - Submit RTCP XR Report Block for Jitter Buffer Metric Reporting

  Apr 2010 - Submit RTCP XR Report Block for Loss Concealment metric
Reporting

  Apr 2010 - Submit RTCP XR Report Block for Packet Delay Variation Metric
Reporting

  Apr 2010 - Submit Real-time Transport Control Protocol Extension Report
for Run Length Encoding of Discarded Packets

  Apr 2010 - Submit RTCP XR Report Block for QoE Metrics Reporting

We did not see any progress in these work items since May 2009. 

The AVT chairs are looking to see if there is interest in continuing this
work and if there are people who will actually update the drafts and move
the work forward.

Please respond to the list if you have any interest and think this work is
important and also if you are willing to actively participate in reviewing
and editing the above drafts.

If we do not see enough interest we can take out this milestones for the
moment.

Thanks

Roni Even

AVT co-chair

---

From: <[email-masked]>
Date: Wed, 5 May 2010 09:39:26 +0100

Hi Roni, All,

Although the current editors of the RTCP XR* drafts were not at the Anaheim meeting, we are still interested in working on these drafts. 

Philip Arden and I are currently working on the monitoring architecture draft and expect to submit it within the next 4 weeks.

We believe that the drafts relating to specific metrics - though currently expired - are technically almost complete subject to any changes arising from review of the new architecture draft, and could be re-submitted in their current state. Would you prefer us to re-submit them before, or after, submission of the architecture draft?

Regards
Geoff

Geoff Hunt
BT Design

Tel: 01473 651704
Email: [email-masked]
Web: www.bt.com 
This email contains BT information, which may be privileged or confidential.
It is meant only for the individual(s) or entity named above. If you are not the intended
recipient, note that disclosing, copying, distributing or using this information
is prohibited. If you have received this email in error, please let me know immediately
on the email address above. Thank you.
We monitor our email system, and may record your emails. 
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000 

From: Roni Even [mailto:[email-masked]] 
Sent: 05 May 2010 07:06
To: 'IETF AVT WG'
Cc: Hunt,RG,Geoff,DLW R; [email-masked]; [email-masked]
Subject: Status of monitoring architecture for RTP - RTCP XR reports

Hi,
  
  Mar 2010 - Submit RTCP XR Report Block for Measurement Identity
  Apr 2010 - Submit RTCP XR Report Block for Burst/Gap Discard metric Reporting
  Apr 2010 - Submit RTCP XR Report Block for Burst/Gap Loss metric Reporting
  Apr 2010 - Submit RTCP XR Report Block for Concealed Seconds metric Reporting
  Apr 2010 - Submit RTCP XR Report Block for Delay metric Reporting
   Apr 2010 - Submit RTCP XR Report Block for Jitter Buffer Metric Reporting
  Apr 2010 - Submit RTCP XR Report Block for Loss Concealment metric Reporting
  Apr 2010 - Submit RTCP XR Report Block for Packet Delay Variation Metric Reporting
  Apr 2010 - Submit Real-time Transport Control Protocol Extension Report for Run Length Encoding of Discarded Packets
  Apr 2010 - Submit RTCP XR Report Block for QoE Metrics Reporting

The AVT chairs are looking to see if there is interest in continuing this work and if there are people who will actually update the drafts and move the work forward.

Please respond to the list if you have any interest and think this work is important and also if you are willing to actively participate in reviewing and editing the above drafts.

If we do not see enough interest we can take out this milestones for the moment.

Thanks
Roni Even
AVT co-chair

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 5 May 2010 12:12:39 +0200

(speaking as a WG participant)
 
I believe that this work is important and I am willing to review the
drafts. 
 
Dan

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Roni Even
	Sent: Wednesday, May 05, 2010 9:06 AM
	To: 'IETF AVT WG'
	Cc: [email-masked]; [email-masked]
	Subject: [AVT] Status of monitoring architecture for RTP - RTCP
XR reports

	Hi,

	  Mar 2010 - Submit Monitoring Architecture for RTP for
Informational

	  Mar 2010 - Submit RTCP XR Report Block for Measurement
Identity

	  Apr 2010 - Submit RTCP XR Report Block for Burst/Gap Discard
metric Reporting

	  Apr 2010 - Submit RTCP XR Report Block for Burst/Gap Loss
metric Reporting

	  Apr 2010 - Submit RTCP XR Report Block for Concealed Seconds
metric Reporting

	  Apr 2010 - Submit RTCP XR Report Block for Delay metric
Reporting

	   Apr 2010 - Submit RTCP XR Report Block for Jitter Buffer
Metric Reporting

	  Apr 2010 - Submit RTCP XR Report Block for Loss Concealment
metric Reporting

	  Apr 2010 - Submit RTCP XR Report Block for Packet Delay
Variation Metric Reporting

	  Apr 2010 - Submit Real-time Transport Control Protocol
Extension Report for Run Length Encoding of Discarded Packets

	  Apr 2010 - Submit RTCP XR Report Block for QoE Metrics
Reporting

	The AVT chairs are looking to see if there is interest in
continuing this work and if there are people who will actually update
the drafts and move the work forward.

	Please respond to the list if you have any interest and think
this work is important and also if you are willing to actively
participate in reviewing and editing the above drafts.

	If we do not see enough interest we can take out this milestones
for the moment.

	Thanks

	Roni Even

	AVT co-chair

---

From: Alan Clark <[email-masked]>
Date: Thu, 06 May 2010 10:50:04 -0400

Hi Roni

I can also support the completion of this work, although may not be able to
physically attend the next few IETF meetings (my company has been
exceptionally busy this last year)

Best Regards

Alan

On 5/5/10 4:39 AM, "[email-masked]" <[email-masked]> wrote:

> Hi Roni, All,
> 
> Although the current editors of the RTCP XR* drafts were not at the Anaheim
> meeting, we are still interested in working on these drafts.
> 
> Philip Arden and I are currently working on the monitoring architecture draft
> and expect to submit it within the next 4 weeks.
> 
> We believe that the drafts relating to specific metrics - though currently
> expired - are technically almost complete subject to any changes arising from
> review of the new architecture draft, and could be re-submitted in their
> current state. Would you prefer us to re-submit them before, or after,
> submission of the architecture draft?
> 
> Regards
> Geoff
> 
> Geoff Hunt
> BT Design
> 
> Tel: 01473 651704
> Email: [email-masked]
> Web: www.bt.com 
> The AVT chairs are looking to see if there is interest in continuing this work
> and if there are people who will actually update the drafts and move the work
> forward.
> 
> important and also if you are willing to actively participate in reviewing and
> editing the above drafts.
>

---

From: Peilin YANG <[email-masked]>
Date: Fri, 14 May 2010 17:17:09 +0800

Hi Geoff,

I am also interested in this work. I will review the revised draft.

Best regards,

Peilin

----- 原邮件 -----
发件人: [email-masked]
日期: 星期三, 五月 5日, 2010 下午4:40
主题: Re: [AVT] Status of monitoring architecture for RTP - RTCP XR	reports
收件人: [email-masked], [email-masked]
抄送: [email-masked], [email-masked]

> Hi Roni, All,
> 
> Although the current editors of the RTCP XR* drafts were not at 
> the Anaheim meeting, we are still interested in working on these 
> drafts. 
> 
> Philip Arden and I are currently working on the monitoring 
> architecture draft and expect to submit it within the next 4 weeks.
> 
> We believe that the drafts relating to specific metrics - though 
> currently expired - are technically almost complete subject to any 
> changes arising from review of the new architecture draft, and 
> could be re-submitted in their current state. Would you prefer us 
> to re-submit them before, or after, submission of the architecture 
> draft?
> Regards
> Geoff
> 
> Geoff Hunt
> BT Design
> 
> Tel: 01473 651704
> Email: [email-masked]
> Web: www.bt.com 
> This email contains BT information, which may be privileged or 
> confidential.It is meant only for the individual(s) or entity 
> named above. If you are not the intended
> Cc: Hunt,RG,Geoff,DLW R; [email-masked]; avt-
> [email-masked]: Status of monitoring architecture 
> for RTP - RTCP XR reports
> 
> Hi,
> ? Mar 2010 - Submit Monitoring Architecture for RTP for Informational
> ? 
> ? Mar 2010 - Submit RTCP XR Report Block for Measurement Identity
> ? Apr 2010 - Submit RTCP XR Report Block for Burst/Gap Discard 
> metric Reporting
> ? Apr 2010 - Submit RTCP XR Report Block for Burst/Gap Loss metric 
> Reporting? Apr 2010 - Submit RTCP XR Report Block for Concealed 
> Seconds metric Reporting
> ? Apr 2010 - Submit RTCP XR Report Block for Delay metric Reporting
> ? ?Apr 2010 - Submit RTCP XR Report Block for Jitter Buffer Metric 
> Reporting? Apr 2010 - Submit RTCP XR Report Block for Loss 
> Concealment metric Reporting
> ? Apr 2010 - Submit RTCP XR Report Block for Packet Delay 
> ? Apr 2010 - Submit Real-time Transport Control Protocol Extension 
> Report for Run Length Encoding of Discarded Packets
> ? Apr 2010 - Submit RTCP XR Report Block for QoE Metrics Reporting
> 
> continuing this work and if there are people who will actually 
> update the drafts and move the work forward.
> 
> Please respond to the list if you have any interest and think this 
> work is important and also if you are willing to actively 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Peter Musgrave <[email-masked]>
Date: Fri, 14 May 2010 06:24:04 -0400

Hi,

I am also interested in the XR drafts and would like to see the work
go forward.

Peter Musgrave

---

From: <[email-masked]>
Date: Tue, 18 May 2010 18:27:47 +0100

All

I've just submitted draft-hunt-avt-monarch-01 as a step towards the milestone "Submit Monitoring Architecture for RTP for Informational"

The new draft is much shorter and narrower in scope than the expired draft-hunt-avt-monarch-00 (July 2008). It is focused on the use of small metrics blocks in RTCP XR.

Please review and post comments...

Thanks

Geoff Hunt
BT Design

Tel: 01473 651704
Email: [email-masked]
Web: www.bt.com 

Hi,

Thanks
Roni Even
AVT co-chair

---

From: Roni Even <[email-masked]>
Date: Tue, 18 May 2010 23:54:59 +0300

Geoff thanks,
There was interest in the work by people who responded on the list. Please
review the new draft http://tools.ietf.org/html/draft-hunt-avt-monarch-01 in
order to allow us to continue with this topic
Thanks
Roni Even

---

From: Tom Taylor <[email-masked]>
Date: Thu, 20 May 2010 13:17:22 -0400

We will be asking the WG to consider this as a work item in a few weeks. Reviews 
in advance of that, to verify that the document is in reasonable shape, will be 
much appreciated.

---

From: Peter Musgrave <[email-masked]>
Date: Mon, 24 May 2010 20:37:08 -0400

Hi Tom,

I have read up to the part on mixer topologies (which I have set aside
since I need to read the background material first).

In general I like the idea being promoted. I think it maps out the
terrain you wish to cover. I think a bit more editing is required to
tie the sections together.

My specific comments are:
Section 4 bullet 4
- why is the sequence number of the first packet in the session required?
[is it not enough to indicate the seq number of the first packet in
the reporting interval?]

Section 4
Given that nodes may join mid-stream or miss early packets in a media
stream is it possible to have meaningful cumulative measurement?

" The RTCP XR header itself includes the SSRC of the node at which all
of the contained metrics were measured"
I read this as the node being identified by an SSRC id. Is this the
SSRC of the sent stream or the received stream? Is cname not a better
way to identify a node?

Also, is it worth mentioning that there are limits on how often RTCP
can be sent based on a number of factors (number of recipients etc.)
and the implications this has for the reporting of extended
measurements?

As or the tag field, I think I prefer the tag. I may wish to assemble
reports which group by type (i.e. put in all the PDV then all the
NGBL) after I fill in all the identity blocks.

Regards,

Peter Musgrave

On Thu, May 20, 2010 at 1:17 PM, Tom Taylor <[email-masked]> wrote:
> We will be asking the WG to consider this as a work item in a few weeks.
> Reviews in advance of that, to verify that the document is in reasonable
> shape, will be much appreciated.
>
> Roni Even wrote:
>>
>> Geoff thanks,