Subject: [AVT] AD review: draft-ietf-avt-forward-shift-red-05

From: Robert Sparks <[email-masked]>
Date: Fri, 25 Jun 2010 16:38:48 -0500

I've requested IETF LC for this document.

It might be worth being explicit about not allowing the sender to change the contents
of a packet that appears in a forward shifted stream when it comes time to send it in the 
main stream, and calling out that receiver behavior is undefined if the sender does this.

What is an "outrageous value"? and what does it mean for the receiver to ignore it? Are
you trying to say the receiver may choose to ignore the redundant stream if the forward
offset signalled would cause it to allocate more buffer memory than it was willing to allocate?

Typo nits:
Security considerations : receive->receiver
2nd paragraph of A1: fast->fact

RjS

---

From: Qiaobing Xie <[email-masked]>
Date: Mon, 28 Jun 2010 22:04:03 -0500

Robert,

Thanks for the review and comments. Please see my response in-line below.

regards,
-Qiaoing

> main stream, and calling out that receiver behavior is undefined if the sender does this.

How about adding this clarification:

"The sender SHOULD NOT change the contents of a packet that appears in a 
forward shifted stream when it comes time to send it in the main stream. 
If a sender does change the contents of a packet that appears in a 
forward shifted stream when it comes time to send it in the main stream, 
the receiver behavior is undefined."

> offset signalled would cause it to allocate more buffer memory than it was willing to allocate?

How about change the sentence to something like:

"In addition, since an excessive forwardshift value can be signalled, as 
a denial of service, a receive SHOULD be prepared to ignore a 
'forwardshift' parameter declaration if it considers the offset value in 
the declaration excessive, and ignore the redundant stream in the 
resultant RTP session."

> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Jun 2010 09:22:44 -0500

On Jun 28, 2010, at 10:04 PM, Qiaobing Xie wrote:

>> of a packet that appears in a forward shifted stream when it comes time to send it in the main stream, and calling out that receiver behavior is undefined if the sender does this.
> 
> "The sender SHOULD NOT change the contents of a packet that appears in a forward shifted stream when it comes time to send it in the main stream. If a sender does change the contents of a packet that appears in a forward shifted stream when it comes time to send it in the main stream, the receiver behavior is undefined."

Why isn't that MUST NOT?

> "In addition, since an excessive forwardshift value can be signalled, as a denial of service, a receive SHOULD be prepared to ignore a 'forwardshift' parameter declaration if it considers the offset value in the declaration excessive, and ignore the redundant stream in the resultant RTP session."
> 
>> Typo nits:

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 29 Jun 2010 16:12:17 -0500

Ok, we will use a 'MUST NOT' there.

Thanks,
-Qiaobing