Subject: [AVT] I-D Action:draft-ietf-avt-rtp-evrc-nw-01.txt

From: [email-masked]
Date: Mon, 26 Jul 2010 11:00:03 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Working Group of the IETF.

	Title           : RTP payload format for Enhanced Variable Rate Narrowband-Wideband Codec (EVRC-NW)
	Author(s)       : Z. Fang
	Filename        : draft-ietf-avt-rtp-evrc-nw-01.txt
	Pages           : 28
	Date            : 2010-07-26

This document specifies real-time transport protocol (RTP) payload
formats to be used for the Enhanced Variable Rate Narrowband-Wideband
Codec (EVRC-NW).  Three media type registrations are included for
EVRC-NW RTP payload formats.  In addition, a file format is specified
for transport of EVRC-NW speech data in storage mode applications
such as e-mail.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-avt-rtp-evrc-nw-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 27 Jul 2010 14:20:21 +0200

(As WG co-chair) 

I notice this has gone from -00 to -01 with apparently no WG discussion.

Please remember this is now a working group item, and therefore the contents of this draft depend on consensus of the working group, not the document editor.

Therefore for every new version, you should be ensuring that all technical changes do have consensus in the working group before issuing the new version.

Please send a mail to the AVT list summarising the technical changes made and seek consensus for those changes.

regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, July 26, 2010 7:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [AVT] I-D Action:draft-ietf-avt-rtp-evrc-nw-01.txt
> 
> 	Title           : RTP payload format for Enhanced 
> Variable Rate Narrowband-Wideband Codec (EVRC-NW)
> 	Author(s)       : Z. Fang
> This document specifies real-time transport protocol (RTP) 
> payload formats to be used for the Enhanced Variable Rate 
> Narrowband-Wideband Codec (EVRC-NW).  Three media type 
> registrations are included for EVRC-NW RTP payload formats.  
> In addition, a file format is specified for transport of 
> EVRC-NW speech data in storage mode applications such as e-mail.
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
>

---

From: "Fang, Zheng" <[email-masked]>
Date: Tue, 27 Jul 2010 15:56:15 -0700

Hi Keith and all,

Thanks for pointing this out. And sorry...I was not familiar with the procedures. 

The changes made from version 00 to 01 are summarize in below. The diff can be found at http://tools.ietf.org/rfcdiff?url2=draft-ietf-avt-rtp-evrc-nw-01.txt

1. Specify wideband mode support in EVRC-NW to be optional. This is to enable interoperability among implementations with minimal feature sets (i.e. narrow-band support only). 
   As a result: 
   * The default operating mode(s) are set to be narrow-band mode(s), as indicated in Section 3, Section 9.1, Section 12. 
   * An SDP offer example is added in Section 14 for the case when wideband mode in EVRC-NW is not supported by a terminal.
   * The wideband capability is announced through the parameter "mode-set-recv" (Section 10). 

2. Explicitly specify that EVRC-NW modes 0 to 6 uses *the full set or a subset of* full rate, 1/2 rate, 1/4 rate and 1/8 rate frames. This is a more accurate description, since for some of the modes in EVRC-NW, not all the frame rates are used. (Please see the 1st diff in Section 3). 

3. Fix a typo in Section 12. A semicolon was missing between two parameters. 

Please let me know if you have any comments or suggestions.

Best Regards,
Zheng 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: Tuesday, July 27, 2010 5:20 AM
To: [email-masked]
Subject: Re: [AVT] I-D Action:draft-ietf-avt-rtp-evrc-nw-01.txt

(As WG co-chair) 

regards

Keith

> version of the Internet-Draft.
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt