Subject: [AVT] Comments on Retransmission Suppression for NACK Implosion

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 29 Jul 2010 11:15:14 +0200

Hi

I have now read through this draft (a bit hasty so I might miss some important point)
I am not sure that I understand this fully so some level of tolerance please :-)

If I uderstand the concept correctly the sender will send a feedback suppression message RTCP multicast to all receivers as soon as it receives a NACK from any receiver. This NACK suppression RTCP will then limit the risk that the sender gets flooded by  NACK RTCPs. This NACK suppression will take 1 RTT to reach all the other receivers. Which means that the other senders must listen to the NACK suppression message for at least one RTT before he sends his NACK.
Now there must be something that I miss here as the other receivers may as well look for the retransmitted packets on he multicast stream and from that determine if it is necessay to send a NACK.

Regards
Ingemar

---

From: David R Oran <[email-masked]>
Date: Thu, 29 Jul 2010 02:21:34 -0700

> If I uderstand the concept correctly the sender will send a feedback suppression message RTCP multicast to all receivers as soon as it receives a NACK from any receiver. This NACK suppression RTCP…
It may also send it in the absence of receiving ANY MACKs because t has independently detected upstream loss and is topologically upstream of all the receivers on the same multicast subtree.

> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: Qin Wu <[email-masked]>
Date: Thu, 29 Jul 2010 11:36:35 +0200

Hi, Ingemar:
Thank for your feedback.
Maybe there is few descriptive problem which make you have such misunderstanding. Sorry about that.
The concept of feedback suppression is integrate loss detector into feedback target box, for flexibility consideration, this loss detector can be seperated out from feedback target and distribution source, which is referred to as dedicated receiver in the I-D. wherever the loss detector is, the loss detector in the middle of media sender and all the receiver sitting at the end device will be first to detect the massive packet loss in the upstream or downstream agrregated link, therefore it will not take one RTT for NACK suppression to reach all the other receivers. Hope this clarify.

Regards!
-Qin
  ----- Original Message ----- 
  From: Ingemar Johansson S 
  To: [email-masked] 
  Cc: Qin Wu ; Roni Even 
  Sent: Thursday, July 29, 2010 11:15 AM
  Subject: Comments on Retransmission Suppression for NACK Implosion

  Hi

  Regards
  Ingemar

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 29 Jul 2010 12:28:31 +0200

OK

Now I understand. The delay will then be substantially less than 1 RTT and the feedback suppression then apply to the stream up to and including the point where the loss detector is located (along the same multicast branch).
Followup comment. Normally I would believe that the RTCP NACK is sent in AVPF early mode. I need to updated myself on RFC5760 to see how timing of RTCP transmission works but I guess that transmission of RTCP NACK is held for some time for the RTCP NACK suppression to arrive at the STBs before they send off a NACK ?

/Ingemar

________________________________
From: Qin Wu [mailto:[email-masked]]
Sent: den 29 juli 2010 11:37
To: Ingemar Johansson S; [email-masked]
Cc: Roni Even
Subject: Re: Comments on Retransmission Suppression for NACK Implosion

Hi, Ingemar:
Thank for your feedback.

Regards!
-Qin
----- Original Message -----
From: Ingemar Johansson S<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
Cc: Qin Wu<mailto:[email-masked]> ; Roni Even<mailto:[email-masked]>
Sent: Thursday, July 29, 2010 11:15 AM
Subject: Comments on Retransmission Suppression for NACK Implosion

Hi

Regards
Ingemar

---

From: David R Oran <[email-masked]>
Date: Thu, 29 Jul 2010 13:20:33 +0200

On Jul 29, 2010, at 12:28 PM, Ingemar Johansson S wrote:

> Followup comment. Normally I would believe that the RTCP NACK is sent in AVPF early mode.
Yes.

> I need to updated myself on RFC5760 to see how timing of RTCP transmission works but I guess that transmission of RTCP NACK is held for some time for the RTCP NACK suppression to arrive at the STBs before they send off a NACK ?
Not exactly - since you are managing a jitter buffer with playout deadline constraints, and packets can arrive out of order, you send the NACK when you "get nervous" that the packet won't arrive before the playout deadline. If you think about the problem this way, there is no separate timing regime for deciding if you think the packet is lost versus deciding if you ought to send your NACK or delay it.

There are some subtleties in NACK timing beyond this (e.g. ensuring the timers are jittered, whether you are using retransmission as a secondary repair strategy behind FEC) but I hope this gives you the general idea.

DaveO.

P.S. to comply with the IETF "Note Well", I must disclose that I have some intellectual property on algorithms for the optimal combination of FEC, unicast retransmission and multicast retransmission, a major part of which is the exact NACK strategy in various configurations. The use of NACK suppression by itself is not part of this IPR as it's well known prior art from the RMT world.