Subject: [AVT] draft-ietf-avt-srtp-ekt-01 posted

From: "Dan Wing" <[email-masked]>
Date: Mon, 12 Jul 2010 21:12:18 -0700

-01 of EKT has been posted, which 
  * adds support for MIKEY
  * allows an alternate DTLS-SRTP-EKT server for multicast per Romain
Biehlmann's suggestion (reference
http://www.ietf.org/mail-archive/web/avt/current/msg13043.html)
  * adds some additional detail around DTLS-SRTP.  More is still needed (my
fault)

Thanks to Kai for writing the MIKEY section, and thanks to Lakshminath for
his earlier help.  Lakshminath asked to be dropped from the authors list.

New draft,
  http://tools.ietf.org/html/draft-ietf-avt-srtp-ekt-01

diffs from -00 are at:
  http://tools.ietf.org/rfcdiff?url2=draft-ietf-avt-srtp-ekt-01

-d

---

From: "Wyss, Felix" <[email-masked]>
Date: Sun, 18 Jul 2010 17:25:56 -0400

I have two questions/suggestions regarding this draft:

  1) As mentioned in the draft, requiring the answerer to use the same master salt as the offerer can be somewhat problematic.  Why not allow the master salt to be included in the EKT authentication tag at the sender's discretion?  Whether a master salt is present could be signaled with bit 30 of the ISN/SPI DWORD.  This would reduce the size of the SPI to 14 bits, but that should still be more than plenty.  As an aside, note that the text is wrong about the SPI being 16 bits (section 2.1, page 8). 

  2) Referring to the ciphers in section 2.3: Why not use ciphertext stealing (CTS) when encrypting the master key?  In my opinion this would have at least two advantages:
    a) Only one cipher would be needed for all SRTP master key sizes (c.f. draft-ietf-avt-srtp-big-aes-xx)
    b) N would be equal to M for SRTP master key sizes greater than or equal to an AES block size and the resulting SRTP/SRTCP packets would thus be 8 bytes smaller than if Key Wrap were used as proposed.  

Regards,
--Felix Wyss

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Dan
> Wing
> Sent: Tuesday, July 13, 2010 00:12
> To: [email-masked]
> Cc: 'Flemming Andreasen'; 'David McGrew'; Lakshminath Dondeti
> Subject: [AVT] draft-ietf-avt-srtp-ekt-01 posted
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt