Subject: Re: [AVT] rfc3984bis - max-smbps limit

From: Roni Even <[email-masked]>
Date: Fri, 01 Oct 2010 22:49:25 +0200

Hi,

We got the following comment as a private email (bellow) . The draft has not
be published yet and we can do this change before publication.
Please review and send comments to the list since it changes the current
semantics. If there are no objections we will do this change.
Since this parameter has been added in the bis draft and was not part of RFC
3984 we do not see any interoperability issues.

Thanks
Roni Even
As a co-author of the draft

Email from Tom Kristensen

I discovered missing alignment between H.241 MaxStaticMBPS and max-smbps as
defined in draft-ietf-avt-rtp-rfc3984bis.

 From Table 8-9, H.241:
---
The encoder should recompute this value for each picture.
The value of (MaxStaticMBPS × 500) shall not be less than the value MaxMBPS
for the Level given in Table A-1/H.264, and if CustomMaxMBPS is signalled,
shall not be less than the value (CustomMaxMBPS × 500).
---

On the other hand in the SIP world, rfc3984bis says:
---
The value of max-smbps MUST be greater than the value of MaxMBPS given in
Table A-1 of [1] for the highest level.
---
http://tools.ietf.org/html/draft-ietf-avt-rtp-rfc3984bis-11#page-44

H.241 says      max-smbps >= max-mbps.
rfc3984bis says max-smbps >  max-mbps.
We are missing "or equal".

Of course it doesn't really make much meaning to include a max-smbps 
equal to max-mbps, but we have a mismatch between H.241 and the SDP 
counterpart.

Is it possible and feasible to alter the text given the current state of 
soon-to-be-RFC draft-ietf-avt-rtp-rfc3984bis?

---

From: Stephen Botzko <[email-masked]>
Date: Fri, 1 Oct 2010 17:03:32 -0400

I think reconciling the text with H.241 is a good idea, as it removes a
corner-case from fully compliant non-transcoding gateways.

I also agree with Tom's observation that it doesn't make sense to signal
max-smbps unless it is greater than max_mpbs.

Stephen Botzko

2010/10/1 Roni Even <[email-masked]>

> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Ye-Kui Wang <[email-masked]>
Date: Fri, 01 Oct 2010 17:06:25 -0400

+1

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stephen Botzko
Sent: Friday, October 01, 2010 5:04 PM
To: Roni Even
Cc: Randell Jesup; [email-masked]; Tom Kristensen; IETF AVT
WG
Subject: Re: [AVT] rfc3984bis - max-smbps limit

Stephen Botzko

Hi,

Thanks
Roni Even

 From Table 8-9, H.241:
---

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 1 Oct 2010 14:27:17 -0700

I agree, and have seen this come up with H.323/SIP interworking gateways. I think the change is worthwhile.

Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Ye-Kui Wang
> Sent: Friday, October 01, 2010 2:06 PM
> To: 'Stephen Botzko'; 'Roni Even'
> Cc: 'Randell Jesup'; [email-masked]; 'Tom Kristensen'; 'IETF AVT WG'
> ________________________________
> 
> 	From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephen Botzko
> 	Cc: Randell Jesup; [email-masked]; Tom Kristensen; IETF AVT WG
> 	I think reconciling the text with H.241 is a good idea, as it removes a corner-case from fully
> compliant non-transcoding gateways.
> 
> 	I also agree with Tom's observation that it doesn't make sense to signal max-smbps unless it is
> greater than max_mpbs.
> 
> 	Stephen Botzko
> 
>

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Sat, 2 Oct 2010 08:08:13 -0500

The draft is missing more than just "or equal to".

> Table A-1 of [1] for the highest level.

It should also take max-mbps into account. And the reference to "highest level" has no antecedent in this section; it is in the prior section on max-mbps.

I suggest this [new] text:

"The value of max-smbps MUST be greater than [or equal to] the value of MaxMBPS given [explicitly in max-mbps or implicitly] in Table A-1 of [1] for the highest level [given in profile-level-id or max-recv-level]."

Regards,
Mo

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Friday, October 01, 2010 4:49 PM
To: 'IETF AVT WG'
Cc: 'Randell Jesup'; 'Tom Kristensen'; [email-masked]
Subject: Re: [AVT] rfc3984bis - max-smbps limit

Hi,

Thanks
Roni Even

 From Table 8-9, H.241:
---

---

From: Tom Kristensen <[email-masked]>
Date: Sun, 03 Oct 2010 11:49:15 +0200

Indeed, Mo, we have to take a potential max-mbps into account in the 
description and the clarification of "highest level" also in the 
max-smbps text part is just fine.

Even though "highest level" is described under a common heading for 
these parameters, it is repeated for the other parameters.
Cf.:
        max-mbps, max-smbps, max-fs, max-cpb, max-dpb, and max-br:
           These parameters MAY be used to signal the capabilities of a
           receiver implementation. These parameters MUST NOT be used
           for any other purpose.  The highest level conveyed in the
           value of the profile-level-id parameter or the max-recv-level
           parameter MUST be such that the receiver is fully capable of
           supporting.

-- Tom

On 10/02/2010 03:08 PM, Mo Zanaty (mzanaty) wrote:
> H.241 says      max-smbps>= max-mbps.
> rfc3984bis says max-smbps>   max-mbps.

---

From: Roni Even <[email-masked]>
Date: Sun, 03 Oct 2010 14:46:32 +0200

Tom,
Can you suggest a final text so that we can ask the AD what to do
Roni

> Tom Kristensen
> Sent: Sunday, October 03, 2010 11:49 AM
> To: Mo Zanaty (mzanaty)
> Cc: Randell Jesup; [email-masked]; IETF AVT WG; Roni
> Even
> > It should also take max-mbps into account. And the reference to
> "highest level" has no antecedent in this section; it is in the prior
> section on max-mbps.
> >
> > "The value of max-smbps MUST be greater than [or equal to] the value
> of MaxMBPS given [explicitly in max-mbps or implicitly] in Table A-1 of
> [1] for the highest level [given in profile-level-id or max-recv-
> level]."
> >
> > Regards,
> > Mo
> >

---

From: Tom Kristensen <[email-masked]>
Date: Mon, 04 Oct 2010 23:16:51 +0200

Roni,
I propose clarifying "highest level" first time the term is used for 
max-smbps, that is in the first bullet point at page 44. New text in []:
----
   o If the parameter max-mbps is signalled, set a variable
       MaxMacroblocksPerSecond to the value of max-mbps.
       Otherwise, set MaxMacroblocksPerSecond equal to the value
       of MaxMBPS in Table A-1 [1] for the [signaled] highest level
       [conveyed in the value of the profile-level-id parameter or the
        max-recv-level parameter].
----

Then the paragraph on top of page 45, after the bullet points should be:
----
   The encoder should recompute this value for each picture. The
   value of max-smbps MUST be greater than [or equal to] the value
   of MaxMBPS given [explicitly as the value of the max-mbps
   parameter or implicitly] in Table A-1 of [1] for the [signaled]
   highest level. Senders MAY use this knowledge to send pictures
   of a given size at a higher picture rate than is indicated in the
   signaled highest level.
----

This way the "highest level" is explained initially in the scope of the 
parameter and referenced as "signaled highest level" later on as done 
for the other parameters.

-- Tom