Subject: Re: [AVT] I-D Action:draft-kristensen-avt-rtp-h241param-01.txt

From: Tom Kristensen <[email-masked]>
Date: Tue, 26 Oct 2010 11:06:02 +0200

On 25 October 2010 18:00,  <[email-masked]> wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>        Title           : Additional H.241 Parameter in the RTP Payload Format for H.264 Video
>        Author(s)       : T. Kristensen, M. Walters
>        Filename        : draft-kristensen-avt-rtp-h241param-01.txt
>        Pages           : 12
>        Date            : 2010-10-25
>
> As systems increasingly are able to run video at 60 frames per
> second, there is a need to signal desired frame rate to optimise
> resolution choices and to avoid unnecessary resource or energy usage.
> This document defines a new optional parameter addressing recent
> extensions currently supported in H.323 systems: The signalling of
> the maximum frames per second that can be efficiently received or
> that can be sent.
>
> A URL for this Internet-Draft is:
http://tools.ietf.org/html/draft-kristensen-avt-rtp-h241param-01

The -01 version was submitted yesterday, before the IETF-79 great wall
surrounded the draft submission tool.

This version addresses the feedback and handles the issues from the
AVT mailing list discussion on this draft. Most important:
- Emphasize the resolution choice optimization and energy
consumption/battery duration as motivation for max-fps
- Underline ease of gatewaying between SIP and H.323 as a reason
- Added graphs as an aid visualizing the effect of max-fps, together
with macroblock and frame size signalling
- Changed the normative text in the media type registration along the
lines of for instance sar-supported in RFC3984bis
- Tightened text describing "a=maxprate" and H.26x frame rate
signalling parameters, to get the real message clearer through
- A better text regarding co-existence with "a=framerate" added

(The -00/-01 diff:
http://tools.ietf.org/rfcdiff?url2=draft-kristensen-avt-rtp-h241param-01.txt
)

-- Tom

---

From: Tom Kristensen <[email-masked]>
Date: Tue, 26 Oct 2010 11:15:07 +0200

On 10/26/2010 11:06 AM, Tom Kristensen wrote:
> On 25 October 2010 18:00,<[email-masked]>  wrote:
[...]

I forgot to flag this "errata" in the announce message. Noticed just as 
-01 was submitted that we accidentally changed the normative text for 
the mediatype parameter registration.

Cf. 
http://tools.ietf.org/html/draft-kristensen-avt-rtp-h241param-01#section-3.1

As max-fps is an OPTIONAL parameter the right thing to say is
"This parameter MAY be used to indicate the maximum [...]" not
"This parameter SHOULD be used to indicate the maximum [...]"
as currently said in -01. Will be fixed in next version.

-- Tom