Subject: [AVT] SSRC change in a single RTP session

From: paromita chowdhury <[email-masked]>
Date: Wed, 20 Oct 2010 01:25:56 -0700

Hi,

I have read the RTP rfc 3550 a couple of times, still have a doubt on the
following issue:

- If a RTP unicast session with no change in the source and destination
address, changes its SSRC during the call session is it permissible? In
other words, between the same pair of source and destination addresses, can
a change in the SSRC value acceptable at the destination?

I request the experts in this field to respond to this query?

Thanks
PC

---

From: Colin Perkins <[email-masked]>
Date: Wed, 20 Oct 2010 09:54:08 +0100

On 20 Oct 2010, at 09:25, paromita chowdhury wrote:
> I have read the RTP rfc 3550 a couple of times, still have a doubt on the following issue:
> 
> - If a RTP unicast session with no change in the source and destination address, changes its SSRC during the call session is it permissible? In other words, between the same pair of source and destination addresses, can a change in the SSRC value acceptable at the destination?

Yes, the SSRC can change. In addition, you might see multiple SSRCs on the session (a unicast session is not restricted to one single SSRC from each participant, or even only two participants, since one may be an RTP translator or mixer). 

-- 
Colin Perkins
http://csperkins.org/

---

From: paromita chowdhury <[email-masked]>
Date: Wed, 20 Oct 2010 02:10:09 -0700

I noticed in a audio(VoIP) call with no change in the source or destination
IP addresses, the ssrc value of side of the communication changed while the
call was still going.

I find in the RFC 3550 that ssrc may change when one of the endpoint changes
but it mentions nothing about the scenario when endpoints do not change. Can
you please point/direct me to the section of the RFC stating it?

Thanks

On 20 October 2010 01:54, Colin Perkins <[email-masked]> wrote:

> Yes, the SSRC can change. In addition, you might see multiple SSRCs on the
> session (a unicast session is not restricted to one single SSRC from each
> participant, or even only two participants, since one may be an RTP
> translator or mixer).
>
> --
> Colin Perkins
> http://csperkins.org/
>
>
>
>

---

From: Colin Perkins <[email-masked]>
Date: Wed, 20 Oct 2010 10:38:47 +0100

An SSRC collision can happen at any time, and will force a change of SSRC. A new participant can join at any time, causing new SSRCs to appear. An existing participant may decide to send an additional media stream into a session, causing a new SSRC to appear. An application may restart, causing an SSRC change. A source may change its transport address requiring an SSRC change, but do so behind a NAT such that you don't see the change of transport address. An implementation may be broken, and change its SSRC for no reason.

Don't assume the SSRC is constant. Nothing in RFC 3550 requires it to be, and there are many things that may cause it to change.

Colin

On 20 Oct 2010, at 10:10, paromita chowdhury wrote:
> I noticed in a audio(VoIP) call with no change in the source or destination IP addresses, the ssrc value of side of the communication changed while the call was still going. 
> 
> I find in the RFC 3550 that ssrc may change when one of the endpoint changes but it mentions nothing about the scenario when endpoints do not change. Can you please point/direct me to the section of the RFC stating it?
> 
> Thanks
>

---

From: paromita chowdhury <[email-masked]>
Date: Wed, 20 Oct 2010 02:45:56 -0700

Thanks for the response.. it clarified my doubt

On 20 October 2010 02:38, Colin Perkins <[email-masked]> wrote:

> An SSRC collision can happen at any time, and will force a change of SSRC.
> A new participant can join at any time, causing new SSRCs to appear. An
> existing participant may decide to send an additional media stream into a
> session, causing a new SSRC to appear. An application may restart, causing
> an SSRC change. A source may change its transport address requiring an SSRC
> change, but do so behind a NAT such that you don't see the change of
> transport address. An implementation may be broken, and change its SSRC for
> no reason.
>
> Don't assume the SSRC is constant. Nothing in RFC 3550 requires it to be,
> and there are many things that may cause it to change.
>
> Colin
>
>
>
> I find in the RFC 3550 that ssrc may change when one of the endpoint
> changes but it mentions nothing about the scenario when endpoints do not
> change. Can you please point/direct me to the section of the RFC stating it?
>
> Thanks
>