Subject: [AVTCORE] Open issue- identity info repetition in draft-ietf-avtcore-monarch

From: Qin Wu <[email-masked]>
Date: Mon, 09 May 2011 16:08:51 +0800

In the last IETF meeting, there was discussion on identity info repetition or dupplication. However it
 was not clear whether new packet type for identity block is needed. Here is some clarification and 
prososal from my point of view.

In the example figure 2 of section 5.2 in drat-ietf-avtcore-monarch, it is assumed there is an RTCP
 XR packet containing four metrics blocks, reporting on streams from two source.
each source is associated with two meric block.

In order to reduce overhead to carry duplicated data for all the metric block contained in 
the same RTCP XR packet, it was proposed by draft-ietf-avtcore-monarch that measurement 
identity information should be separated from metric block and form independent block.

However this proposal save zero octets in figure 2. So the question  is
whether an identity block is actually needed if identity information 
only contain SSRC of stream souce, or if just stacking 
multiple XR Blocks is acceptable.

However I re-check with RTCP XR Report Block for Measurement Identity defined in
draft-ietf-avt-rtcp-xr-meas-identity-02, identity information included is more than
SSRC of stream source. So it should be useful to define new packet type for identity block.

However the example figure 2(i.e., only contain SSRC of stream souce) is actually not consistent with report block format defined in 
draft-ietf-avt-rtcp-xr-meas-identity-02(i.e., contain more than SSRC of stream source).

Also as we know, identity block work has just started from XRBlock WG,
Therefore  I suggest that the example (Figure 2, and the related discussion) is removed until the identity block is clearly 
defined in XRBLock.

Any Comments or suggestion?

Regards!
-Qin

---

From: Qin Wu <[email-masked]>
Date: Tue, 10 May 2011 10:22:50 +0800

Just make correction. My colleague reminds me that the example figure 2  does not conflict with report block format defined in draft-ietf-avt-rtcp-xr-meas-identity-02.
Since the detailed measurement identity information following the field SSRC of stream source in the figure 2 is omitted.
However as I mentioned, it is not clear how much information is included in identity block until identity block is clearly defined in XRBlock WG.
That is why I propose to remove figure 2 and related text from this document.

Regards!
-Qin
----- Original Message ----- 
  From: Qin Wu 
  To: [email-masked] ; [email-masked] 
  Cc: [email-masked] 
  Sent: Monday, May 09, 2011 4:08 PM
  Subject: [AVTCORE] Open issue- identity info repetition indraft-ietf-avtcore-monarch

  Regards!
  -Qin

------------------------------------------------------------------------------

  _______________________________________________
  Audio/Video Transport Core Maintenance
  [email-masked]
  https://www.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Mon, 16 May 2011 11:37:28 +0100

Qin,

To my mind, the most important part of the identity block was the correlation tag used to relate RTCP statistics to non-RTCP measurements (draft-clark-avt-rtcphr-02 had something along these lines, although more structured than needed). The tools to save space in RTCP XR packets by removing duplicate identity information when stacking reports are less compelling. Given this, I don't see much value in Section 5.2 of draft-ietf-avtcore-monarch as currently written, and would prefer to see the draft focus on ways to correlate RTP-layer identify information with other identify data.

I'd be interested to hear other opinions though.

Colin

On 10 May 2011, at 03:22, Qin Wu wrote:
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock

-- 
Colin Perkins
http://csperkins.org/

---

From: Qin Wu <[email-masked]>
Date: Tue, 17 May 2011 12:00:52 +0800

Hi, Colin:
It looks like to me we go back to the history and re-pickup the story of identity block again although I haven't gotten invloved into the historical discussion.
However I do check with section 4.3 of draft-clark-avt-rtcphr-02 and compare it with measurement identity block specified in draft-ietf-avt-rtcp
-xr-meas-identity. 
I think identity block has already considered the way on how to correlate RTP-layer identity information with other identity data. If you look at the format
of identity block, you will see identity block defines the sub-identifier field to carry an additional identifier which can be useful in the context of a specific application, e.g.,
IMS Charging Identity,SIP Call-ID, all these additional identity can be included in the identity block. Using this application specific identity information, 
you can easily correlate RTP-layer identity information with other identity data.
I think the only problem with measurement identity block is which kind of information should be included, which kind of information should not be included.
Therefore it will be good to have a template for measurement identity block or any other new RTCP XR block.

Regards!
-Qin
  ----- Original Message ----- 
  From: Colin Perkins 
  To: Qin Wu 
  Cc: AVT WG ; [email-masked] 
  Sent: Monday, May 16, 2011 6:37 PM
  Subject: Re: [xrblock] [AVTCORE] Open issue- identity info repetition indraft-ietf-avtcore-monarch

  Qin,

  Colin

    Regards!
    -Qin
    ----- Original Message -----
      From: Qin Wu
      To: [email-masked] ; [email-masked]
      Cc: [email-masked]
      Sent: Monday, May 09, 2011 4:08 PM
      Subject: [AVTCORE] Open issue- identity info repetition indraft-ietf-avtcore-monarch

      Regards!
      -Qin

--------------------------------------------------------------------------

  -- 
  Colin Perkins
  http://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Mon, 23 May 2011 12:19:30 +0100

Qin,

[bcc to avt, so replies go to the xrblock list only]

The identity information in draft-ietf-avt-rtcp-xr-meas-identity-02 is derived from that in draft-clark-avt-rtcphr-02, true. Both blocks contain too much non-identity information for my taste, however. None of this negates my comment on Section 5.2 of draft-ietf-avtcore-monarch-01, which I think still focusses on the wrong things.

Colin

-- 
Colin Perkins
http://csperkins.org/