Subject: Re: [AVTCORE] New Version Notification for draft-singh-avtcore-mprtp-04.txt

From: Thomas Schierl <[email-masked]>
Date: Tue, 27 Mar 2012 10:26:43 +0200

Dear all,

I support this draft to become a working group document. I think it is 
definitely of interest having today's availability of multiple 
interfaces in mind. Therefore it makes sense to start exploring the 
field of using multiple RTP connections in an experimental document.

Thomas
--
Fraunhofer HHI

On 27.02.2012 11:37, Varun Singh wrote:
> Hi,
>
> We have submitted an updated draft for Multipath RTP (MPRTP) and would
> like the WG to review the draft and provide feedback.
> The exact changes are:
> https://tools.ietf.org/rfcdiff?url2=draft-singh-avtcore-mprtp-04.txt
>
> The main changes are:
> 1. Advertising MPRTP interfaces can be done in RTCP or using SDP. Both
> extensions are in the draft.
> 2. MPRTP multiplexes RTP and RTCP on a single port.
> 3. If an endpoint wants to do NAT traversal then it should use ICE
> procedures and the Section 11 covers how it could be done. However,
> using ICE is optional. So session can be setup using ICE and without
> ICE (Examples for session setup are in Section 11.6).
> 4. Using MPRTP with RTSP 2.0
>
> There are still some open issues, mainly related to advertising
> interfaces in RTCP (in-band) and in SDP (out-of-band). In some
> situations advertising in RTCP is less complex, especially, if the
> interfaces were already offered as ICE candidates and connectivity
> checks were successful.
>
> Security considerations for sending interface advertisements in RTCP
> (without ICE) are still pending and will be covered in the coming
> iterations.
>
> Cheers,
> Varun
>
>
> Begin forwarded message:
>> A new version of I-D, draft-singh-avtcore-mprtp-04.txt has been successfully submitted by Varun Singh and posted to the IETF repository.
>>
>> Filename:      draft-singh-avtcore-mprtp
>> Revision:      04
>> Title:                 Multipath RTP (MPRTP)
>> Creation date:         2012-02-27
>> WG ID:                 Individual Submission
>> Number of pages: 49
>>
>> Abstract:
>>    The Real-time Transport Protocol (RTP) is used to deliver real-time
>>    content and, along with the RTP Control Protocol (RTCP), forms the
>>    control channel between the sender and receiver.  However, RTP and
>>    RTCP assume a single delivery path between the sender and receiver
>>    and make decisions based on the measured characteristics of this
>>    single path.  Increasingly, endpoints are becoming multi-homed, which
>>    means that they are connected via multiple Internet paths.  Network
>>    utilization can be improved when endpoints use multiple parallel
>>    paths for communication.  The resulting increase in reliability and
>>    throughput can also enhance the user experience.  This document
>>    extends the Real-time Transport Protocol (RTP) so that a single
>>    session can take advantage of the availability of multiple paths
>>    between two endpoints.
>>
>>
>>
>>
>> The IETF Secretariat
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

--------------------
visit us at

FOE 2012
April 11-13 / Tokyo Big Sight, Japan / German Pavilion Booth No. 26-31 

NAB Show 2012
April 16-19 / Las Vegas, USA / Booth C8444

www.hhi.fraunhofer.de/events

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Tue, 27 Mar 2012 08:44:32 +0000

+1

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Schierl
> Sent: Tuesday, March 27, 2012 10:27 AM
> To: [email-masked]
> Subject: Re: [AVTCORE] New Version Notification for draft-singh-avtcore-mprtp-04.txt
> 
> Dear all,
> 
> I support this draft to become a working group document. I think it is definitely of interest having today's availability of
> multiple interfaces in mind. Therefore it makes sense to start exploring the field of using multiple RTP connections in an
> experimental document.
> 
> Thomas
> --
> Fraunhofer HHI
> 
> 
> 
> -----