Subject: Re: [AVTCORE] Working group last call on draft-ietf-avtcore-srtp-aes-gcm-03

From: Jonathan Lennox <[email-masked]>
Date: Tue, 27 Nov 2012 12:31:05 -0500

I have read the draft.

It would be useful to have test vectors for the various algorithms, for implementers to validate their implementations.

The draft needs to specify how header extension encryption (as specified in draft-ietf-avtcore-srtp-encrypted-header-ext) is to be done when using the AES-GCM and AES-CCM algorithms.

I believe the consensus was that it should be done using the equivalent CTR-mode encryption transform, so I'd suggest adding something like the following text to this draft:

[Section Number]. Header Extension Encryption.

When RTP Header Extension Encryption [I-D.ietf-avtcore-srtp-encrypted-header-ext] is in use, a separate keystream is generated to encrypt selected RTP header extension elements.  For the AEAD_AES_128_GCM and the AEAD_AES_128_CCM algorithms, this keystream MUST be generated in the manner defined in [I-D.ietf-avtcore-srtp-encrypted-header-ext] for the AES_128_CM transform.  For the AEAD_AES_256_GCM and the AEAD_AES_256_CCM algorithms, the keystream MUST be generated in the manner defined for the AES_256_CM transform.

-----Original Message-----
From: Magnus Westerlund [mailto:[email-masked]] 
Sent: Tuesday, November 27, 2012 9:21 AM
To: IETF AVTCore WG
Subject: [AVTCORE] Working group last call on draft-ietf-avtcore-srtp-aes-gcm-03

WG,

This announces the WG last call on AES-GCM and AES-CCM Authenticated Encryption in Secure RTP (SRTP) https://datatracker.ietf.org/doc/draft-ietf-avtcore-srtp-aes-gcm/

Please provide any comments no later than the 12th of December. Also comments of the nature of "I have read it and have no comments and think it should be published" are highly valuable.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: "David McGrew (mcgrew)" <[email-masked]>
Date: Tue, 27 Nov 2012 17:47:28 +0000

Thanks Jonathan for the review and suggested text.   I agree about the
header extension encryption.

David

On 11/27/12 12:31 PM, "Jonathan Lennox" <[email-masked]> wrote:

>I have read the draft.
>
>It would be useful to have test vectors for the various algorithms, for
>implementers to validate their implementations.
>
>The draft needs to specify how header extension encryption (as specified
>in draft-ietf-avtcore-srtp-encrypted-header-ext) is to be done when using
>the AES-GCM and AES-CCM algorithms.
>
>I believe the consensus was that it should be done using the equivalent
>CTR-mode encryption transform, so I'd suggest adding something like the
>following text to this draft:
>
>When RTP Header Extension Encryption
>[I-D.ietf-avtcore-srtp-encrypted-header-ext] is in use, a separate
>keystream is generated to encrypt selected RTP header extension elements.
> For the AEAD_AES_128_GCM and the AEAD_AES_128_CCM algorithms, this
>keystream MUST be generated in the manner defined in
>[I-D.ietf-avtcore-srtp-encrypted-header-ext] for the AES_128_CM
>transform.  For the AEAD_AES_256_GCM and the AEAD_AES_256_CCM algorithms,
>the keystream MUST be generated in the manner defined for the AES_256_CM
>transform.
>
>This announces the WG last call on AES-GCM and AES-CCM Authenticated
>Encryption in Secure RTP (SRTP)
>https://datatracker.ietf.org/doc/draft-ietf-avtcore-srtp-aes-gcm/
>
>Please provide any comments no later than the 12th of December. Also
>comments of the nature of "I have read it and have no comments and think
>it should be published" are highly valuable.
>
>Cheers
>
>Magnus Westerlund
>