Subject: [AVTCORE] Comments on draft-ietf-avtcore-clksrc-02

From: John Fletcher <[email-masked]>
Date: Wed, 20 Feb 2013 15:56:43 +0000

I have reviewed draft-ietf-avtcore-clksrc-02 and have the following comments:

Abstract - Suggest use of the term "NTP format" to make it clear that the source of the timestamp may not have been NTP, e.g. it might have been PTP.

Introduction - A better/alternative reference for "genlock" is SMPTE ST 318-1999.

Introduction - AES11 (DARS) is preferred over "word clock" as an audio reference signal.

Section 4 - Suggest mentioning PTP as well as NTP as examples of network time protocols.

Section 4.7 - Would it be worth including items for PTP grandmaster parameters clockClass, clockAccuracy and timeSource?  Even if clocks had a different grandmaster, they might still be considered equivalent if both locked to a primary reference time source.

Regards,
John Fletcher

-----------------------------
http://www.bbc.co.uk
This e-mail (and any attachments) is confidential and
may contain personal views which are not the views of the BBC unless specifically stated.
If you have received it in
error, please delete it from your system.
Do not use, copy or disclose the
information in any way nor act in reliance on it and notify the sender
immediately.
Please note that the BBC monitors e-mails
sent or received.
Further communication will signify your consent to
this.
-----------------------------

---

From: Aidan Williams <[email-masked]>
Date: Fri, 22 Feb 2013 16:36:40 +1100 (EST)

Hi John,

Thanks for your comments and reference suggestions.

...

> Section 4.7 - Would it be worth including items for PTP grandmaster
> parameters clockClass, clockAccuracy and timeSource? Even if clocks
> had a different grandmaster, they might still be considered
> equivalent if both locked to a primary reference time source.

To allow PTP, NTP or local clocks locked to primary sources to be
considered equivalent, the signalling supports the "traceable" keyword.
"Traceable" means that the clock is ultimately sourced from TAI.

Clocks that are signalled as as traceable can be considered
equivalent (see section 4.6).

regards
        aidan
____
:wq!