Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-rtp-circuit-breakers-03.txt

From: [email-masked]
Date: Mon, 15 Jul 2013 11:55:34 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Audio/Video Transport Core Maintenance Working Group of the IETF.

	Title           : Multimedia Congestion Control: Circuit Breakers for Unicast RTP Sessions
	Author(s)       : Colin Perkins
                          Varun Singh
	Filename        : draft-ietf-avtcore-rtp-circuit-breakers-03.txt
	Pages           : 17
	Date            : 2013-07-15

Abstract:
   The Real-time Transport Protocol (RTP) is widely used in telephony,
   video conferencing, and telepresence applications.  Such applications
   are often run on best-effort UDP/IP networks.  If congestion control
   is not implemented in the applications, then network congestion will
   deteriorate the user's multimedia experience.  This document does not
   propose a congestion control algorithm; instead, it defines a minimal
   set of RTP "circuit-breakers".  Circuit-breakers are conditions under
   which an RTP sender needs to stop transmitting media data in order to
   protect the network from excessive congestion.  It is expected that,
   in the absence of severe congestion, all RTP applications running on
   best-effort IP networks will be able to run without triggering these
   circuit breakers.  Any future RTP congestion control specification
   will be expected to operate within the constraints defined by these
   circuit breakers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-rtp-circuit-breakers

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-avtcore-rtp-circuit-breakers-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-rtp-circuit-breakers-03

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Colin Perkins <[email-masked]>
Date: Thu, 18 Jul 2013 16:19:51 +0100

This is a relatively minor update, based on comments received during the last meeting. Changes include:

- In Section 4.3, reorder the text to be clearer that the sender is allowed to reduce it's sending rate by a factor of ten when the congestion circuit breaker fires, to see if this resolves the problem, before it has to cease transmission.

- In Section 4.2 and Section 4.3, add some text about sessions with a large enough number of media streams that the receivers has to generate round-robin RTCP reception reports.

- In Section 4.3, clarify what RTCP reporting interval is used to trigger the circuit breaker

- Add Section 7 on the Impact of RTCP Reporting Groups.

There are also some minor editorial fixes.

Colin

On 15 Jul 2013, at 19:55, [email-masked] wrote:
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

-- 
Colin Perkins
http://csperkins.org/