Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-rtp-circuit-breakers-07.txt

From: [email-masked]
Date: Mon, 27 Oct 2014 15:44:47 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Audio/Video Transport Core Maintenance Working Group of the IETF.

        Title           : Multimedia Congestion Control: Circuit Breakers for Unicast RTP Sessions
        Authors         : Colin Perkins
                          Varun Singh
	Filename        : draft-ietf-avtcore-rtp-circuit-breakers-07.txt
	Pages           : 21
	Date            : 2014-10-27

Abstract:
   The Real-time Transport Protocol (RTP) is widely used in telephony,
   video conferencing, and telepresence applications.  Such applications
   are often run on best-effort UDP/IP networks.  If congestion control
   is not implemented in the applications, then network congestion will
   deteriorate the user's multimedia experience.  This document does not
   propose a congestion control algorithm; instead, it defines a minimal
   set of RTP "circuit-breakers".  Circuit-breakers are conditions under
   which an RTP sender needs to stop transmitting media data in order to
   protect the network from excessive congestion.  It is expected that,
   in the absence of severe congestion, all RTP applications running on
   best-effort IP networks will be able to run without triggering these
   circuit breakers.  Any future RTP congestion control specification
   will be expected to operate within the constraints defined by these
   circuit breakers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-rtp-circuit-breakers/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-avtcore-rtp-circuit-breakers-07

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-rtp-circuit-breakers-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Colin Perkins <[email-masked]>
Date: Mon, 27 Oct 2014 22:59:43 +0000

Changes in this version include:

- update Section 4.1 to consistently require three consecutive reports before triggering the circuit breaker;

- in Section 4.2, in the discussion of large sessions that round-robin SR/RR reports, strengthen the requirement to treat receipt of any SR/RR packet on the 5-tuple as an indication that the path is working from MAY to SHOULD;

- in Section 4.3, wait for three consecutive reporting intervals before triggering the circuit breaker, to match Sections 4.1 and 4.2;

- update Section 4.3: when sending at a low rate (loss than 1 packet per RTT), a sender MAY ignore a single instance of the congestion circuit breaker, but SHOULD cease transmission if it triggers again immediately, addressing the case where the packet loss rate estimate is inaccurate, due to being derived from too few packets;

- in Section 4.4, clarify that receivers should monitor media quality and terminate the session if it is unusable, not just senders;

- in section 5, clarify when non-compound packets should be ignored;

- add a new section on impact of layered coding;

- add discussion of problem caused by overly long RTCP reporting intervals to the Security Considerations;

- add an Open Issues Section; and

- various minor editorial fixes.

Comments and feedback is welcome.

Colin

On 27 Oct 2014, at 22:44, [email-masked] wrote:
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

-- 
Colin Perkins
https://csperkins.org/