Subject: [AVTCORE] Review and support for working on of multipath RTP

From: "Roni Even" <[email-masked]>
Date: Tue, 7 Oct 2014 19:57:54 +0300

Hi,

At IETF90 there was interest in this work and Emil volunteered to review.
(http://tools.ietf.org/id/draft-singh-avtcore-mprtp-09.txt )

The meeting note say:

"Seems useful, but should probably stay out of pure transport problems, and
has to pay attention to what is done in RMCAT. Less than a handful of people
responded to have read the current document, and it thus needs more
reviewers. Emil Ivov volunteers to read it."

We are looking for more reviewers and to get a feeling about interest in
this work by reviewing and contributing to the work.

Please let us know if you think we should adopt this work in AVTcore

Thanks

Roni Even

AVTcore co-chair

---

From: "Globisch, Ralf" <[email-masked]>
Date: Thu, 9 Oct 2014 09:45:40 +0000

Hi Roni,

Comments inline.

> At IETF90 there was interest in this work and Emil volunteered to review. (http://tools.ietf.org/id/draft-singh-avtcore-mprtp-09.txt )
> The meeting note say:
> “Seems useful, but should probably stay out of pure transport problems, and has to pay attention to what is done in RMCAT. Less than a handful of people responded to have read the current document, and it thus needs more reviewers. Emil Ivov volunteers to read it.”

We have been following the progress of MPRTP since 2011 and have provided comments/feedback on earlier versions of the draft to Varun Singh per email.
In hindsight, perhaps the feedback would have been more appropriate on the mailing list (to show interest).

> We are looking for more reviewers and to get a feeling about interest in this work by reviewing and contributing to the work.

I will (re)read the latest version of the draft and provide feedback.

In terms of interest in the work, we have developed an implementation of the MPRTP and the MPRTP SDP (http://tools.ietf.org/html/draft-singh-mmusic-mprtp-sdp-extension-03)
drafts and are planning a cross-check with the implementation by Aalto university in the next couple of months.

> Please let us know if you think we should adopt this work in AVTcore

I think this work is important and complements the work being done in MPTCP, SCTP CMT, and should be adopted in AVTcore.
Before we "discovered" the MPRTP draft, we were looking at extending RTP to have similar functionality as described in the MPRTP draft.
The MPRTP draft however solved the issues we were trying to address at the time and we decided to use the MPRTP draft instead of
inventing something similar.

While there are outstanding issues and perhaps some things that could be done differently/better, AVTcore is the ideal place for that to happen IMO.

Disclosure: we are collaborating with the authors of the MPRTP draft on the MPRTP SDP draft.
This collaboration came about by us investigating the applicability of MPRTP in other use-cases/scenarios.

Regards,
Ralf

---

From: Emil Ivov <[email-masked]>
Date: Sat, 11 Oct 2014 12:42:02 +0200

On 07.10.14, 18:57, Roni Even wrote:
> Hi,
>
> At IETF90 there was interest in this work and Emil volunteered to
> review. (http://tools.ietf.org/id/draft-singh-avtcore-mprtp-09.txt )

Will do!

Emil
>
> The meeting note say:
>
> “Seems useful, but should probably stay out of pure transport problems,
> and has to pay attention to what is done in RMCAT. Less than a handful
> of people responded to have read the current document, and it thus needs
> more reviewers. Emil Ivov volunteers to read it.”
>

-- 
https://jitsi.org

---

From: MAZE Frederic <[email-masked]>
Date: Mon, 13 Oct 2014 12:10:45 +0000

Dear AVTCORE experts,

I also support the adoption of this draft.
I already sent some comments/feedbacks to Varun Singh by direct email before last meeting and I will continue to review documents and provide feedbacks when necessary.
I think it is important to provide solutions that take benefit from multiple interfaces within devices as for MPTCP or CMT-SCTP, and MPRTP provides interesting approach to handle it in RTP context.

Regards,
--
Frederic MAZE

From: avt [mailto:[email-masked]] On Behalf Of Roni Even
Sent: mardi 7 octobre 2014 18:58
To: [email-masked]; Emil Ivov
Cc: 'Singh Varun'
Subject: [AVTCORE] Review and support for working on of multipath RTP

Hi,

The meeting note say:
"Seems useful, but should probably stay out of pure transport problems, and has to pay attention to what is done in RMCAT. Less than a handful of people responded to have read the current document, and it thus needs more reviewers. Emil Ivov volunteers to read it."

Thanks
Roni Even
AVTcore co-chair