Subject: [AVTCORE] Are thare any existing uses of CCM mode in SRTP?

From: "Igoe, Kevin M." <[email-masked]>
Date: Fri, 27 Feb 2015 20:08:27 +0000

Despite its name, the ID draft-avtcore-srtp aes-gcm actually supports two (2) AEAD  modes of operation, GCM and CCM.  There are known GCM based developments underway, but  at a telechat held yesterday to discuss this ID it became apparent that no one participating in the chat was aware of ANY use of CCM in SRTP.  Hence it was suggested we purge CCM from the current ID  

This is a call to the mailing list to see if anyone is aware of any concrete existing projects underway that use CCM mode in SRTP.  If there are none, CCM will be eliminated from the current ID. 

(Note that if at some date in the future someone wishes to deploy CCM in SRTP, a simple cut and paste from previous drafts of the current ID can be used to craft a new CCM only ID.)

---

From: "Wyss, Felix" <[email-masked]>
Date: Fri, 27 Feb 2015 20:19:40 +0000

I am very much in favor of removing CCM.  

Something I would like to ask for, though: Could you *please* add test vectors to the RFC?  As an implementer, having meaningful test vectors greatly helps in development and testing.  IMHO test vectors should be a MUST requirement for any RFCs describing cryptographic protocols.

Thanks,
--Felix

> -----Original Message-----
> From: avt [mailto:[email-masked]] On Behalf Of Igoe, Kevin M.
> Sent: Friday, February 27, 2015 15:08
> To: [email-masked]'
> Subject: [AVTCORE] Are thare any existing uses of CCM mode in SRTP?
> 
> Despite its name, the ID draft-avtcore-srtp aes-gcm actually supports two (2)
> AEAD  modes of operation, GCM and CCM.  There are known GCM based
> developments underway, but  at a telechat held yesterday to discuss this ID
> it became apparent that no one participating in the chat was aware of ANY
> use of CCM in SRTP.  Hence it was suggested we purge CCM from the current
> ID
> 
> This is a call to the mailing list to see if anyone is aware of any concrete
> existing projects underway that use CCM mode in SRTP.  If there are none,
> CCM will be eliminated from the current ID.
> 
> (Note that if at some date in the future someone wishes to deploy CCM in
> SRTP, a simple cut and paste from previous drafts of the current ID can be
> used to craft a new CCM only ID.)
> 
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt