Subject: Re: [AVTCORE] Review of draft-ietf-avtcore-rfc5764-mux-fixes-02

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 26 Jan 2016 12:26:34 -0800

Sorry for the delay in processing this.  See my answer inline.

On 09/25/2015 07:25 AM, Paul Kyzivat wrote:
> On 9/25/15 6:33 AM, Marc Petit-Huguenin wrote:
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA256
>>
>> Hi Paul,
>>
>> On 09/18/2015 10:17 AM, Paul Kyzivat wrote:
>>> On 9/17/15 4:10 PM, Marc Petit-Huguenin wrote:
>>>
>>>>> K. Section 3:
>>>>>
>>>>> When new values or ranges are added, they MUST be tested in
>>>>> ascending order.
>>>>>
>>>>
>>>> This text should not talk about adding new values/ranges. Changed
>>>> the text to:
>>>>
>>>> "The various range values for the first byte MUST be tested in
>>>> ascending order."
>>>
>>> I just reviewed this, and I have no idea what it means. I see nothing
>>> about Figure 3 that requires testing to be done in a particular
>>> order. The *text* suggests an if/then/else or switch statement
>>> implementation. But the code generated for a switch statement may
>>> well be a lookup table and so have no particular ordering.
>>>
>>> The only time ordering would matter would be if the ranges
>>> overlapped. And IIUC the goal here that the ranges *not* overlap.
>>
>> The reason we added this was to plan when a new overlapping range is added (mostly because someone ignored the advices provided by this draft).  If the algorithm says today that range must be checked in ascending order, then *all* implementations will work (or, most likely, fail) in a similar way.  That sentence is meant to explicitly prevent using a lookup table or perfect hashing or whatever technique that would prevent things to fail identically everywhere.
>>
>> That said the sentence can probably be improved.
> 
> Yes.
> 
> Do you consider overlapping ranges to be an error, and want the error to be handled deterministically? Or are you thinking that there may be overt changes that legally define overlapping ranges and want to make the meaning deterministic?
> 
> If there is a deterministic choice when ranges overlap, then that seems to effectively update one of the ranges so that they don't overlap.

After more discussions between authors, we decided to remove the section about ordering altogether.  We now think that even if the proposal is not as future-proof as possible, it is good enough.

Thanks.

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 26 Jan 2016 16:41:43 -0500

> After more discussions between authors, we decided to remove the section about ordering altogether.  We now think that even if the proposal is not as future-proof as possible, it is good enough.

This works better for me. Thanks!

A few comments on -04:

* Section 5 (Terminology):

This is now section 5. That seems wrong. The document will read better 
if you make it section 2.

* Section 6 (RFC5764 Updates):

The new text still has some remnants of the ordering. In particular: 
"Then if ... Then if ... Then if ... Else if ...".

I suggest changing this to "If ... If ... If ... If ...".

Otherwise I'm happy.

	Thanks,
	Paul

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Tue, 26 Jan 2016 22:08:53 +0000

Thanks for the review, Paul.  Posted an -05  addressing both your points.

Cheers,

Gonzalo

> On Jan 26, 2016, at 1:41 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> This is now section 5. That seems wrong. The document will read better if you make it section 2.
> 
> The new text still has some remnants of the ordering. In particular: "Then if ... Then if ... Then if ... Else if ...".
> 
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 26 Jan 2016 18:27:31 -0500

> Thanks for the review, Paul.  Posted an -05  addressing both your points.

OK. I'm satisfied!

	Thanks,
	Paul