Subject: [AVTCORE] Fwd: I-D Action: draft-lennox-avtcore-dtls-srtp-bigaes-00.txt

From: Jonathan Lennox <[email-masked]>
Date: Mon, 27 Mar 2017 23:08:39 +0000

For some reason, codepoints for the SRTPProtectionProfiles SRTP_AES256_CM_HMAC_SHA1_80 and SRTP_AES256_CM_HMAC_SHA1_32 were never assigned for DTLS/SRTP.

After some discussion yesterday, people generally seemed pretty sure it was an oversight — these registrations got taken out of draft-ietf-avt-dtls-srtp because draft-ietf-avt-srtp-big-aes wasn’t ready yet, but they never then got put into draft-ietf-avt-srtp-big-aes.

Thus, I put together a short draft doing the registration.  The meat of it is copy and pasted from draft-ietf-avt-dtls-srtp-03, the final version before these registrations got taken out.

Comments are welcome.  It’s a very short document, and if people could at least look it over before tomorrow’s AVTCORE meeting (and I apologize for the very short notice) I’d appreciate it.

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: I-D Action: draft-lennox-avtcore-dtls-srtp-bigaes-00.txt
Date: March 27, 2017 at 6:07:15 PM CDT
To: <[email-masked]<mailto:[email-masked]>>
Resent-From: Jonathan Lennox <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>
Reply-To: <[email-masked]<mailto:[email-masked]>>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

       Title           : DTLS/SRTP Protection Profiles for 256-bit AES-CTR Encryption
       Author          : Jonathan Lennox
Filename        : draft-lennox-avtcore-dtls-srtp-bigaes-00.txt
Pages           : 5
Date            : 2017-03-27

Abstract:
  This memo defines Datagram Transport Layer Security (DTLS) Secure
  Real-time Transport Protocol (SRTP) Protection Profiles for 256-bit
  Advanced Encryption Standard (AES) Counter Mode.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-lennox-avtcore-dtls-srtp-bigaes/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-lennox-avtcore-dtls-srtp-bigaes-00
https://datatracker.ietf.org/doc/html/draft-lennox-avtcore-dtls-srtp-bigaes-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Martin Thomson <[email-masked]>
Date: Tue, 28 Mar 2017 05:50:51 -0500

This looks pretty good.  You should probably include a nod toward the
recent SHA-1 collisions, and note the use of HMAC, which is still
apparently unaffected by this.

On 27 March 2017 at 18:08, Jonathan Lennox <[email-masked]> wrote:
> For some reason, codepoints for the SRTPProtectionProfiles
> SRTP_AES256_CM_HMAC_SHA1_80 and SRTP_AES256_CM_HMAC_SHA1_32 were never
> assigned for DTLS/SRTP.
>
> After some discussion yesterday, people generally seemed pretty sure it was
> an oversight — these registrations got taken out of draft-ietf-avt-dtls-srtp
> because draft-ietf-avt-srtp-big-aes wasn’t ready yet, but they never then
> got put into draft-ietf-avt-srtp-big-aes.
>
> Thus, I put together a short draft doing the registration.  The meat of it
> is copy and pasted from draft-ietf-avt-dtls-srtp-03, the final version
> before these registrations got taken out.
>
> Comments are welcome.  It’s a very short document, and if people could at
> least look it over before tomorrow’s AVTCORE meeting (and I apologize for
> the very short notice) I’d appreciate it.
>
> Begin forwarded message:
>
> From: <[email-masked]>
> To: <[email-masked]>
> Resent-From: Jonathan Lennox <[email-masked]>
> Resent-To: <[email-masked]>
> Reply-To: <[email-masked]>
>
>
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>