Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-cc-feedback-message-03.txt

From: [email-masked]
Date: Sun, 23 Dec 2018 05:59:33 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Core Maintenance WG of the IETF.

        Title           : RTP Control Protocol (RTCP) Feedback for Congestion Control
        Authors         : Zaheduzzaman Sarker
                          Colin Perkins
                          Varun Singh
                          Michael A. Ramalho
	Filename        : draft-ietf-avtcore-cc-feedback-message-03.txt
	Pages           : 13
	Date            : 2018-12-23

Abstract:
   This document describes an RTCP feedback message intended to enable
   congestion control for interactive real-time traffic using RTP.  The
   feedback message is designed for use with a sender-based congestion
   control algorithm, in which the receiver of an RTP flow sends RTCP
   feedback packets to the sender containing the information the sender
   needs to perform congestion control.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-cc-feedback-message/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-avtcore-cc-feedback-message-03
https://datatracker.ietf.org/doc/html/draft-ietf-avtcore-cc-feedback-message-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-cc-feedback-message-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Colin Perkins <[email-masked]>
Date: Sun, 23 Dec 2018 14:16:14 +0000

This version includes the following changes:

Fixes the description of arithmetic on sequence numbers, which should be done modulo 65536 not 65535;
Switch to using num_reports rather than end_seq + 1 in report blocks;
Better explain the value of the ATO field, in particular what value to include for packets that are know to have arrived after the time instant denoted by the RTS field;
Better explain the value of the RTS field;
Note that if a packet was reported as received in a report, then that packet MUST also be reported as received in any overlapping reports sent later that cover its sequence number range;
Don’t try to explain how to recover after an outage, since recovering state in that case is a general RTCP problem and not specific to this report block;
Better explain how to report on duplicate packets;
Clarify that the receiver has to report on every active SSRC since it can’t tell what SSRCs are being congestion controlled;
Clarify that wild card payload types need to be used in the SDP signalling; and
Explain relation to RFC 6679.

The first two changes are made to belatedly address feedback from the Montréal IETF. The other changes attempt to address feedback from Jonathan Lennox based on implementation experience during the hackathon at the Bangkok IETF meeting.

Colin

> On 23 Dec 2018, at 13:59, [email-masked] wrote:
> 
> 
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

-- 
Colin Perkins
https://csperkins.org/