Subject: [AVTCORE] Mail regarding draft-ietf-payload-tetra

From: Marc Weustink <[email-masked]>
Date: Tue, 8 Oct 2019 13:36:40 +0200

Hi,

Has the payload description any relation to ETSI TS 100 392-19-2 ?
Imo it should be avoided to have 2 different RTP payload descriptions 
for the same (?) TETRA ACELP.

Best regards,
Marc Weustink

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 09 Oct 2019 22:33:50 -0400

> for the same (?) TETRA ACELP.

I tried to track this down.  I think you mean to refer to:

https://www.etsi.org/deliver/etsi_en/300300_300399/30039503/01.02.00_40/en_30039503v010200o.pdf

    ETSI EN 300 395-3 V1.2.0 (2004-09)
    European Standard (Telecommunications series)
    Terrestrial Trunked Radio (TETRA);
    Speech codec for full-rate traffic channel;
    Part 3: Specific operating features

But a search for "RTP" in that document had 0 hits.  So I expect that
draft-ietf-payload-tetra contains information not in ETSI.

OTOH, the referencing from draft-ietf-payload-tetra to the ETSI
documents seems incomplete.  Section 4.4 says

   The payload itself contains TETRA ACELP coded speech information
   encoded according to table 4 of [ETSI-TETRA-Codec].

but searching for "table 4" in the ETSI document finds a table that
doesn't seem to describe a speech encoding method.

Also, section 4.2 gives a detailed payload layout, showing 8 fields, of
which the 7th is the "D" field containing the audio information proper.
But the subsections of 4.2 define the use of every field *except* the D
field.

Dale

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 10 Oct 2019 05:10:16 +0000

Hi,
This issue was discussed with the authored and the AD. 
This problem started that during the work in payload WG on tetra RTP payload there was a request from ETSI to IANA to register the tetra media subtype name. this request did not go also to payload WG chairs so it was missed otherwise the payload chairs would have asked to first see how to synchronize those two requests . The conclusion was that if the RTP media subtype specifications are different we can have another RTP media subtype with a different name.
See the last mail  https://mailarchive.ietf.org/arch/msg/payload/5ZLf35CXB1LaWZX_zTCLUKG2h2U 

Roni Even 
AVTcore WG co-chair (former Payload WG  co-chair)

-----Original Message-----
From: avt [mailto:[email-masked]] On Behalf Of Marc Weustink
Sent: Tuesday, October 08, 2019 2:37 PM
To: [email-masked]
Subject: [AVTCORE] Mail regarding draft-ietf-payload-tetra

Hi,

Has the payload description any relation to ETSI TS 100 392-19-2 ?
Imo it should be avoided to have 2 different RTP payload descriptions for the same (?) TETRA ACELP.

Best regards,
Marc Weustink

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Marc Weustink <[email-masked]>
Date: Thu, 10 Oct 2019 18:12:41 +0200

>      Part 3: Specific operating features

I was refering to this one:

https://www.etsi.org/deliver/etsi_ts/100300_100399/1003921902/01.01.01_60/ts_1003921902v010101p.pdf

I haven't done an in depth comparison to draft-ietf-payload-tetra it 
seems both try to encode the same information

Marc