Subject: [AVTCORE] Francesca Palombini's No Objection on draft-ietf-payload-rtp-jpegxs-16: (with COMMENT)

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Wed, 16 Jun 2021 15:42:07 -0700

Francesca Palombini has entered the following ballot position for
draft-ietf-payload-rtp-jpegxs-16: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-payload-rtp-jpegxs/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work on this document. I have some non-blocking comments and
observations.

Francesca

1. -----

   A JPEG XS codestream header, starting with an SOC marker, followed by
   one or more slices, and terminated by an EOC marker form a JPEG XS
   codestream.

FP: I understand from the terminology what this is meant to specify, however
how this is expressed makes it slightly confusing: it is not clear that the
subject of "followed" is "A JPEG XS codestream header" and not "an SOC marker".

2. -----

FP: I agree with John that without access to ISO21122-{1,2,3}, it's not
possible to do a complete review; in particular the media type registration
contains parameters that are inherited by the ISO standards, with normative
text that I cannot review. Like John, I trust the responsible AD on that the
doc has had sufficient reviews in the WG, from people with access to the ISO
specifications.

3. -----

FP: I couldn't find that the Media type registration has been posted to the
media-type mailing list, was that done? This was also highlighted in the
shepherd write up, which I found helpful, so thank you Bernard.

---

From: Tim Bruylants <[email-masked]>
Date: Thu, 17 Jun 2021 19:04:07 +0000

> Thank you for the work on this document. I have some non-blocking comments and observations.
>
> Francesca
>
> 1. -----
>
> FP: I understand from the terminology what this is meant to specify, however how this is expressed makes it slightly confusing: it is not clear that the subject of "followed" is "A JPEG XS codestream header" and not "an SOC marker".

We reformulated this definition. It was indeed confusing.

> 2. -----
>
> FP: I agree with John that without access to ISO21122-{1,2,3}, it's not possible to do a complete review; in particular the media type registration contains parameters that are inherited by the ISO standards, with normative text that I cannot review. Like John, I trust the responsible AD on that the doc has had sufficient reviews in the WG, from people with access to the ISO specifications.

This is a valid comment. We are unsure how to resolve this. ISO is very strict about distribution of documents outside of the working groups (i.e. it is not allowed at all). I suppose the DISCUSS will trigger some resolution.

> 3. -----
>
> FP: I couldn't find that the Media type registration has been posted to the media-type mailing list, was that done? This was also highlighted in the shepherd write up, which I found helpful, so thank you Bernard.

We did receive feedback concerning the media type registration some weeks ago. But please do verify.