Subject: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

From: [email-masked]
Date: Wed, 09 Jun 2021 23:55:29 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Core Maintenance WG of the IETF.

        Title           : RTP Payload Format for ISO/IEC 21122 (JPEG XS)
        Authors         : Sébastien Lugan
                          Antonin Descampe
                          Corentin Damman
                          Thomas Richter
                          Tim Bruylants
	Filename        : draft-ietf-payload-rtp-jpegxs-16.txt
	Pages           : 31
	Date            : 2021-06-09

Abstract:
   This document specifies a Real-Time Transport Protocol (RTP) payload
   format to be used for transporting JPEG XS (ISO/IEC 21122) encoded
   video.  JPEG XS is a low-latency, lightweight image coding system.
   Compared to an uncompressed video use case, it allows higher
   resolutions and frame rates, while offering visually lossless
   quality, reduced power consumption, and end-to-end latency confined
   to a fraction of a frame.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-payload-rtp-jpegxs/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-payload-rtp-jpegxs-16

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-payload-rtp-jpegxs-16

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Thomas Richter <[email-masked]>
Date: Wed, 16 Jun 2021 11:53:40 +0200

Dear members, Tim,
> This draft is a work item of the Audio/Video Transport Core Maintenance WG of the IETF.

is it too late to ask for making the packetmode parameter mandatory 
instead of optional, thus implying a clarification of the SDP parameter?

Greetings,
	Thomas

---

From: Tim Bruylants <[email-masked]>
Date: Wed, 16 Jun 2021 10:09:53 +0000

Hi Thomas,

I don't know. It does not impact the text itself, but it does impact some implementations that might already exist. The document is currently (actually today) under review at the IESG Telechat, so I'm expecting some feedback there. But I'm not sure if we can still change this (or not).

What is the issue with this parameter being optional? SDP enables you to specify the parameter when negotiating, so implementations that need to can always specify it. I'm probably missing a use-case here.

Tim.

-----Original Message-----
From: Thomas Richter <[email-masked]> 
Sent: Wednesday 16 June 2021 11:54
To: [email-masked]; Tim Bruylants <[email-masked]>
Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

Dear members, Tim,
> This draft is a work item of the Audio/Video Transport Core Maintenance WG of the IETF.

is it too late to ask for making the packetmode parameter mandatory instead of optional, thus implying a clarification of the SDP parameter?

Greetings,
	Thomas

---

From: Thomas Richter <[email-masked]>
Date: Wed, 16 Jun 2021 12:19:16 +0200

> What is the issue with this parameter being optional? SDP enables you to specify the parameter when negotiating, so implementations that need to can always specify it. I'm probably missing a use-ca…

The use case is that a decoder does not need to guess what type of a 
stream is coming, even in case it supports both types. This may result 
in a quicker setup time. IOWs, there is no stream analysis needed. In 
case the first attempt at the transport type is incorrect, this may 
loose a frame.

Greetings,
	Thomas

---

From: Tim Bruylants <[email-masked]>
Date: Wed, 16 Jun 2021 11:14:13 +0000

Hi Thomas,

I will move this parameter un line up into the "required" parameters in the next draft version that I prepared. I'm still waiting for potential reviewers comments, so I'll issue the update after the IESG Telechat ends (so somewhere tomorrow). It won't change the way that our RTP draft works, so I guess (and hope) that this is an acceptable change.

Tim

-----Original Message-----
From: Thomas Richter <[email-masked]> 
Sent: Wednesday 16 June 2021 12:19
To: Tim Bruylants <[email-masked]>; [email-masked]
Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

> What is the issue with this parameter being optional? SDP enables you to specify the parameter when negotiating, so implementations that need to can always specify it. I'm probably missing a use-ca…

The use case is that a decoder does not need to guess what type of a stream is coming, even in case it supports both types. This may result in a quicker setup time. IOWs, there is no stream analysis needed. In case the first attempt at the transport type is incorrect, this may loose a frame.

Greetings,
	Thomas

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 16 Jun 2021 15:37:29 +0000

Not having skin in this game, but historically most RTP payload formats try to minimize the number of required parameters and instead specify default values in case a parameter is not included.  That keeps the SDP small while still allowing for the necessary flexibility.  And, it avoids unnecessary discussions motivated by unnecessary IPR.
S.

On 6/16/21, 04:14, "avt on behalf of Tim Bruylants" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Thomas,

    Tim

    -----Original Message-----
    From: Thomas Richter <[email-masked]> 
    Sent: Wednesday 16 June 2021 12:19
    To: Tim Bruylants <[email-masked]>; [email-masked]
    Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

    Greetings,
    	Thomas

    _______________________________________________
    Audio/Video Transport Core Maintenance
    [email-masked]
    https://www.ietf.org/mailman/listinfo/avt

---

From: John Fletcher <[email-masked]>
Date: Wed, 16 Jun 2021 15:55:02 +0000

I realise it is extremely late to comment on this but if there is time to make changes, could I suggest that the section on Traffic Shaping and Delivery Timing is removed (and the reference to it at the end of 8.1)?

The intention of SMPTE ST 2110-21 was not that payload definitions would reference it but that implementations could state that they comply with it.  For example, an implementation could say it uses the JPEG-XS payload as specified in RFC xxxx and compiles with SMPTE ST 2110-21.
Repeating provisions of ST 2110-21 such as the TP parameter is unhelpful because it could lead to a conflict if the parameters in the SMPTE standard are revised.

Thanks,
John Fletcher

---

From: Tim Bruylants <[email-masked]>
Date: Wed, 16 Jun 2021 20:03:11 +0000

I think having default values is indeed a very clean way to handle such case. Good suggestion.

Regardless, we need to see what can be done (and what not) to the text at this stage.

Tim.

-----Original Message-----
From: Stephan Wenger <[email-masked]> 
Sent: Wednesday 16 June 2021 17:37
To: Tim Bruylants <[email-masked]>; Thomas Richter <[email-masked]>; [email-masked]
Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

    Hi Thomas,

    Tim

    -----Original Message-----
    From: Thomas Richter <https://urldefense.proofpoint.com/v2/url?u=http-3A__thomas.richter-40iis.fraunhofer.de&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=XCJoW-7jJ_X3EhNCjNm4AyEnQ7DCBV4F-AZfVv0D0Iw&s=DXrCmA3CuekbjAt6Njw7Q2nSSmbI6WvdFhSTGJOJEp4&e=> 
    Sent: Wednesday 16 June 2021 12:19
    To: Tim Bruylants <[email-masked]>; [email-masked]
    Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

    Greetings,
    	Thomas

    _______________________________________________
    Audio/Video Transport Core Maintenance
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_avt&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=XCJoW-7jJ_X3EhNCjNm4AyEnQ7DCBV4F-AZfVv0D0Iw&s=S7kZM4PBD7ffiw9t-EVeNHhJ370TY6Ms8KVke-5Ex5o&e=

---

From: Tim Bruylants <[email-masked]>
Date: Wed, 16 Jun 2021 20:05:35 +0000

Hi John,

While I agree, this was discussed before and it was decided to keep the traffic shaping references (some argued in favor). We did however make it a recommended section, and as such it is not normative.

Best regards,
Tim

-----Original Message-----
From: avt <[email-masked]> On Behalf Of John Fletcher
Sent: Wednesday 16 June 2021 17:55
To: [email-masked]
Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

Thanks,
John Fletcher

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_avt&d=DwICAg&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=7uH5EmQ80IL8Ny91nr1rxKBEQasuZUf_iNmqGdfabPA&s=MZ7kcTkofZ5YzognaeJQi1vaFibJYKtTEl92s2tc8xs&e=

---

From: Thomas Richter <[email-masked]>
Date: Thu, 17 Jun 2021 08:59:18 +0200

Tim, John,

> While I agree, this was discussed before and it was decided to keep the traffic shaping references (some argued in favor). We did however make it a recommended section, and as such it is not normat…

Traffic shaping recommendations I believe is a good idea as this can be 
very tricky, and it may be very handy to have these references in place 
when you need them.

Concerning default parameters: That's a good idea as long as a 
particular default can be reasonably picked. For this particular 
parameter, it is a bit tricky since the "best" value depends on 
implementation choices and one could consider eithter of the two binary 
values a good default. The "in-order traffic" parameter (which is 
currently a mandatory parameter) would be a better candidate.

Greetings,
	Thomas

---

From: John Fletcher <[email-masked]>
Date: Thu, 17 Jun 2021 08:12:11 +0000

Understood but I think it would be better just to recommend compliance with ST 2110-21 without repeating provisions of ST 2110-21.  As I said, duplicating the provisions causes a problem if the SMPTE standard is revised.  The TP values you list are not actually the same as the ones in the current SMPTE standard.  So I wonder if you would consider removing the details of TP parameter values?

By the way, we are planning to revise ST 2110-21 to clarify that it makes no requirement concerning gapped or linear transmission pattern.

Thanks,
John

-----Original Message-----
From: Tim Bruylants <[email-masked]>
Sent: 16 June 2021 21:06
To: John Fletcher <[email-masked]>; [email-masked]
Subject: RE: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

Hi John,

Best regards,
Tim

-----Original Message-----
From: avt <[email-masked]> On Behalf Of John Fletcher
Sent: Wednesday 16 June 2021 17:55
To: [email-masked]
Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

Thanks,
John Fletcher

---

From: Tim Bruylants <[email-masked]>
Date: Thu, 17 Jun 2021 19:08:02 +0000

Hi John,

We have reformulated this paragraph to be more "neutral" to the SMPTE ST 2110-21 specification. I hope it is now no longer duplicating 2110-21 provisions.

Regards,
Tim

-----Original Message-----
From: John Fletcher <[email-masked]> 
Sent: Thursday 17 June 2021 10:12
To: Tim Bruylants <[email-masked]>
Cc: [email-masked]
Subject: RE: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

Thanks,
John

-----Original Message-----
From: Tim Bruylants <[email-masked]>
Sent: 16 June 2021 21:06
To: John Fletcher <[email-masked]>; [email-masked]
Subject: RE: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

Hi John,

Best regards,
Tim

-----Original Message-----
From: avt <[email-masked]> On Behalf Of John Fletcher
Sent: Wednesday 16 June 2021 17:55
To: [email-masked]
Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

Thanks,
John Fletcher

---

From: Tim Bruylants <[email-masked]>
Date: Thu, 17 Jun 2021 19:12:08 +0000

Following this comment by Stephan Wenger, we changed the "transmode" parameter from required to optional and provided a default behavior when not specified. We modified the "packetmode" parameter from optional to required because no neutral default behavior is favorable.

Tim.

-----Original Message-----
From: Stephan Wenger <[email-masked]> 
Sent: Wednesday 16 June 2021 17:37
To: Tim Bruylants <[email-masked]>; Thomas Richter <[email-masked]>; [email-masked]
Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

    Hi Thomas,

    Tim

    -----Original Message-----
    From: Thomas Richter <https://urldefense.proofpoint.com/v2/url?u=http-3A__thomas.richter-40iis.fraunhofer.de&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=XCJoW-7jJ_X3EhNCjNm4AyEnQ7DCBV4F-AZfVv0D0Iw&s=DXrCmA3CuekbjAt6Njw7Q2nSSmbI6WvdFhSTGJOJEp4&e=> 
    Sent: Wednesday 16 June 2021 12:19
    To: Tim Bruylants <[email-masked]>; [email-masked]
    Subject: Re: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-16.txt

    Greetings,
    	Thomas