Subject: Re: [AVTCORE] Zaheduzzaman Sarker's Discuss on draft-ietf-payload-rtp-jpegxs-16: (with DISCUSS)

From: Stephan Wenger <[email-masked]>
Date: Thu, 17 Jun 2021 19:48:09 +0000

Hi,

Copying Mayumi Koike, SC29 committee manager.

I'm sending this wearing my hat as the IETF's liaison to ISO/IEC JTC1/SC29, which includes SC29's WG1 JPEG.

It is my understanding that ISO documents can be shared in a liaison relationship, which we have here.  The IETF is a cat A liaison organization to SC29.  According to the ISO Directives (2021) (https://www.iso.org/sites/directives/current/consolidated/index.xhtml#_idTextAnchor095), section 1.17.2, subclause Category A, "[...] Such organizations are given access to all relevant documentation [...]".

Mayumi, can you please confirm?  For context, an RTP payload format for JPEG-XS under standardization in the IETF faces a hurdle in the approval process as it normatively references ISO/IEC 21122 and its subparts, and cannot be properly evaluated without having that ISO spec available.  What would be the easiest way to provide the IETF’s AVT WG with an appropriate copy?

Thanks,

Stephan

On 6/17/21, 12:10, "avt on behalf of Tim Bruylants" <[email-masked] on behalf of [email-masked]> wrote:

    > ----------------------------------------------------------------------

    > DISCUSS:

    > ----------------------------------------------------------------------

    > This memo is defining a RTP payload for JPEG XS that is not publicly available.

    > This hampers the review of the memo, specially when it is defining terminologies which ask me to look at the specifications.

    > This concerns has also been raised by other ADs.

    > Was this document made available during the work in the working group?

    This is a valid comment. We are unsure how to resolve this. ISO is very strict about distribution of documents outside of the working groups (i.e. it is not allowed at all).

    The ISO 21122 standards were written by some of the same authors as this RTP Payload spec (like myself and Thomas Richter), but the ISO documents were (to my knowledge) not shared.

    In order to resolve this issue, we need to know how IESG handled this with other ISO standards that are not open? Or is 21122 the first? Please advise.

    _______________________________________________

    Audio/Video Transport Core Maintenance

    [email-masked]

    https://www.ietf.org/mailman/listinfo/avt

---

From: Tim Bruylants <[email-masked]>
Date: Fri, 18 Jun 2021 08:14:38 +0000

(2nd try, without original image).

Hi Stephan, and also Spencer,

Thanks for stepping in on this. I think ISO makes it really complicated, but at least having you as IETF liaison can help move things forward.

In order to resolve the DISCUSS, what needs to be done now? Do/can we (authors of the RTP payload draft) need to do anything?

If anything, please let me know, I’m available to help resolving this.

Best regards,
Tim Bruylants -- intoPIX.

From: Mayumi Koike <[email-masked]>
Sent: Friday 18 June 2021 00:32
To: stewe <[email-masked]>; Tim Bruylants <[email-masked]>; Zaheduzzaman Sarker <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [AVTCORE] Zaheduzzaman Sarker's Discuss on draft-ietf-payload-rtp-jpegxs-16: (with DISCUSS)

Dear Stephan,

Thank you for asking.

As an A liaison representative from IETF to SC 29, you have access to standard documents discussed in SC 29 from ISO Project Portal. I am not sure about what part of ISO/IEC 21122 is on target in this discussion and am referring to Part 1 in the Portal. Please log in with your ISO credential. https://sd.iso.org/projects/project/74535/overview<https://urldefense.proofpoint.com/v2/url?u=https-3A__sd.iso.org_projects_project_74535_overview&d=DwMGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=SI4045jMgDg8ud-qqMTp-hnV1PFq15tOXekcuqaVtHQ&s=MwpMxXeHWJdWiw_6KOnDVuoP2ns6_d2gohPHT2CSpLg&e=> You can find other parts by searching.

Here, you will see Documents section at the bottom left as shown in the picture attached. What you see here is what you are allowed to have. Please note that each document is watermarked with your name.

Best regards,
Mayumi Koike

差出人: Stephan Wenger <[email-masked]<mailto:[email-masked]>>
日付: 金曜日, 2021年6月18日 4:48
宛先: Tim Bruylants <[email-masked]<mailto:[email-masked]>>, Zaheduzzaman Sarker <[email-masked]<mailto:[email-masked]>>, The IESG <[email-masked]<mailto:[email-masked]>>, Mayumi Koike <[email-masked]<mailto:[email-masked]>>
CC: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
件名: Re: [AVTCORE] Zaheduzzaman Sarker's Discuss on draft-ietf-payload-rtp-jpegxs-16: (with DISCUSS)

Hi,

Thanks,

Stephan

    [email-masked]<mailto:[email-masked]>

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 18 Jun 2021 15:39:28 +0000

As a follow-up, I had conversations with Mayumi and with Gary Sullivan (SC29 chair).  We are still checking if and how we can make 21122 available to the WG, and I will come back to you on this, hopefully early next week.
Stephan

From: avt <[email-masked]> on behalf of Stephan Wenger <[email-masked]>
Date: Thursday, June 17, 2021 at 12:48
To: Tim Bruylants <[email-masked]>, Zaheduzzaman Sarker <[email-masked]>, The IESG <[email-masked]>, Mayumi Koike <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [AVTCORE] Zaheduzzaman Sarker's Discuss on draft-ietf-payload-rtp-jpegxs-16: (with DISCUSS)

Hi,

Thanks,

Stephan

    [email-masked]

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 25 Jun 2021 17:46:19 +0000

All:
Mayumi came back to me with guidance.  Based on this guidance, I’m prepared to share those recent versions of the relevant parts of ISO/IEC 21122 I have access to through my credentials in the ISO system while logged in as IETF’s liaison person.  If you are an IESG member or part of the AVT community and want to review the JPEG-XS payload format, please reply to me in private, and I will send you .zip files.  I may not be able to send exactly the document cited in the draft, but something that’s technically substantially similar, fi not identical.
(As a practical matter, I think this offer goes mostly towards the IESG.  I think pretty much everyone in the AVT community who is interested in JPEG-XS is also working over in SC29/WG1 and hence has access to the relevant documents.)
Thanks,
Stephan

From: Tim Bruylants <[email-masked]>
Date: Friday, June 18, 2021 at 01:14
To: Mayumi Koike <[email-masked]>, Stephan Wenger <[email-masked]>, Zaheduzzaman Sarker <[email-masked]>, The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [AVTCORE] Zaheduzzaman Sarker's Discuss on draft-ietf-payload-rtp-jpegxs-16: (with DISCUSS)

Best regards,

Dear Stephan,

Thank you for asking.

Best regards,
Mayumi Koike

Hi,

Thanks,

Stephan

---

From: Tim Bruylants <[email-masked]>
Date: Fri, 25 Jun 2021 18:19:41 +0000

Thanks Stephan :)

This is great news.

Tim
________________________________
From: Stephan Wenger <[email-masked]>
Sent: Friday, June 25, 2021 7:46:19 PM
To: Tim Bruylants <[email-masked]>; Zaheduzzaman Sarker <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Mayumi Koike <[email-masked]>; Gary Sullivan <[email-masked]>
Subject: Re: [AVTCORE] Zaheduzzaman Sarker's Discuss on draft-ietf-payload-rtp-jpegxs-16: (with DISCUSS)

All:

Thanks,

Stephan

Best regards,

Dear Stephan,

Thank you for asking.

Best regards,
Mayumi Koike

Hi,

It is my understanding that ISO documents can be shared in a liaison relationship, which we have here.  The IETF is a cat A liaison organization to SC29.  According to the ISO Directives (2021) (https://www.iso.org/sites/directives/current/consolidated/index.xhtml#_idTextAnchor095<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iso.org_sites_directives_current_consolidated_index.xhtml-23-5FidTextAnchor095&d=DwMGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=rSHxXEekaMcCmf61vQbxo7ZBLiouREuZSSLyOcb9yqw&s=KQhOjrKRDARcnxvMzeRsO5_tvDKLmGgcLQW2w9CGB-Y&e=>), section 1.17.2, subclause Category A, "[...] Such organizations are given access to all relevant documentation [...]".

Thanks,

Stephan

    https://www.ietf.org/mailman/listinfo/avt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_avt&d=DwMGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=rSHxXEekaMcCmf61vQbxo7ZBLiouREuZSSLyOcb9yqw&s=n8cDSdb7vTSz4SRtL6UyK8lW-ZQ5rNJmrA4sMnyYQkY&e=>