Subject: Re: [AVTCORE] New Version Notification for draft-dawkins-avtcore-sdp-rtp-quic-00.txt

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 28 Jan 2022 13:34:13 -0600

Dear AVTCORE (with MMUSIC and MOQ cc:ed, but please follow up to AVTCORE),

I had been working on a draft describing SDP for RTP over QUIC, and after
the AVTCORE co-chairs said that it was appropriate to discuss RTP over QUIC
proposals in AVTCORE, I conferred with the AVTCORE and MMUSIC co-chairs
about where my draft should be discussed. As I described in the draft,

   With the concurrence of the AVTCORE and MMUSIC working group co-
   chairs, this document should be discussed in the AVTCORE working
   group, in the same venue where RTP over QUIC proposals are being
   discussed.  When proposals for RTP over SIP have stabilized in
   AVTCORE, this document will be sent to the MMUSIC working group for
   review by SDP experts, but SDP-specific comments are welcomed at any
   time.

   Readers are also invited to open issues and send pull requests with
   contributed text for this document in the GitHub repository at
   https://github.com/SpencerDawkins/sdp-rtp-quic.  The direct link to
   the list of issues is https://github.com/SpencerDawkins/sdp-rtp-quic/
   issues.

One of the reasons that I focused on the SDP early on, is that it has
helped me identify open issues that have popped up in various discussions.
I should mention that I'm especially interested in feedback on
https://www.ietf.org/archive/id/draft-dawkins-avtcore-sdp-rtp-quic-00.html#name-an-aside-on-secure-avp-prof
.

Happy reading, and I hope to discuss this further at the upcoming AVTCORE
interim meeting on 15 February..

Best,

Spencer

On Fri, Jan 28, 2022 at 10:53 AM <[email-masked]> wrote:

>
> A new version of I-D, draft-dawkins-avtcore-sdp-rtp-quic-00.txt
> has been successfully submitted by Spencer Dawkins and posted to the
> IETF repository.
>
> Name:           draft-dawkins-avtcore-sdp-rtp-quic
> Revision:       00
> Title:          SDP Offer/Answer for RTP using QUIC as Transport
> Document date:  2022-01-28
> Group:          Individual Submission
> Pages:          13
> URL:
> https://www.ietf.org/archive/id/draft-dawkins-avtcore-sdp-rtp-quic-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-dawkins-avtcore-sdp-rtp-quic/
> Html:
> https://www.ietf.org/archive/id/draft-dawkins-avtcore-sdp-rtp-quic-00.html
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-dawkins-avtcore-sdp-rtp-quic
>
>
> Abstract:
>    This document describes these new SDP "proto" attribute values:
>    "QUIC", "QUIC/RTP/SAVP", "QUIC/RTP/AVPF", and "QUIC/RTP/SAVPF", and
>    describes how SDP Offer/Answer can be used to set up an RTP
>    connection using QUIC as a transport protocol.
>
>    These proto values are necessary to allow the use of QUIC as an
>    underlying transport protocol for applications such as SIP and WebRTC
>    that commonly use SDP as a session signaling protocol to set up RTP
>    connections.
>
>
>
>
> The IETF Secretariat
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 29 Jan 2022 15:35:11 +0000

Hi Spencer,

Please remember to check whether there are any BUNDLE impacts. Section 9 of BUNDLE contains RTP considerations for BUNDLE, so I suggest to check whether there is anything that needs to be updated/modified for QUIC usage.

Regards,

Christer

________________________________
From: mmusic <[email-masked]> on behalf of Spencer Dawkins at IETF <[email-masked]>
Sent: Friday, January 28, 2022 9:34 PM
To: IETF AVTCore WG <[email-masked]>
Cc: MOQ Mailing List <[email-masked]>; mmusic WG <[email-masked]>
Subject: Re: [MMUSIC] New Version Notification for draft-dawkins-avtcore-sdp-rtp-quic-00.txt

I had been working on a draft describing SDP for RTP over QUIC, and after the AVTCORE co-chairs said that it was appropriate to discuss RTP over QUIC proposals in AVTCORE, I conferred with the AVTCORE and MMUSIC co-chairs about where my draft should be discussed. As I described in the draft,

   Readers are also invited to open issues and send pull requests with
   contributed text for this document in the GitHub repository at
   https://github.com/SpencerDawkins/sdp-rtp-quic<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-6b23c2fb2dd81c1d&q=1&e=88dc547f-b64f-4d4c-870d-b93be8a1d8d0&u=https%3A%2F%2Fgithub.com%2FSpencerDawkins%2Fsdp-rtp-quic>.  The direct link to
   the list of issues is https://github.com/SpencerDawkins/sdp-rtp-quic/<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-d9b6cc4eeb6e8227&q=1&e=88dc547f-b64f-4d4c-870d-b93be8a1d8d0&u=https%3A%2F%2Fgithub.com%2FSpencerDawkins%2Fsdp-rtp-quic%2F>
   issues.

One of the reasons that I focused on the SDP early on, is that it has helped me identify open issues that have popped up in various discussions. I should mention that I'm especially interested in feedback on https://www.ietf.org/archive/id/draft-dawkins-avtcore-sdp-rtp-quic-00.html#name-an-aside-on-secure-avp-prof.

Happy reading, and I hope to discuss this further at the upcoming AVTCORE interim meeting on 15 February..

Best,

Spencer

On Fri, Jan 28, 2022 at 10:53 AM <[email-masked]<mailto:[email-masked]>> wrote:

Name:           draft-dawkins-avtcore-sdp-rtp-quic
Revision:       00
Title:          SDP Offer/Answer for RTP using QUIC as Transport
Document date:  2022-01-28
Group:          Individual Submission
Pages:          13
URL:            https://www.ietf.org/archive/id/draft-dawkins-avtcore-sdp-rtp-quic-00.txt
Status:         https://datatracker.ietf.org/doc/draft-dawkins-avtcore-sdp-rtp-quic/
Html:           https://www.ietf.org/archive/id/draft-dawkins-avtcore-sdp-rtp-quic-00.html
Htmlized:       https://datatracker.ietf.org/doc/html/draft-dawkins-avtcore-sdp-rtp-quic

Abstract:

The IETF Secretariat

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sat, 29 Jan 2022 18:30:41 -0600

H, Christer,

(following up on AVTCORE)

On Sat, Jan 29, 2022 at 9:35 AM Christer Holmberg <
[email-masked]> wrote:

> Hi Spencer,
>
> Please remember to check whether there are any BUNDLE impacts. Section 9
> of BUNDLE contains RTP considerations for BUNDLE, so I suggest to check
> whether there is anything that needs to be updated/modified for QUIC usage.
>

Thank you! I'll create an issue for this in Github so we don't forget to
check.

Best,

Spencer

> Regards,
>
> Christer
>
>
> ------------------------------
> *From:* mmusic <[email-masked]> on behalf of Spencer Dawkins at
> IETF <[email-masked]>
> *Sent:* Friday, January 28, 2022 9:34 PM
> *To:* IETF AVTCore WG <[email-masked]>
> *Cc:* MOQ Mailing List <[email-masked]>; mmusic WG <[email-masked]>
> *Subject:* Re: [MMUSIC] New Version Notification for
> draft-dawkins-avtcore-sdp-rtp-quic-00.txt
>
>    https://github.com/SpencerDawkins/sdp-rtp-quic
> <https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-6b23c2fb2dd81c1d&q=1&e=88dc547f-b64f-4d4c-870d-b93be8a1d8d0&u=https%3A%2F%2Fgithub.com%2FSpencerDawkins%2Fsdp-rtp-quic>.
> The direct link to
> <https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-d9b6cc4eeb6e8227&q=1&e=88dc547f-b64f-4d4c-870d-b93be8a1d8d0&u=https%3A%2F%2Fgithub.com%2FSpencerDawkins%2Fsdp-rtp-quic%2F>
>    issues.
>
>