Subject: [babel] What sub-TLV number to use for source-specific?

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 24 Jan 2018 19:55:53 +0100

After babeld 1.9.0 is out (hopefully this week or next), I'd like to merge
Matthieu's code for the new source-specific extension into babeld master.

Now:

  - draft-ietf-babel-source-specific-02 suggests using sub-TLV number 128,
    which is the first number in the mandatory range;
  - Matthieu's code uses sub-TLV number 250, which, according to
    rfc6126bis Section 5, is reserved for experimental use.

What shall I do in babeld master?  I guess I could either request that
IANA allocate number 128 for draft-ietf-babel-source-specific-02, or use
an experimental sub-TLV number, or I could simply ignore the IETF and
squat number 128.

Advice?

-- Juliusz

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 24 Jan 2018 19:17:21 +0000

> What shall I do in babeld master?  I guess I could either request that IANA
> allocate number 128 for draft-ietf-babel-source-specific-02, or use an
> experimental sub-TLV number, or I could simply ignore the IETF and squat
> number 128.

I would suggest requesting IANA allocate.
But in looking at https://www.iana.org/assignments/babel/babel.xhtml, I'm curious...
Why are we leaping over 4 through 127? The unassigned (which I would interpret as "reserved-for-mandatory") range is 4-223 according to the registry page. 4 would be the next logical value.
While asking IANA to do things to the babel registry, does it make sense to ask them to get rid of the current TLV allocations for draft-boutier-babel-source-specific?
13 Source-specific Update [draft-boutier-babel-source-specific] 
14 Source-specific Request [draft-boutier-babel-source-specific] 
15 Source-specific Seqno Request [draft-boutier-babel-source-specific]

If I can be of any assistance in dealing with IANA, please let me know. I've been getting pretty good at this IANA registry stuff.
Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 24 Jan 2018 20:58:51 +0100

> I would suggest requesting IANA allocate.

Noted.  I'll wait for Donald to comment.

> Why are we leaping over 4 through 127? The unassigned (which I would
> interpret as "reserved-for-mandatory") range is 4-223 according to the
> registry page. 4 would be the next logical value.

The IANA registry follows RFC 6126.  6126bis splits the range into
non-mandatory (0-127) and mandatory (128-255).  See Section 5:

    https://tools.ietf.org/html/draft-ietf-babel-rfc6126bis-04#section-5

One thing, by the way -- should the registry be split into two registries?

> 15 Source-specific Seqno Request [draft-boutier-babel-source-specific]

We could either leave them as is, mark them as reserved for backwards
compatibility, or delete them.  At any rate, we shouldn't be reusing them
for at least a year or so after we deploy the new version of source-specific.

-- Juliusz

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 26 Jan 2018 23:26:51 -0500

Hi Juliusz,

Given that the Babel Sub-TLV Types registry is Specification Required and
you are a designated expert, I think you could just send IANA a request
pointing out that draft-boutier-babel-source-specific has been replaced by
draft-ietf-babel-source-specific which allocates sub-TLV type 128. Probably
best practice would be to mark types 13-15 as Reserved due to previous
allocation.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Wed, Jan 24, 2018 at 2:58 PM, Juliusz Chroboczek <[email-masked]> wrote:

> > While asking IANA to do things to the babel registry, does it make sense
> to ask them to get rid of the current TLV allocations for
> draft-boutier-babel-source-specific?
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel
>

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 27 Jan 2018 12:25:36 +0100

> Given that the Babel Sub-TLV Types registry is Specification Required and you
> are a designated expert, I think you could just send IANA a request pointing
> out that draft-boutier-babel-source-specific has been replaced by
> draft-ietf-babel-source-specific which allocates sub-TLV type 128.

Done.

> Probably best practice would be to mark types 13-15 as Reserved due to
> previous allocation.

Not done, one thing at a time.

Donald, Barbara, Russ, everyone -- any opinion on whether the registry
should be split into non-mandatory/mandatory registries?

-- Juliusz

---

From: Donald Eastlake <[email-masked]>
Date: Sat, 27 Jan 2018 15:08:39 -0500

> Not done, one thing at a time.

OK. No problem leaving the entries for 13-15 as they are for a while.

> should be split into non-mandatory/mandatory registries?

I guess I'm inclined to leave it as one sub-TLV Type registry with
appropriate annotations. The alternative is a "Non-mandatory sub-TLV
Type Registry" and a "Mandatory sub-TLV Type Registry" each of which
is a table of 7-bit values, or something like that, which seems
clunkier.

Thanks,
Donald

---

From: David Schinazi <[email-masked]>
Date: Mon, 29 Jan 2018 10:11:31 -0800

To add a datapoint regarding splitting the IANA registry, IKEv2 notify codes
are defined as errors for 0-16383 and status for 16384-65535 and they have separate IANA registries.

https://tools.ietf.org/html/rfc7296#section-3.10.1 <https://tools.ietf.org/html/rfc7296#section-3.10.1>
https://www.iana.org/assignments/ikev2-parameters/ikev2-parameters.xhtml#ikev2-parameters-14 <https://www.iana.org/assignments/ikev2-parameters/ikev2-parameters.xhtml#ikev2-parameters-14>

I would personally recommend doing the same for Babel but I have no strong feelings on this.

Thanks,
David Schinazi

> On Jan 27, 2018, at 12:08, Donald Eastlake <[email-masked]> wrote:
>