Subject: [babel] info-model: question on "k out of j"

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 17 Jul 2019 14:50:40 +0000

Currently, when reporting what metric calculation algorithms are supported, the info model supports an enumeration of "k-out-of-j". I notice that the only "k out of j" algorithm that really seems to be used is "2 out of 3". Should we replace the generic "k-out-of-j" with the more specific "2-out-of-3"? And if other k out of j algorithms are supported, they can be specifically called out with whatever values of k and j they use? Or is it really the case that if any values of k and j are supported, then it would be easy to use whatever values of k and j make sense in some particular case? Note that the proposed link type properties definitions call out "2 out of 3" instead of the generic "k out of j". I think it would be good to be consistent in which one we use.
Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sun, 21 Jul 2019 22:03:29 +0200

> Currently, when reporting what metric calculation algorithms are
> supported, the info model supports an enumeration of
> "k-out-of-j". I notice that the only "k out of j" algorithm that really
> seems to be used is "2 out of 3". Should we replace the generic
> "k-out-of-j" with the more specific "2-out-of-3"?

Yes.