Subject: [babel] I-D Action: draft-ietf-babel-yang-model-12.txt

From: [email-masked]
Date: Wed, 15 Sep 2021 16:22:26 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Babel routing protocol WG of the IETF.

        Title           : YANG Data Model for Babel
        Authors         : Mahesh Jethanandani
                          Barbara Stark
	Filename        : draft-ietf-babel-yang-model-12.txt
	Pages           : 44
	Date            : 2021-09-15

Abstract:
   This document defines a data model for the Babel routing protocol.
   The data model is defined using the YANG data modeling language.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-babel-yang-model/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-babel-yang-model-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-babel-yang-model-12

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 15 Sep 2021 19:37:23 -0700

This version of the draft addresses the discussion around the usage of 0 as NULL in the YANG model. With this version, when a model needs to represent a NULL value, the model uses a union with an enumeration called ’null’ to represent the NULL value.

Cheers.

> On Sep 15, 2021, at 4:22 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel

Mahesh Jethanandani
[email-masked]