Subject: RE: [BXXPwg] A couple of questions

From: Kris Magnusson <[email-masked]>
Date: Tue, 16 Jan 2001 14:33:07 -0800

You might also check with Jay Kint ([email-masked]) about the Python
work he has been doing. It might make sense for you guys to put your heads
together.

........... kris

-----Original Message-----
From: Gabe Wachob [mailto:[email-masked]]
Sent: Tuesday, January 16, 2001 2:13 PM
To: Manros, Carl-Uno B; [email-masked]
Subject: Re: [BXXPwg] A couple of questions

On Tue, Jan 16, 2001 at 01:56:13PM -0800, Manros, Carl-Uno B wrote:
> Hi,
> 
> I followed some the initial work on BEEP, but later got busy with too many
> other things.
> 
> I am now trying to catch up and have just eyed through the latest drafts
> dated January 4 and as result I have a few comments and questions:
> 
> 1) The documents start looking pretty good and I assume that you are soon
> getting ready to submit them to the IESG. Is this a correct understanding
of
> where you are?
> 
> 2) In was told earlier on that actual code was being written in parallel
to
> the specs. Is any of that code available as open source or are there any
> plans to make that happen?

The PyBXXP (Python implementation) is open source and is available at
bxxp.org.
If you are a python person, I would appreciate any help you can give.

> 3) I can't find anything mentioned about a default port or URL scheme to
go
> with BEEP. Is that by design and would port numbers and URL schemes be
> defined by the applications that sit on top of BEEP?

It would seem to me that a bxxp well-known port number should be defined,
unless 
there is a requirement be  passed "up" to all applications on top of beep
that 
a port must be part of the URL for the bxxp peer. I don't think requiring
a port number is a good thing.  

Since (as I understand it), specific channel numbers are *not* assigned to 
specific applications (unlike port numbers), that the only thing an
application
would need to specify is an endpoint for a bxxp peer (endpoint being ip
address
and port).  But this is part of the TCP Mapping, I'm guessing, which I
haven't 
looked at in detail very recently.

To restate:
In the modal case, an app that works on top of BXXP only requires a IP
address 
(in the TCP Mapping) to specify a peer. Authentication and TLS may have
further 
naming requirements for specifying the peer endpoint.

Is this right?

	-Gabe 

> 
> Thankful for any clarifications on these questions,
> 
> Carl-Uno
> 
> Carl-Uno Manros
> Manager, Print Services
> Xerox Architecture Center - Xerox Corporation
> 701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
> Phone +1-310-333 8273, Fax +1-310-333 5514
> Email: [email-masked] 
> 
> 
> _______________________________________________
> BXXPwg mailing list
> [email-masked]
> http://lists.invisible.net/mailman/listinfo/bxxpwg

_______________________________________________
BXXPwg mailing list
[email-masked]
http://lists.invisible.net/mailman/listinfo/bxxpwg

_______________________________________________
BXXPwg mailing list
[email-masked]
http://lists.invisible.net/mailman/listinfo/bxxpwg

---

From: "Azim, Ozakil" <[email-masked]>
Date: Tue, 16 Jan 2001 18:10:23 -0500

Hi,

Just wanted to check if anyone is working on a C based implementation for BXXP.

I didn't find any reference to that on bxxp.org site.

Thanks,

Azim

--
Azim, Ozakil - [email-masked]
Product Engineering
http://www.netforensics.com