Subject: [BXXPwg] Profile or Profiles? Is it too late for edits?

From: "Bob Wyman" <[email-masked]>
Date: Thu, 25 Jan 2001 10:29:02 -0800

Is it too late for edits?

Section 2 of draft-ietf-beep-framework-11.txt says:
"When a session is established, each BEEP peer advertises the profile it supports."
Shouldn't this sentence have referred to "profiles" (i.e. plural?). 

Also, it would appear from 2.3.1.1 that peers only advertise the profiles that they support while acting in a server role. This distinction is not made in this text. Given these two observations, I would suggest that the sentence in Section 2 would read better as:
"When a session is established, each BEEP peer advertises the profile[s] it supports [when acting in a server role]."

Section 2.3 says:
"Channel management allows each BEEP peer to advertise the profiles that it supports..."
This sentence may have a problem similar to the one in Section 2., although it isn't stating a requirement -- only reflecting on the purposes of channel management. It might read better as:
"Channel management allows each BEEP peer to advertise the profiles that it supports [when acting in a server role]...."

Also, I'm curious, other than the "TASK=0" of DECnet, I can't think of any other protocol that works the way BEEP does in that the protocol or profile is specified after the connection is made. Please forgive me if I'm missing something obvious. Can anyone provide other examples?

        bob wyman

---

From: "Marshall T. Rose" <[email-masked]>
Date: Sun, 28 Jan 2001 23:04:31 -0800

> Is it too late for edits?

probably. we've already had two working group last calls and an extended
iesg last call. other than the punctuation typo you mention, i'm disinclined
to argue with the rfc editor to hold the presses and get everyone to agree
to the changes...

/mtr
  ----- Original Message -----
  From: Bob Wyman
  To: [email-masked]
  Sent: Thursday, January 25, 2001 10:29
  Subject: [BXXPwg] Profile or Profiles? Is it too late for edits?

  Section 2 of draft-ietf-beep-framework-11.txt says:
  "When a session is established, each BEEP peer advertises the profile it
supports."
  Shouldn't this sentence have referred to "profiles" (i.e. plural?).

  Also, it would appear from 2.3.1.1 that peers only advertise the profiles
that they support while acting in a server role. This distinction is not
made in this text. Given these two observations, I would suggest that the
sentence in Section 2 would read better as:
  "When a session is established, each BEEP peer advertises the profile[s]
it supports [when acting in a server role]."

  Section 2.3 says:
  "Channel management allows each BEEP peer to advertise the profiles that
it supports..."
  This sentence may have a problem similar to the one in Section 2.,
although it isn't stating a requirement -- only reflecting on the purposes
of channel management. It might read better as:
  "Channel management allows each BEEP peer to advertise the profiles that
it supports [when acting in a server role]...."

  Also, I'm curious, other than the "TASK=0" of DECnet, I can't think of any
other protocol that works the way BEEP does in that the protocol or profile
is specified after the connection is made. Please forgive me if I'm missing
something obvious. Can anyone provide other examples?

          bob wyman