Subject: [BXXPwg] Re: TUNNEL status?

From: "john d. beatty" <[email-masked]>
Date: Thu, 26 Jul 2001 10:05:22 -0700

After having offline discussions with Darren, my conclusion is that we
should probably not include the "session brokering" functionality in the
TUNNEL profile for the following reasons:

 - I was unable to make a persuasive argument (even to myself) that this was
the right approach.
 - The session brokering functionality is only necessary in a small number
of cases. In general, asynch message relaying can be used to communicate to
peers lacking reachability due to firewalls and NATs.
 - It opens up a new set of security concerns.

There are still cases where I would like to have direct-as-possible sessions
created in the single and double NAT/firewall cases, but I believe there are
viable alternatives and that this functionality would convolute and overload
the TUNNEL profile.

john

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Thursday, July 26, 2001 9:42 AM
Subject: TUNNEL status?

> Hey ya'll,
>
> So, what was the resolution on this issue?  Are we extending the TUNNEL
> profile and, if so, where is the updated ID?  We're close to releasing
> IDXP-03 and putting it into WG Last Call.  We need to have the TUNNEL ID
> ready for last call at the same time, seeing as IDXP references TUNNEL and
> my understanding is that RFCs cannot reference IDs.
>
> Cheers,
> Ben
>
> PS - Sorry about the last message containing only the quoted reply to
> Marshall's email. I accidentally sent it out before it was ready!
>
> On Mon, 16 Jul 2001, Marshall T. Rose wrote:
>
> > hi. i suggest that the two of you have a private conversation as to what
> > minimal sets of mods to the tunnel profile are necessary to meet john's
> > requirements, and then you can send a note to the idwg mailing list
> > explaining what you want to do.
> >
> > time is of the essence here, that wg would like to be closing up shop
> > soon...
> >
> > thanks,
> >
> > /mtr
> >
>
> > Ben Feinstein
> >   Software Development Engineer, R & D
> >   W: 404.460.5193 F: 404.460.5001 M: 678.772.4126
> >   3003 Summit Blvd., Suite 1500, Atlanta, GA 30319 www.guardent.com
> > _____________________________________________________
> > G U A R D E N T
> >   Enterprise Security and Privacy Programs
>

_______________________________________________
BXXPwg mailing list
[email-masked]
http://lists.invisible.net/mailman/listinfo/bxxpwg

---

From: [email-masked]
Date: Thu, 26 Jul 2001 12:42:37 -0400

Hey ya'll,

Cheers,
Ben