Subject: [BEEPwg] Beep mapping to TCP

From: Andrew Davison <[email-masked]>
Date: Sun, 24 Mar 2002 19:46:39 +1000

i can understand the use of SEQ frames where a sender wants to write 
large amounts of data and/or pipeline many messages, but in a simple 1 
request to 1 response scenario the response gives an implicit ack, 
surely, so no SEQs would be required while that situation lasts?

_______________________________________________
BEEPwg mailing list
[email-masked]
http://lists.beepcore.org/mailman/listinfo/beepwg

---

From: Marshall Rose <[email-masked]>
Date: Sun, 24 Mar 2002 08:21:02 -0800

> surely, so no SEQs would be required while that situation lasts?

in order for this to work, you'd have to be able to know that there would never be another channel opened on the session except for the one you have now. beep doesn't let you negotiate it, so this is unknowable.

if you want to implement beep with only one channel, that's fine. just have your protocol engine send a SEQ everytime it receives a frame.

/mtr