Subject: Re: [BEHAVE] Comments on draft-boucadair-dhc-port-range-01.txt

From: Dave Thaler <[email-masked]>
Date: Thu, 6 Nov 2008 10:12:39 -0800

One more...

4) I didn't see a discussion of how/whether the DHCP server knows whether the DHCP client supports this option.
Since sending the option actually requires allocation of a scarce resource, does the client need to indicate that it actually understands this option or is the DHCP server supposed to allocate port ranges even to a client that is going to ignore it and treat the address it gets as if it can use all ports?  Also, which DHCP messages is it legal for this option to appear in?  OFFER?  INFORM?  REQUEST?

From: Dave Thaler
Sent: Thursday, November 06, 2008 10:06 AM
To: [email-masked]'
Cc: [email-masked]; 'Stuart Cheshire'
Subject: Comments on draft-boucadair-dhc-port-range-01.txt

In addition to the comments I sent on draft-boucadair-port-range-00.txt, here's some that apply specifically to this draft.

1)      The concept of asking for one or more ports to be allocated seems to overlap to a large extent with NAT-PMP in draft-cheshire-nat-pmp-03 (and work on UnP IGD v2 for that matter).  The main difference seems to be that this draft asks for a block, whereas NAT-PNP asks for one.

2)      The use of non-contiguous masks rather than a set of ranges seems cumbersome.  Non-contiguous subnet masks were originally possible but then abandoned because no one could really understand them.  This seems to repeat that same problem.  In addition, I'll point out that masks constrain you to a power-of-two, whereas ranges allow arbitrary sizes.

3)      Sections 3.1 and 3.2 imply that the DHCP client device (CPE) is responsible for informing the service provider's router what port range the service provider's DHCP server allocated.  There's a trust problem there... why would a router trust a customer to provide it what amounts to routing information?  This isn't what people do today.  Instead the DHCP server/relay can talk to the router as needed, since they're all under the control of the same provider.  This is generally how prefix delegation works.  It's also consistent with the model where the DHCP server updates a DNS server (rather than allowing clients to use dynamic update).

-Dave Thaler
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: <[email-masked]>
Date: Mon, 10 Nov 2008 10:20:58 +0100

Re-
 
See inline
 
Cheers
Med

  _____  

De : [email-masked] [mailto:[email-masked]] De la part de Dave Thaler
Envoyé : jeudi 6 novembre 2008 19:13
À : BOUCADAIR Mohamed RD-CORE-CAE
Cc : Stuart Cheshire; [email-masked]
Objet : Re: [BEHAVE] Comments on draft-boucadair-dhc-port-range-01.txt

One more...

[Med] You are right. The text will be updated to describe the DHCP client behaviour.

From: Dave Thaler 

-Dave Thaler