Subject: Re: [BEHAVE] NAT66 - lets bring back FEC0:: ( was Lack of need for66nat)

From: [email-masked]
Date: Fri, 28 Nov 2008 16:45:38 +0000

Keith - I agree, the *goal* is to not use much NAT (personally, I hope to never use/need it :) ) ... But if the market thinks they need it (for now?) then we can define it and give sane guidance ... 

Also, negative on the overlapping space - atleast in general, 48bits of randomness'ish should keep things sane - yes?

/TJ
------Original Message------
From: Keith Moore
To: Rémi Després
Cc: [email-masked]
Cc: Dave Thaler
Cc: Behave Mailing List
Cc: Eric Klein
Cc: TJ Evans
Subject: Re: [BEHAVE] NAT66 - lets bring back FEC0:: ( was Lack	of	need	for66nat)
Sent: Nov 28, 2008 11:03

Rémi Després wrote:
> Keith Moore  -  le (m/j/a) 11/28/08 3:33 PM:
>>> Using Fc00::/8 in IPv6 like 10.0.0.0/8 is used in IPv4 would make a lot
>>> of sense to me.
>>>     
>>
>> So what you want to do is to make IPv6 as dysfunctional as IPv4?
>>   
> Sorry I appreciate moderately this comment.
> 
> Like you I suppose, I work to help the community to deploy IPv6 gracefully.
> (If most of native IPv6 users today are at Free.fr (Google statistics),
> this is because my understanding of issues led me to propose the
> innovative 6rd approach to this ISP, and because its CTO, Rani Assaf
> adopted it enthusiastically.)
> 
> Your technical and marketing comments are most welcome, but not this
> kind of statement without any substance.

I don't see a huge benefit in deploying IPv6 if it's going to work as
badly as IPv4 does today.

IPv4 is a huge mess because of overlapping address space and NATs.  It
is hard to convince people to do without NATs in IPv6 because from their
IPv4 experience they think they need them, and we have not (yet)
provided better solutions for everything that people use NATs for today.
 Even if people use NATs with IPv6 in the near term, IETF's goal should
be to provide better solutions than NAT, so that operators can turn NAT
off in the future without harming their networks.

What you are proposing is exactly the opposite.  It is a return to
overlapping address spaces, and NAT lockin.

Keith

Sent from my Verizon Wireless BlackBerry
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Keith Moore <[email-masked]>
Date: Fri, 28 Nov 2008 13:34:17 -0500

[email-masked] wrote:
> Keith - I agree, the *goal* is to not use much NAT (personally, I
> hope to never use/need it :) ) ... But if the market thinks they need
> it (for now?) then we can define it and give sane guidance ...

I'm okay with that as a tentative strategy...but I'm not okay with
encouraging overlapping addresses in v6.  the whole point is to define
v6 and NAT66 in such a way that (a) address translation is really not
needed for much (if anything) and (b) operators can easily turn it off
-- which they cannot do if they've invested in RFC 1918 - like addressing.

> Also, negative on the overlapping space - atleast in general, 48bits of randomness'ish should keep things sane - yes?

no.  partially because hosts don't have to use stateless address
autoconfig (and not doing so would increase the risk of collisions),
partly because it really is important that hosts and apps be able to
tell whether a peer is on the same network, and partly because I really
don't believe the /64 boundary between host and net number will stay
there for a long time.

Keith