Subject: Re: [BEHAVE] BitTorrent with shared IP addresses

From: <[email-masked]>
Date: Mon, 3 Nov 2008 13:38:41 +0100

Ok, I'm going to writte an I-D on this BitTorrent behavior.

Pierre 

-----Message d'origine-----
De : Dan Wing [mailto:[email-masked]] 
Envoyé : vendredi 31 octobre 2008 17:56
À : LEVIS Pierre RD-CORE-CAE
Cc : [email-masked]
Objet : RE: BitTorrent with shared IP addresses

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]
> Sent: Friday, October 31, 2008 6:12 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: BitTorrent with shared IP addresses
> 
> The second can download the file when the first has finished and when 
> it has re-launched the bittorent download.
> After further investigation I saw in the BitTorrent seed (BitTorrent 
> 6.0.3)in Options/Preferences/Advanced, the parameter:
> bt.allow_same_ip
> When this parameter is set to false the behavior is as mentioned.
> When this parameter is set to true the two PCs sharing the same IP 
> address can simultaneously download the file.

Thanks for your investigation on this.  Would you be willing to write up an I-D describing this application behavior?  I expect we will find other applications that expect each 'user' has one IP address - which will no longer be true with IPv4 address sharing.  This affects NAT44 (CGN), port borrowing, DS-Lite, and IPv6->IPv4 translation.

I touched on this problem a little bit in http://tools.ietf.org/html/draft-wing-nat-pt-replacement-comparison-02#section
-9.1 but without specifics on BitTorrent, of course.

-d

> Pierre
> 
> -----Message d'origine-----
> De : Dan Wing [mailto:[email-masked]] Envoyé : mercredi 29 octobre 
> 2008 19:22 À : LEVIS Pierre RD-CORE-CAE Cc : [email-masked] Objet : 
> RE: BitTorrent with shared IP addresses
> 
>  
> 
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]]
> > Sent: Wednesday, October 29, 2008 7:52 AM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: RE: BitTorrent with shared IP addresses [was RE: 
> > [BEHAVE] TR: I-D Action:draft-boucadair-port-range-00.txt]
> > 
> > Dan,
> > 
> > Yes, the test you carried out work also in our lab (I have
> tested the
> > same torrent download as yours on two different PCs sharing
> the same
> > IP address).
> > 
> > In fact, the result we have mentionned in our draft is from another 
> > test which is much more constrained:
> > 
> > "For one P2P (Peer-to-Peer) application tested, we found that two
> >    peers each behind a CPE sharing the same public address cannot
> >    download a SAME file from a source peer."
> > 
> > By "SAME file from a source peer" we mean a single file on a single 
> > location.
> > Then, the two PCs with the same IP address tried to
> download the file
> > from the very same location, by BitTorrent.
> >
> > So, of course we cannot say that it does not work at all,
> we can only
> > say that it does not work in these very particular conditions.
> 
> Ah, okay.  So the failure occurs when a file that has only one seed in 
> the BitTorrent swarm, like this:
> 
> 
>              PC-A--+
>                     \
>                      NAT--seed
>                     /
>              PC-B--+
> 
> 
> And PC-A is able to download the file, but PC-B can't download the 
> file.
> 
> What happens after PC-A completes downloading the file -- can PC-B 
> start downloading it immediately after PC-A finishes?
> Perhaps after the next tracker update, can PC-B start downloading 
> it?   Or does your testing show that PC-B is *never* able to 
> download the file because PC-A already downloaded it from the seed?
> 
> -d
> 
> 

_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: "Saikat Guha" <[email-masked]>
Date: Fri, 7 Nov 2008 20:14:58 -0500

On Fri, Oct 31, 2008 at 11:56 AM, Dan Wing <[email-masked]> wrote:
>> After further investigation I saw in the BitTorrent seed
>> (BitTorrent 6.0.3)in Options/Preferences/Advanced, the parameter:
>> bt.allow_same_ip
>
> up an I-D describing this application behavior?  I expect we will find
> other applications that expect each 'user' has one IP address - which
> will no longer be true with IPv4 address sharing.

IIRC, this was a result of some BT applications being susceptible to
Sybil attacks where the attacker peer would open multiple connections
to the victim peer; when the victim peer performs random unchoke
(where it picks a random peer and sends it a block of data hoping the
peer would reciprocate), it would be more likely to pick the attacker,
and the attacker would therefore get more bandwidth from the peer
without himself uploading to the victim peer.

Solving a Sybil attack in the general case where the attacker can mint
new IP addresses (e.g. the RIAA) is hard. But some BT clients opted to
pick the low hanging fruit by disallowing multiple connections from a
single IP address.

Basically, I believe this behavior is not due to the assumption that
each IP address is a single user, but rather due to the assumption
that currently, there are few users behind the same IP address and so
such a technique is effective in stemming Sybil attacks today.

My 2c.
-- 
Saikat

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 7 Nov 2008 17:41:53 -0800

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Saikat Guha
> Sent: Friday, November 07, 2008 5:15 PM
> To: Dan Wing
> Cc: [email-masked]; [email-masked]
> Subject: Re: [BEHAVE] BitTorrent with shared IP addresses
> 

Thanks!
-d