Subject: Re: [BEHAVE] Amount of fragmentation resulting from translation

From: Iljitsch van Beijnum <[email-masked]>
Date: Sun, 1 Nov 2009 13:07:23 +0100

On 31 okt 2009, at 21:00, Brian E Carpenter wrote:

>> I've been looking at IPv6 in BitTorrent a bit, and nearly all peers
>> participating in BitTorrent over IPv6 use 6to4. Obviously there  
>> will be
>> little overlap between 6to4 users and NAT64 users...

> Actually draft-defeche shows that Teredo is twice as important as  
> 6to4,
> but yes, most of the 1280s come from automatic tunnels.

Another interesting observation: of all of those 6to4 peers I saw,  
pretty much none successfully accepted incoming TCP sessions.

> But I don't get
> your argument: if the PMTU is limited to 1280 anywhere in the IPv6  
> domain,
> it's a problem, for some of the deployment scenarios for
> draft-ietf-behave-v6v4-xlate.

It's not really a problem as long as you make sure the PMTUD works.

However, if such small MTUs are common (and I think they won't be  
because typical NAT64 deployments will happen with native IPv6 where  
there is no need to have a < 1500 MTU) then it makes sense to adjust  
the MSS option so TCP traffic doesn't have to hit PMTUD all the time.

>> I'll see if I can dig up some info from people visiting my websites  
>> over
>> IPv6.

> Yes, that would be valuable.

My websites (and mail server) aren't THAT popular and neither is IPv6,  
so in the past 24 hours I only caught this:

2001:xxx > 2001:1af8:2:5::2.25: <mss 1440,sackOK,timestamp 427258783 0>
2001:xxx > 2001:1af8:2:5::2.80: <mss 8940,nop,wscale  
1,nop,nop,timestamp 616253582 0,sackOK,eol>
2001:xxx > 2001:1af8:2:5::2.80: <mss 1220,nop,wscale 2,nop,nop,sackOK>

So average MTU = 3927.  :-)

I'll let it run for a week or so and after that also see in how many  
cases the actual path MTU is smaller than the MTU advertised in the  
MSS option.

---

From: Xing Li <[email-masked]>
Date: Mon, 02 Nov 2009 22:10:40 +0800

marcelo bagnulo braun 写道:
> Stig Venaas escribió:
>>
>> So if IPv4 DF is not set, better not do IPv6 PMTUD. Just assume PMTU
>> 1280.
>>
>> If IPv4 DF is set, then you can do PMTUD end to end, which I think is
>> fine.
>>
>
> This is what the current stateless does.
> I am reading that people still support this option, so unless we have 
> strong oposition, i guess we should go this path

So, we will not change the stateless draft on this issue.

regards,

xing

>
> Regards, marcelo
>
>
>> Stig
>> _______________________________________________
>> Behave mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/behave
>>
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>
>