Subject: Re: [BEHAVE] comments on draft-wing-behave-learn-prefix-04

From: Dave Thaler <[email-masked]>
Date: Wed, 18 Nov 2009 01:39:39 +0000

> -----Original Message-----
> From: Xu Xiaohu [mailto:[email-masked]]
> Sent: Tuesday, November 17, 2009 5:11 PM
> To: Dave Thaler; 'Dan Wing'
> Cc: [email-masked]
> Subject: re: [BEHAVE] comments on draft-wing-behave-learn-prefix-04
> 
> > -----邮件原件-----
> > 发件人: Dave Thaler [mailto:[email-masked]]
> > 发送时间: 2009年11月18日 4:14
> > 收件人: Dan Wing; 'xuxiaohu 41208'
> > 抄送: [email-masked]
> > 主题: RE: [BEHAVE] comments on draft-wing-behave-learn-prefix-04
> >
> > > > As for the DHCP mechanism, it works well. However, if the
> > > > IPv6 site network operator chooses RA for IPv6 address
> > > > auto-configuration, is it reasonable to require him to enable
> DHCP
> > > > just for a single purpose of obtaining prefix64.
> >
> > DHCP is used for obtaining any other
> > information besides the address... DNS information, prefix64,
> anything
> > else for which the router isn't authoritative.
> > So there isn't a "single purpose" per se, it's for all other
> purposes.
> > I can't imagine a site network operator not having other information
> > (like DNS information) to configure.
> 
> Hi Dave,
> 
> Thanks for your response.
> 
> Since RFC5006 has already specified an IPv6 Router Advertisement Option
> for
> DNS Configuration, I wonder whether some router/host OS venders have
> implemented it.

DHCP is the standard.  We (Windows) currently have no plans to support
RFC 5006 which is only experimental.  I would hope ISPs would want to
use standards rather than just conduct experiments, although some 
probably view all of IPv6 as an experiment :)

-Dave

---

From: Stig Venaas <[email-masked]>
Date: Thu, 19 Nov 2009 14:58:32 -0800

Dave Thaler wrote:
[...]
> probably view all of IPv6 as an experiment :)

Maybe biggest issue is that there is no standard API for the application
to obtain this data (whether DHCP or RA). DHCP client needs to know to
request the option, and if it gets an option back, how to pass it to the
application?. For RAs, the RA option must also in some way be passed to
the application.

I think there is some API for Windows where somehow apps can get certain
DHCP options via the DHCP client. I've been wishing for such a general
API for some time... On many platforms, the only communication seems to
be the DHCP client updating configuration files...

Stig

> -Dave
> 
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave