Subject: Re: [BEHAVE] Reason(s) for Modified EUI-64 format to apply to ALLnon-0::/3 IPv6 addresses ?

From: Xu Xiaohu <[email-masked]>
Date: Thu, 24 Dec 2009 14:36:48 +0800

> -----邮件原件-----
> 发件人: Christian Huitema [mailto:[email-masked]]
> 发送时间: 2009年12月24日 13:29
> 收件人: Xu Xiaohu; 'Dan Wing'; 'marcelo bagnulo braun'
> 抄送: [email-masked]
> 主题: RE: [BEHAVE] Reason(s) for Modified EUI-64 format to apply to
> ALLnon-0::/3 IPv6 addresses ?
> 
> >> It seems that you are trying really hard to make sure that addresses
> constructed
> >> by translation can be easily distinguished from regular IPv6 addresses.
But
> >> why is that such a big issue? At worst, it means that some connection
will
> be
> >> a little bit slower than normally expected. This happens all the time
in
> >> multihoming scenario, without translation.
> >
> > Irrelated to whether slower or faster. The major purpose is to avoid
ADDRESS
> > FAMILY translation if possible.
> 
> The WKP allows for easy distinction between translated and native
addresses,
> thus avoiding address family translation.

Can the WKP be used in the IPv6 internet to IPv4 network scenario?

> You are actually asking for something
> else, a solution to run multiple translators with multiple prefixes. 

Besides being a solution to run multiple translators with multiple prefixes,
it can also be used in the IPv6 internet to IPv4 network scenario where the
communication initiator (dual-stack host) wants to distinguish the synthetic
AAAA of the IPv4 correspondent from native IPv6 addresses.

Xiaohu

> We studied
> that, and note that such deployments create tensions between multiple
> requirements. Load balancing between multiple NAT is easier to achieve
with
> multiple prefixes, one per NAT, while references are better handled with a
> single prefix, unique for the whole Internet. Multiple prefix also are
> difficult to reconcile with P2P applications using STUN.
> 
> I would rather spend more efforts in developing coordinated translators
that
> use the same prefix. That will get us the best of both worlds.
> 
> -- Christian Huitema
> 
>

---

From: Xu Xiaohu <[email-masked]>
Date: Thu, 24 Dec 2009 18:03:17 +0800

But
will
in
ADDRESS
addresses,
> thus avoiding address family translation. You are actually asking for
something
> else, a solution to run multiple translators with multiple prefixes. We
studied
with
that
> use the same prefix. That will get us the best of both worlds.

                    +-------------+
                    |             |
  +------------+    |    H2       |
  |        +---+--+ |             |    +----------------+
  |        |NAT64a+-+ IPv4 ISP#1  +----+                |
  | H1     +---+--+ +-------------+    |                |
  |        +---+--+ +-------------+    | IPv4 Internet  |
  |        |NAT64b+-+    H3       +----+                |
  |IPv6 Site---+--+ |             |    +----------------+
  +------------+    |             |
                    | IPv4 ISP#2  |
                    +-------------+

In the above scenario, NAT64a is configure with prefix64-a, while NAT64b is
configured with prefix64-b. If H1 wants to initiate a communication to H2,
it'd better to use the prefix64-a for synthesizing the IPv6 address of H2.
If H1 want to initiate a communication to H3, it'd better to use the
prefix64-b for synthesizing the IPv6 address of H2. In the way, traffic
forwarding path is shorten by using different prefix64 for different IPv4
destination hosts. That can also be used for traffic-engineering purpose
according to the correspondents' IPv4 addresses (i.e., using corresponding
prefix64 according to the IPv4 address of the correspondent). I wonder
whether using the same WKP on these NAT64 boxes can achieve the same goal.

Xiaohu

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 28 Dec 2009 07:40:15 -0800

> -----Original Message-----
> From: Xu Xiaohu [mailto:[email-masked]] 
> Sent: Wednesday, December 23, 2009 10:37 PM
> To: 'Christian Huitema'; 'Dan Wing'; 'marcelo bagnulo braun'
> Cc: [email-masked]
> Subject: re: [BEHAVE] Reason(s) for Modified EUI-64 format to 
> apply to ALLnon-0::/3 IPv6 addresses ?
> 
> 
> 
> > -----邮件原件-----

No, that would require the WKP to be advertised as a route on the public
Internet.

-d