Subject: Re: [BEHAVE] SIPNAT documents posted

From: Dave Thaler <[email-masked]>
Date: Sat, 12 Dec 2009 02:48:59 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Charles E. Perkins
> Sent: Monday, October 19, 2009 2:16 PM
> To: [email-masked]
> Subject: [BEHAVE] SIPNAT documents posted
> 
> 
> Hello folks,
> 
> At 1:59:30pm Pacific Time today, I posted the following draft:
>     "Payload-assisted Delivery for SIPNAT"
>     http://www.ietf.org/internet-drafts/draft-perkins-behave-dpinat-
> 00.txt
> 
> There is also a revision to the base SIPNAT document:
>     "Translating IPv4 to IPv6 based on source IPv4 address"
>     http://www.ietf.org/internet-drafts/draft-perkins-sourceipnat-
> 01.txt
> 
> Comments are appreciated.  Thanks to those who have helped
> me to improve these documents before submission.
> 
> Regards,
> Charlie P.

Two comments:

1) The documents do not address the problem whereby some recursive
   resolvers (aka DNS servers) used by clients cache answers for
   some time (like 30 seconds) even if the record TTL is less.
   Multiple clients can get the same answer and only the first one
   will work and the rest will break.

2) In the dpinat document, it discusses using the HTTP GET in the
   NAT for demultiplexing.  However, it can't get an HTTP GET until
   after a TCP connection is established, which means it would need
   to terminate the TCP connections itself and act more like an
   HTTP proxy rather than a NAT.  (Which is what is discussed in
   http://tools.ietf.org/html/draft-wing-behave-http-46-relay)

-Dave

---

From: Zhen Cao <[email-masked]>
Date: Mon, 21 Dec 2009 14:10:36 +0800

Hi all,

I also have one comment. In the example of the draft, fooNS (name server for
foo.net) needs to contact the NAT box to get an IPv4 address. But the fooNS
may not know the address of the NAT box. There might be multiple NAT boxes,
but only one name server for the foo.net. The name server does not know
which NAT box to contact and get the address.

Thanks,
Zhen
On Sat, Dec 12, 2009 at 10:48 AM, Dave Thaler <[email-masked]> wrote:

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>