Subject: [BEHAVE] Translating code of ICMPv4 Parameter Problem (Type 12)

From: Kentaro Ebisawa <[email-masked]>
Date: Thu, 10 Dec 2009 17:54:07 +0900

Hi,

draft-ietf-behave-xlate-04 [Page 14] says to translate ICMPv4 Type 12
(Parameter Problem) to ICMPv6 Type 4, but there are nothing mentioned
about the Code to use.

 | Parameter Problem (Type 12)  Set the Type field to 4.  The
 |    Pointer needs to be updated to point to the corresponding
 |    field in the translated include IP header.

It would be helpfull if we can clearly mention what code to use.

Looking below, maybe we can translate all v4 codes to 0 ?

Codes for ICMPv4 Type 12 :
 0 - Pointer indicates the error
 1 - Missing a Required Option
 2 - Bad Length

Codes for ICMPv6 Type 4 :
 0 - Erroneous header field encountered
 1 - Unrecognized Next Header type encountered
 2 - Unrecognized IPv6 option encountered

Regards,
-- 
Kentaro Ebisawa <[email-masked]>, Skype: ebiken-skype

---

From: Xing Li <[email-masked]>
Date: Mon, 14 Dec 2009 22:31:03 +0800

Kentaro Ebisawa 写道:

Thanks. We will present your comments in the interim meeting and try to 
get consensus. xing